cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

3562
Views
5
Helpful
18
Replies
Highlighted
Beginner

Dialer Interface - High Total Output Drops

Hi,

Can someone give me some links to Dialer Interface info?

I have some issues with my Dialer 1, having lots of Total drops.

My internet connection is broadband (10 Mbps) using fiber,

interface Dialer1

description *** DIALER-1 GROUP-11 POOL-111 ***$FW_OUTSIDE$

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip flow ingress

ip nat outside

ip virtual-reassembly max-reassemblies 512

zone-member security ZONE-3

encapsulation ppp

ip tcp adjust-mss 1460

dialer pool 111

dialer idle-timeout 0

dialer persistent

dialer-group 11

ppp authentication chap pap callin

ppp chap hostname xxxx

Here's the output:

ISR2811#sh int dialer 1

Dialer1 is up, line protocol is up (spoofing)

  Hardware is Unknown

  Description: *** DIALER-1 GROUP-11 POOL-111 ***$FW_OUTSIDE$

  Internet address is 2xx.xx.xx.161/32

  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 8/255

  Encapsulation PPP, loopback not set

  Keepalive set (10 sec)

  DTR is pulsed for 1 seconds on reset

  Interface is bound to Vi3

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 2w2d

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 56468

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/16 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 42 kilobits/sec

  5 minute input rate 58000 bits/sec, 1 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     29068998 packets input, 1586452367 bytes

     15238816 packets output, 18446744072203736053 bytes

Bound to:

Virtual-Access3 is up, line protocol is up

  Hardware is Virtual Access interface

  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 4/255, rxload 8/255

  Encapsulation PPP, LCP Open

  Listen: CDPCP

  Open: IPCP

  PPPoE vaccess, cloned from Dialer1

  Vaccess status 0x44, loopback not set

  Keepalive set (10 sec)

  Interface is bound to Di1 (Encapsulation PPP)

  Last input 00:00:05, output never, output hang never

  Last clearing of "show interface" counters 2w2d

  Input queue: 0/75/1/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 58000 bits/sec, 1 packets/sec

  5 minute output rate 1000 bits/sec, 1 packets/sec

     29228665 packets input, 1588587279 bytes, 1 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     15238850 packets output, 2789157092 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

==================================================

Virtual-Access1            unassigned      YES unset  down                  dow

Virtual-Access2            unassigned      YES unset  up                    up

Virtual-Access3            unassigned      YES unset  up                    up

Dialer1                    2xx.xxx.xxx161   YES IPCP   up                    up

Question:

1 - Why is there 3 Virtual Access?

2- Virtual Access 3 is bound to dialer 1, what about VA2 and VA1?

Thanks again.

Everyone's tags (4)
18 REPLIES 18
Beginner

Dialer Interface - High Total Output Drops

Hi,

Anyone can shed some light?

TQ

Beginner

Dialer Interface - High Total Output Drops

cheonghomtai,

Can we see your full configuration and not just the parts you have shown to better locate the problem.

Abdullah,


Beginner

Dialer Interface - High Total Output Drops

Here's the LAN and WAN subinterface:

interface FastEthernet0/0

description OFFICE-LAN1$FW_INSIDE$

no ip address

duplex auto

speed auto

interface FastEthernet0/0.1

description *** VLAN 1 ***

encapsulation dot1Q 1 native

ip address 192.168.100.254 255.255.255.0

ip nbar protocol-discovery

ip flow ingress

ip nat inside

ip virtual-reassembly max-reassemblies 128

zone-member security ZONE-1

ipv6 address XXXX

ipv6 enable

service-policy input XXX_POLICY

!

interface FastEthernet0/0.200

description *** VLAN 200 ***

encapsulation dot1Q 200

ip address 192.168.200.254 255.255.255.0

ip nbar protocol-discovery

ip flow ingress

ip nat inside

ip virtual-reassembly

zone-member security ZONE-1

interface FastEthernet0/1

description Going To BTU

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

duplex auto

speed auto

no mop enabled

interface FastEthernet0/1.500

description ** VLAN-500 DATA **

encapsulation dot1Q 500

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

pppoe enable group global

pppoe-client dial-pool-number 111

interface Dialer1

description *** DIALER-1 GROUP-11 POOL-111 ***$FW_OUTSIDE$

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip flow ingress

ip nat outside

ip virtual-reassembly max-reassemblies 512

zone-member security ZONE-3

encapsulation ppp

ip tcp adjust-mss 1460

dialer pool 111

dialer idle-timeout 0

dialer persistent

dialer-group 11

ppp authentication chap pap callin

ppp chap hostname xxxx

Hall of Fame Master

Dialer Interface - High Total Output Drops

And which router and IOS is this ?

Beginner

Dialer Interface - High Total Output Drops

Its a 2811 ISR router.

System image file is "flash:c2800nm-adventerprisek9-mz.124-22.T.bin"

Beginner

Dialer Interface - High Total Output Drops

Hi,

Answers inline:

1 - Why is there 3 Virtual Access?

Think of dialer interface as a template from which virtual-access interfaces get created "on demand" i.e. whenever there is a traffic being sent out or received.

2- Virtual Access 3 is bound to dialer 1, what about VA2 and VA1?

What this means is that VA2 & VA1 like VA3 was used earlier for traffic passing. Sometimes, more than 1 virtual access interfaces are created when the traffic flow is between two different endpoints traversing the router. If you want to know whether any VA interface is being used or not, check "show interface va<>". In the output you if you see something like "PPPoE vaccess, cloned from Dialer1" then it indicates this particular VA is being used currently. If a VA is not being used anymore by the router, you will not see "PPPoE vaccess, cloned from Dialer1" there.

As for the output drops, i see that the counter was cleared more than 2 weeks ago, try clearing the counters "clear counters" and monitor this output differnt times of the day to asertain whether the output drop is incrementing all the time or only during certain hours of the day and let us know. Also past the 'show interface

Regards,

Subeh

Beginner

Dialer Interface - High Total Output Drops

Hi Subeh,

Thanks for the comprehensive answers.

Now i know why few VA are generated based on traffic.

As for the counters, yes i have cleared 2 wks ago.

But it seems like its incrementing all the time, and i don't see any pattern at all.

The dialer 1 is bounded to the sub-int FA0/1.500

ISR2811#sh  int fa0/1.500

FastEthernet0/1.500 is up, line protocol is up

  Hardware is MV96340 Ethernet, address is 0018.ba0a.6cf1 (bia 0018.ba0a.6cf1)

  Description: ** VLAN-500 DATA **

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  500.

  ARP type: ARPA, ARP Timeout 04:00:00

  Last clearing of "show interface" counters never

ISR2811#sh  int fa0/1

FastEthernet0/1 is up, line protocol is up

  Hardware is MV96340 Ethernet, address is 0018.ba0a.6cf1 (bia 0018.ba0a.6cf1)

  Description: Going To UNIFI BTU

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/43/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 12000 bits/sec, 12 packets/sec

  5 minute output rate 9000 bits/sec, 8 packets/sec

     164946397 packets input, 2889581039 bytes

     Received 31499799 broadcasts, 0 runts, 0 giants, 4 throttles

     3745 input errors, 5 CRC, 2002 frame, 0 overrun, 1738 ignored

     0 watchdog

     0 input packets with dribble condition detected

     82235932 packets output, 2732695477 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Thanks!

Hom

Beginner

Dialer Interface - High Total Output Drops

Hom,

Can you check if the rate of traffic being sent out from the dialer inteface is under the subscibed rate you got from the ISP? Becuase the 'Total Output drop' counter shows packets which are dropped either due to any/all of the following:

- The output rate being higher than the physical link subscribed rate.

- Failing hardware.

- IOS issue.

I see you've ZBF configured under dialer interface. Is it possibel for you to remove it for testing and then check if somehow the ZBF policy is interfering with the traffic?

Regards,

Subeh

Beginner

Dialer Interface - High Total Output Drops

Hi Subeh,

Here's the latest update which I cleared this morning:

Dialer1 is up, line protocol is up (spoofing)

Hardware is Unknown

Description: *Dialer-1 Grp-11 Pool-111

Internet address is 219.92.xx.xx/32

MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

    reliability 255/255, txload 227/255, rxload 1/255

Encapsulation PPP, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 1 seconds on reset

Interface is bound to Vi3

Last input never, output never, output hang never

Last clearing of "show interface" counters 07:39:11

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1033

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

    Conversations  0/0/16 (active/max active/max total)

    Reserved Conversations 0/0 (allocated/max allocated)

    Available Bandwidth 42 kilobits/sec

5 minute input rate 0 bits/sec, 1 packets/sec

5 minute output rate 50000 bits/sec, 1 packets/sec

    729057 packets input, 522790776 bytes

    430683 packets output, 95170678 bytes

ISR2811#sh int virtual-access 2

Virtual-Access2 is up, line protocol is up

  Hardware is Virtual Access interface

  MTU 1492 bytes, BW 100000 Kbit/sec, DLY 100000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP Closed

  Base PPPoE vaccess

  Vaccess status 0x44, loopback not set

  DTR is pulsed for 5 seconds on reset

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 13w5d

  Input queue: 0/4096/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

As for the BWidth - its 10Mbps line.

Is this the correct way to identify the speed of the line?

For the ZBF, i think that shouldn't be an issue coz i have another 1841 with similiar ZBF but no drops output.

I can only remove the ZBF when no users are around - during the weekend.

Beginner

Dialer Interface - High Total Output Drops

Here's my other Router:

System image file is "flash:c1841-adventerprisek9-mz.151-4.M.bin"

1841#sh int dialer 1

Dialer1 is up, line protocol is up (spoofing)

  Hardware is Unknown

  Description: *Dialer-1 Grp-11 Pool-111

  Internet address is 175.xx.xx.xx/32

  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 255/255, rxload 255/255

  Encapsulation PPP, LCP Closed, loopback not set

  Keepalive set (10 sec)

  DTR is pulsed for 1 seconds on reset

  Interface is bound to Vi2

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 13w5d

  Input queue: 0/75/16723/0 (size/max/drops/flushes); Total output drops: 25

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/0/16 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 42 kilobits/sec

  5 minute input rate 1699000 bits/sec, 230 packets/sec

  5 minute output rate 548000 bits/sec, 162 packets/sec

     804444333 packets input, 2600720886 bytes

     606586814 packets output, 3251055407 bytes

Bound to:

Virtual-Access2 is up, line protocol is up

  Hardware is Virtual Access interface

  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 255/255, rxload 255/255

  Encapsulation PPP, LCP Open

  Stopped: CDPCP

  Open: IPCP

  PPPoE vaccess, cloned from Dialer1

  Vaccess status 0x44, loopback not set

  Keepalive set (10 sec)

  Interface is bound to Di1 (Encapsulation PPP)

  Last input 00:00:00, output never, output hang never

  Last clearing of "show interface" counters 09:34:17

  Input queue: 0/75/16/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1697000 bits/sec, 231 packets/sec

  5 minute output rate 565000 bits/sec, 190 packets/sec

     10075877 packets input, 2875107193 bytes, 16 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     7446225 packets output, 1194558143 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

I noticed the input queue DROP size is huge.

I hv read that its not a gd idea to tweak any of it - which can cause timout + TCP retransmit flooding in.

Any thoughts are welcome?

Beginner

Dialer Interface - High Total Output Drops

Hi,

for your 2811, i don't think the virtual-access2 you pasted is the one which is being used becuase in show interface virtual-access 2 , i don't see the statement, " PPPoE vaccess, cloned from Dialer1" so it can't be the right one. But moving ahead, do this, under dialer interface, configure 'output hold-queue 400' and then see if it improves the situation.

You're right in saying that tweaking the hold-queue can have impact of the traffic flow but it is only if you increase it to, say, 1500 or more. You can try putting the value of the queue from 400 to 800 for checking any improvement.

Regards,

Subeh

Beginner

Dialer Interface - High Total Output Drops

I found this document which applies to both your router's problem. Let me know if the suggestions mentioned it provides some improvements:

http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a0080094791.shtml

Regards,

Subeh

Beginner

Dialer Interface - High Total Output Drops

Funny, 2811 got 3 VA. 1841 has 2 instead.

Somehow the bandwidth is tied to VAx?

2811 is VA3

Virtual-Access3 is up, line protocol is up

  Hardware is Virtual Access interface

  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

    reliability 255/255, txload 4/255, rxload 1/255

1841 is VA2

Virtual-Access2 is up, line protocol is up

  Hardware is Virtual Access interface

  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 255/255, rxload 255/255

Ok - will try out the out hold-queue values.

TQ

Beginner

Dialer Interface - High Total Output Drops

Hi,

VAs are created on demand and nothing to do with the bandwidth of the link. Give it some time and you'll see on 1841 more numbers of VAs, provided the ones which were created are not deleted automatically due to inactivity. Anyways, even if a VA is being shown in 'show ip int brief' and not being used, it'd not matter becuase as its a virtual interface, it wil not consume any memory or CPU cycles.

Regards,

Subeh

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here