cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
3093
Views
0
Helpful
5
Replies

Dialer PPPOE / I can't access internet / Help

I can't access internet through the router

Could someone help get ip, but not out to internet

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

load-interval 30

dialer pool 1

dialer idle-timeout 0

dialer persistent

ppp chap hostname itestet@terra.com

ppp chap password 7 000000087817878242E30

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 Dialer1 name TESTE

=====

Interface                  IP-Address      OK? Method Status                Protocol

Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down

GigabitEthernet0/0         192.168.5.33    YES NVRAM  up                    up

GigabitEthernet0/1          unassigned      YES NVRAM  up                    up

Dialer1                           201.67.111.65   YES IPCP   up                    up

Virtual-Access1               unassigned      YES unset  up                    up

Virtual-Access2               unassigned      YES unset  up                    up

====

Lima#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1

S     128.70.0.0/16 [1/0] via 192.168.107.214

      192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.5.32/28 is directly connected, GigabitEthernet0/0

L        192.168.5.33/32 is directly connected, GigabitEthernet0/0

      192.168.107.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.107.192/27 is directly connected, GigabitEthernet0/0

L        192.168.107.193/32 is directly connected, GigabitEthernet0/0

      200.204.210.0/32 is subnetted, 1 subnets

C        200.204.210.248 is directly connected, Dialer1

      201.67.111.0/32 is subnetted, 1 subnets

C        201.67.111.65 is directly connected, Dialer1

=====

show pppoe  session

     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State

           SID  LocMAC                                      VA-st      Type

    N/A   1622  0090.1aa0.3275  Gi0/1                  Di1  Vi2        UP

                30f7.0d45.91a1                              UP

====

#traceroute 8.8.8.8

Type escape sequence to abort.

Tracing the route to 8.8.8.8

VRF info: (vrf in name/id, vrf out name/id)

  1  *  *  *

  2  *  *  *

  3  *  *  *

5 REPLIES 5
Beginner

Dialer PPPOE / I can't access internet / Help

Hi Rodrigo,

Shut the dialer interface and please get the output of the following:

-'debug ppp negotiation'

- 'debug pppoe event'

After you enable the above, no shut the dialer and collect the logs for about 10-20 seconds. Then disable the logs by 'undebug all'

Regards,

Subeh

Participant

Dialer PPPOE / I can't access internet / Help

Hi Rodrigo,

your pppoe connection is established so debug ppp is not needed:

Dialer1                           201.67.111.65   YES IPCP   up                    up

Besides, your default route is to Dialer1:

S*    0.0.0.0/0 is directly connected, Dialer1

I do not know if your router still has ip address 201.67.111.65 but I can ping it:

ping 201.67.111.65

PING 201.67.111.65 (201.67.111.65) 56(84) bytes of data.

64 bytes from 201.67.111.65: icmp_req=1 ttl=40 time=330 ms

64 bytes from 201.67.111.65: icmp_req=2 ttl=40 time=329 ms

64 bytes from 201.67.111.65: icmp_req=3 ttl=40 time=329 ms

Please, can you post the "ping 8.8.8.8 source dialer1" output?.

Regards.

Beginner

Dialer PPPOE / I can't access internet / Help

I have this probelm too

I'm currently having an issue getting an internet conection on a cisco 881 router. I can get a WAN IP on Dialer 1 but i cant ping the dialer interface or any www addresses (e.g 8.8.8.8). Can any one see from the below config where the issue might be?? the conection is PPPOE with PAP authentication.

In the config you will see cellular 0 configed. That works fine and i have it shut down.

Thanks

Current configuration : 2140 bytes

!

! Last configuration change at 02:38:55 UTC Fri Jan 10 2014

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

memory-size iomem 10

crypto pki token default removal timeout 0

!

!

ip source-route

!

!

!

!

!

ip cef

ip name-server 139.130.4.4

no ipv6 cef

!

!

multilink bundle-name authenticated

vpdn enable

!

chat-script INTERNET ""ATDT*98*4# TIMEOUT 60 "CONNECT"

license udi pid CISCO881G-K9 sn FHK1451758Y

!

!

!

!

!

!

controller Cellular 0

!

!

!

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

no ip address

duplex auto

speed auto

pppoe-client dial-pool-number 2

!

interface Cellular0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

shutdown

dialer in-band

dialer string INTERNET

dialer-group 1

async mode interactive

ppp chap refuse

ppp pap sent-username XXXXXX password 0 XXXXXX

!

interface Vlan1

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 2

dialer idle-timeout 0

dialer persistent

dialer-group 2

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username XXXXXX password 0 XXXXXX

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip nat inside source list 1 interface Cellular0 overload

ip nat inside source list 2 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Cellular0 10

!

logging esm config

access-list 1 permit any

access-list 2 permit any

dialer-list 1 protocol ip list 1

dialer-list 2 protocol ip list 2

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line 3

exec-timeout 0 0

script dialer INTERNET

login

modem InOut

no exec

transport input all

transport output all

speed 237000

line vty 0 4

login

transport input all

!

End

ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

Cellular0                  unassigned      YES NVRAM  administratively down down

Dialer1                    144.131.219.241 YES IPCP   up                    up

FastEthernet0              unassigned      YES unset  up                    up

FastEthernet1              unassigned      YES unset  up                    down

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    down

FastEthernet4              unassigned      YES NVRAM  up                    up

NVI0                       unassigned      YES unset  administratively down down

Virtual-Access1            unassigned      YES unset  up                    up

Vlan1                      192.168.1.254   YES NVRAM  up                    up

Router#show pppoe session

     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State

           SID  LocMAC                                      VA-st      Type

    N/A   2692  0090.1a42.b2bd  Fa4                    Di1  Vi1        UP

                e05f.b99c.1d96                              UP

Advisor

Dialer PPPOE / I can't access internet / Help

Hi,

Can you try this:

ip access-list standard NAT

permit 192.168.1.0 0.0.0.255

route-map NAT-Dialer

match ip add NAT

match interface dialer 1

route-map NAT-Cellular

match ip add NAT

match interface Cellular0

no ip nat inside source list 1 interface Cellular0

no ip nat inside source list 2 interface dialer1

ip nat inside source route-map NAT-Cellular interface Cellular0

ip nat inside source route-map NAT-Dialer interface dialer1

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted
Beginner

Re: Dialer PPPOE / I can't access internet / Help

Can you please try to perform following:-

1. Remove the highlighted command:-

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside  --- remove the command for testing purpose.

ip virtual-reassembly in

encapsulation ppp

dialer pool 2

dialer idle-timeout 0

dialer persistent

dialer-group 2

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username XXXXXX password 0 XXXXXX

2. After removing the command , please run "clear interface dialer1", this command will initiate a new PPP session.

3. wait for some time to establish a session , once new ip address will be assigned , now try to ping 4.2.2.2 , 8.8.8.8,4.2.2.3 and see if that works.

The reason why i am saying to remove the command is because when we try to NAT whole subnet(ip any any ) defined in ACL 1 , it might create issues to the ICMP/Telnet traffic.Alternatively you can define the local subnet(permit ip x.x.x.x y.y.y.y) in the access-list if you don't want to remove the command.

Hope this would be helpful:-

https://supportforums.cisco.com/message/4135617#4135617


CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards