cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

184
Views
0
Helpful
2
Replies
Beginner

Dialup PPP problem

Below is the conig for a demonstration Remote Access Server which has PPPoE setup for broadband access via GigabitEthernet0/1 which works fine and a connection into the core network via GigabitEthernet 0/0.

We are trying to setup dial in narrowband PPP access using the modem card in EHWIC slot 0 but are having routing issues with it.

The dial in client obtains an IP address from the pool fine and knows the IP of the RAS correctly but neither can ping each other.

 

Below is the running config together with the output from show ip route and show line 0/0/0 and show int async 0/0/0

Can anyone please help me understand whats wrong here, it seems to be the same as the examples Ive looked at.

Thanks

 

Config:

username sub101-1 password 0 pass
username sub103-1 password 0 pass
!
!
!
!
!
bba-group pppoe ISP_101_GROUP
 virtual-template 1
!
!
interface Loopback0
 ip address 10.3.255.254 255.255.0.0
!
interface GigabitEthernet0/0
 ip address 192.168.154.252 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 pppoe enable group ISP_101_GROUP

interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Virtual-Template1
 ip address 10.1.255.254 255.255.0.0
 peer default ip address pool ISP_101_POOL
 ppp authentication chap callin
!
interface Group-Async3
 ip unnumbered Loopback0
 encapsulation ppp
 peer default ip address pool ISP_103_POOL
 async mode dedicated
 no keepalive
 ppp authentication chap dialin
 group-range 0/0/0 0/0/1
!
ip local pool ISP_101_POOL 10.1.0.1 10.1.255.199
ip local pool ISP_103_POOL 10.3.0.1 10.3.255.199
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.154.254
line con 0
line aux 0
line 0/0/0 0/0/1
 login local
 modem Dialin
 autoselect ppp
 stopbits 1
 speed 115200
 flowcontrol hardware
line vty 0 4
 login
!
scheduler allocate 20000 1000
end


show int async 0/0/0
Async0/0/0 is up, line protocol is up
  Hardware is WIC Integrated Modem
  Interface is unnumbered. Using address of Loopback0 (10.3.255.254)
  MTU 1500 bytes, BW 115 Kbit/sec, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP, loopback not set
  .....



show line 0/0/0
   Tty Line Typ     Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise Overruns  Int
A 0/0/0    3 TTY 115200/115200- DialIn    -    -    -    14      0    0/0      -

Line 0/0/0, Location: "PPP: 10.3.0.14", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
Status: Ready, Active, No Exit Banner, Async Interface Active
  HW PPP Support Active, CTS Raised, 0x400000
Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
  Modem RI is CD, Line is permanent async interface,
  Get Modem Info Enabled, WIC Modem
Modem state: Ready
Line is running PPP for address 10.3.0.14.
9 output packets queued, 1 input packets.
 Async Escape map is 00000000000000000000000000000000
Modem hardware state: CTS DSR  DTR RTSModem Registers (0x10000000)- IMR:0x0 LED:0x2 RstCntrl:0x0 MSR:0x6F

Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                ^^x    none   -     -       none
Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
               00:10:00        never                        none     not set
                            Idle Session Disconnect Warning




#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is 192.168.154.254 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.154.254
      10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        10.1.0.0/16 is directly connected, Virtual-Access1.1
C        10.1.0.1/32 is directly connected, Virtual-Access1.1
L        10.1.255.254/32 is directly connected, Virtual-Access1.1
C        10.3.0.0/16 is directly connected, Loopback0
C        10.3.0.14/32 is directly connected, Async0/0/0
L        10.3.255.254/32 is directly connected, Loopback0
      192.168.154.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.154.0/24 is directly connected, GigabitEthernet0/0
L        192.168.154.252/32 is directly connected, GigabitEthernet0/0




 

 

2 REPLIES 2
Highlighted
Beginner

Re: Dialup PPP problem

To clarify I cant ping 10.3.0.14 from the RAS  and I cant ping 10.3.255.254 from the client.

Below is the log from the client (a Mac using the built in Mac OS X PPP/dial up software and modem)

 

Modem Reliable Link Established.
Modem Compression Established.
Communicating at 33600 bps.
Connect: ppp0 <--> /dev/cu.modem
local  IP address 10.3.0.14
remote IP address 10.3.255.254

Serial link appears to be disconnected.
Modem hangup
Connection terminated.

Re: Dialup PPP problem

Same problem here, tried to setup dial in for remote access to a router via a phone line using the above method. 

Modem connects fine Windows PC Received IP but cannot Ping/Connect to the Router or the Other Way round. Any idea why this is not working ?.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here