cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
364
Views
0
Helpful
0
Replies

DMVPN Dual HUB issue - 1 tunnel dual nhs scenario

Cas_CCIE#60232
Beginner
Beginner

hello forum guys,

 

I try to crate dual hub scenario in the lab environment. Spoke 1 register fine with hub 1 and hub 2, spoke 2 register fine but I can cot ping tunnel IP addresses hub 1 and hub2.

 

Topology: 

Dual Hub scenarioDual Hub scenario

Here is config:

 

HUB1:

 

 

interface Tunnel1
ip address 10.1.123.1 255.255.255.0
no ip redirects
ip mtu 1400
ip rip advertise 10
ip nhrp map multicast dynamic
ip nhrp map 10.1.123.4 150.160.0.4
ip nhrp map multicast 150.160.0.4
ip nhrp network-id 101
no ip split-horizon
tunnel source FastEthernet1/0.101
tunnel mode gre multipoint
end
 
Interface: Tunnel1, IPv4 NHRP Details
Type:Hub/Spoke, NHRP Peers:3,
 
 
# Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
     1 150.160.0.2          10.1.123.2    UP 00:13:35     D
     1 150.160.0.3          10.1.123.3    UP 00:13:34     D
     1 150.160.0.4          10.1.123.4  NHRP    never     S

 

HUB2:

 

 

interface Tunnel2
ip address 10.1.123.4 255.255.255.0
no ip redirects
ip mtu 1400
ip rip advertise 10
ip nhrp map multicast dynamic
ip nhrp map 10.1.123.1 150.160.0.1
ip nhrp map multicast 150.160.0.1
ip nhrp network-id 101
no ip split-horizon
tunnel source FastEthernet1/0.101
tunnel mode gre multipoint
 
# Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
     1 150.160.0.1          10.1.123.1  NHRP    never     S
     1 150.160.0.2          10.1.123.2    UP 00:13:55     D
     1 150.160.0.3          10.1.123.3    UP 00:13:53     D

 

SPOKE 1:

 

 

interface Tunnel1
description DMVPN_Marriott primary tunnel
ip address 10.1.123.2 255.255.255.0
no ip redirects
no ip proxy-arp
ip mtu 1400
ip rip advertise 10
ip nhrp map 10.1.123.1 150.160.0.1
ip nhrp map multicast 150.160.0.1
ip nhrp map 10.1.123.4 150.160.0.4
ip nhrp map multicast 150.160.0.4
ip nhrp network-id 101
ip nhrp nhs 10.1.123.1
ip nhrp nhs 10.1.123.4
ip nhrp shortcut
tunnel source FastEthernet0/0.101
tunnel mode gre multipoint
 
Interface: Tunnel1, IPv4 NHRP Details
Type:Spoke, NHRP Peers:2,
 
 
# Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
     1 150.160.0.1          10.1.123.1    UP 00:13:55     S
     1 150.160.0.4          10.1.123.4    UP 00:13:55     S

 

Marriott_CTR_USA_Fre(config-if)#do ping 10.1.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
Marriott_CTR_USA_Fre(config-if)#do ping 10.1.123.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.123.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/16 ms

 

SPOKE 2:

 

 

interface Tunnel1
description DMVPN_Marriott primary tunnel
ip address 10.1.123.3 255.255.255.0
no ip redirects
no ip proxy-arp
ip mtu 1400
ip rip advertise 10
ip nhrp map 10.1.123.1 150.160.0.1
ip nhrp map multicast 150.160.0.1
ip nhrp map 10.1.123.4 150.160.0.4
ip nhrp map multicast 150.160.0.4
ip nhrp network-id 101
ip nhrp nhs 10.1.123.1
ip nhrp nhs 10.1.123.4
ip nhrp shortcut
tunnel source FastEthernet0/0.101
tunnel mode gre multipoint
 
Interface: Tunnel1, IPv4 NHRP Details
Type:Spoke, NHRP Peers:2,
 
 
# Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
     1 150.160.0.1          10.1.123.1    UP 00:13:54     S
     1 150.160.0.4          10.1.123.4    UP 00:13:54     S
 
Marriott_CTR_USA_Boy(config-if)#do ping 10.1.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.123.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Marriott_CTR_USA_Boy(config-if)#do ping 10.1.123.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.123.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

Any idea what have I missed 

0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: