cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
725
Views
0
Helpful
5
Replies
Highlighted
Beginner

DMVPN OSPF routes in database but not in routing table

Hi guys Im having an issue whereby my DMVPN has peered with my spokes and OSPF neighbors have formed adjacency but for some reason the routes are not showing on either end. When I look at the database I can see them but not in the respective routing tables. Below is my config.

 

Hub
interface Tunnel0
 ip vrf forwarding MPLS
 ip address 10.10.10.10 255.255.255.0
 no ip redirects
 ip mtu 1440
 ip nhrp authentication cisco123
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 ip nhrp holdtime 600
 ip nhrp server-only
 no ip mfib cef input
 no ip mfib cef output
 ip ospf network broadcast
 tunnel source GigabitEthernet0/3
 tunnel mode gre multipoint
 tunnel vrf MPLS
!         
router ospf 1 vrf MPLS
 router-id 192.168.99.3
 priority 2
 redistribute static subnets
 network 10.4.21.156 0.0.0.3 area 1.1.1.1
 network 10.10.10.0 0.0.0.255 area 2
 network 192.168.99.0 0.0.0.15 area 0
 neighbor 10.4.21.157
 default-information originate
Spoke

interface Tunnel0
 ip address 10.10.10.20 255.255.255.0
 no ip redirects
 ip mtu 1440
 ip nhrp authentication cisco123
 ip nhrp map multicast dynamic
 ip nhrp map multicast 172.16.1.1
 ip nhrp map 10.10.10.10 172.16.1.1
 ip nhrp network-id 1
 ip nhrp holdtime 300
 ip nhrp nhs 10.10.10.10
 ip nhrp shortcut
 ip nhrp redirect
 no ip mfib cef input
 no ip mfib cef output
 delay 1000
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint

!         
router ospf 1
 priority 0
 network 10.10.10.0 0.0.0.255 area 2
 network 192.168.15.0 0.0.0.255 area 2
Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Advocate

Re: DMVPN OSPF routes in database but not in routing table

Hi,

The issue is looking as network type at both ends.

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

5 REPLIES 5
Highlighted
Engager

Re: DMVPN OSPF routes in database but not in routing table

Hi,

could you post the output of "show ip ospf interface Tunnel0" from both routers?

(I'm particulary interested in the OSPF network types.) 

 

Regards,

Rolf

Highlighted
Beginner

Re: DMVPN OSPF routes in database but not in routing table

Hub

Tunnel0 is up, line protocol is up 
  Internet Address 10.10.10.10/24, Area 2, Attached via Network Statement
  Process ID 1, Router ID 192.168.99.3, Network Type BROADCAST, Cost: 1000
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1000      no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 192.168.99.3, Interface address 10.10.10.10
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:05
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/3, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 8, maximum is 8
  Last flood scan time is 0 msec, maximum is 1 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 192.168.15.1
  Suppress hello for 0 neighbor(s)
Spoke
Tunnel0 is up, line protocol is up 
  Internet Address 10.10.10.20/24, Area 2, Attached via Network Statement
  Process ID 1, Router ID 192.168.15.1, Network Type POINT_TO_POINT, Cost: 1000
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1000      no          no            Base
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 192.168.99.3
  Suppress hello for 0 neighbor(s)
Highlighted
Engager

Re: DMVPN OSPF routes in database but not in routing table

The network types point-to-point and broadcast are not compatible.

 

Unfortunately I'm not up-to-date about the current recommendations for OSPF network types in DMVPNs.

When you don't want to change the network type on the hub, you'll need to change it on the spoke to broadcast or NBMA (with timer adjustment and neighbor statement in this case).

Highlighted
VIP Mentor

Re: DMVPN OSPF routes in database but not in routing table

Hello

I agree with rolf,

 

Hub tunnel -  BROADCAST
spoke tunnel -POINT_TO_POINT,

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
VIP Advocate

Re: DMVPN OSPF routes in database but not in routing table

Hi,

The issue is looking as network type at both ends.

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post