cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

340
Views
0
Helpful
24
Replies
Beginner

DMVPN Phase 1 Hub to Spoke connection

Hi all,

 

Hopefully you can help me out. I'm trying to configure a DMVPN phase 1 Hub to Spoke connection (only mGRE and NHRP). On the hub my tunnel 0 interface is up/down and i'm unsure why. I've triple checked the tunnel config. (NBMA and tunnel IP's etc.) and it all looks good. I'm using a default route on the hub and spokes and have full connectivity site to site using the underlay network. I've added the relevant config. below :-

 

HUB

interface Tunnel0
ip address 10.1.1.1 255.255.255.0
no ip redirects
ip nhrp network-id 10
tunnel source 15.0.0.1
tunnel mode gre multipoint
!
interface Serial0/0
ip address 15.0.0.1 255.255.255.0
clock rate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0

 

SPOKE

interface Tunnel0
ip address 10.1.1.2 255.255.255.0
ip nhrp map 10.1.1.1 15.0.0.1
ip nhrp network-id 10
ip nhrp nhs 10.1.1.1
tunnel source 25.0.0.2
tunnel destination 15.0.0.1
!
interface Serial0/1
ip address 25.0.0.2 255.255.255.0
clock rate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/1

 

I'm not using any routing protocols, only default routes on the hub and spokes but (as mentioned above) have full connectivity yet still can't get the hub tunnel 0 to move from up/down. The spoke is looking good in terms of the tunnel 0 being up/up and output from sh ip nhrp.

 

Any help is much appreciated,

 

Sunny

24 REPLIES 24
VIP Advisor

Re: DMVPN Phase 1 Hub to Spoke connection

Had quick look on te Hub side,  hub is missing the nhs server command.

 

Hub :

 

inteface tunnelX

  ip nhrp nhs x.x.x.x

 

Also tweak the hold timer.

 

BB
*** Rate All Helpful Responses ***
VIP Mentor

Re: DMVPN Phase 1 Hub to Spoke connection

Hello,

 

in additio to the other post, I think you also need to map the multicast:

 

interface Tunnel0
ip address 10.1.1.2 255.255.255.0
ip nhrp map 10.1.1.1 15.0.0.1
ip nhrp map multicast 15.0.0.1
ip nhrp network-id 10
ip nhrp nhs 10.1.1.1
tunnel source 25.0.0.2
tunnel destination 15.0.0.1

Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Gents,

 

I applied the suggested config :-

 

HUB

interface Tunnel0
ip address 10.1.1.1 255.255.255.0
no ip redirects
ip nhrp network-id 10
ip nhrp holdtime 1
ip nhrp nhs 10.1.1.1
tunnel source 15.0.0.1
tunnel mode gre multipoint

 

SPOKE

interface Tunnel0
ip address 10.1.1.2 255.255.255.0
ip nhrp map 10.1.1.1 15.0.0.1
ip nhrp map multicast 15.0.0.1
ip nhrp network-id 10
ip nhrp holdtime 1
ip nhrp nhs 10.1.1.1
tunnel source 25.0.0.2
tunnel destination 15.0.0.1

 

Unfortunately issue still persists. Tunnel 0 on the HUB is still up/down :-

 

R1#sh ip int t 0
Tunnel0 is up, line protocol is down
Internet address is 10.1.1.1/24
Broadcast address is 255.255.255.255

 

R1#sh ip nhrp

<no output>

 

Any further suggestions?

 

Your help is greatly appreciated,

 

Sunny 

 

 

VIP Advisor

Re: DMVPN Phase 1 Hub to Spoke connection

Ok going back to basic question, do you have undelay reachability between Hub and Spoke ?

 

can you post full configuraiton of the bothe device and post any topology to understand.

 

show us the reachability with ping each other side.

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

 
Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

 
Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Full configs (with suggested config changes) attached.

Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Full configs with suggested config changes attached.

Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Topology

Highlighted
Enthusiast

Re: DMVPN Phase 1 Hub to Spoke connection

Hi,

 

Assuming that you have reachability on the physical interfaces, on both Hub and Spoke could you change the tunnel source to the physical interface.

 

If the tunnel comes up, you would also need to add ip nhrp map multicast dynamic under the Hub tunnel interface.

Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Applied but issue still persists.
Rising star

Re: DMVPN Phase 1 Hub to Spoke connection

from spoke

ping 15.0.0.1 source 25.0.0.2
Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Gents,

 

I have applied the latest suggestions to no avail. Issue still persists. As requested full configs :-

 

HUB

hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
!
ip audit po max-events 100
no ip domain lookup
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
ip address 10.1.1.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 10
ip nhrp nhs 10.1.1.1
tunnel source Serial0/0
tunnel mode gre multipoint
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 15.0.0.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet3/0
no ip address
shutdown
!
interface FastEthernet3/1
no ip address
shutdown
!
interface FastEthernet3/2
no ip address
shutdown
!
interface FastEthernet3/3
no ip address
shutdown
!
interface FastEthernet3/4
no ip address
shutdown
!
interface FastEthernet3/5
no ip address
shutdown
!
interface FastEthernet3/6
no ip address
shutdown
!
interface FastEthernet3/7
no ip address
shutdown
!
interface FastEthernet3/8
no ip address
shutdown
!
interface FastEthernet3/9
no ip address
shutdown
!
interface FastEthernet3/10
no ip address
shutdown
!
interface FastEthernet3/11
no ip address
shutdown
!
interface FastEthernet3/12
no ip address
shutdown
!
interface FastEthernet3/13
no ip address
shutdown
!
interface FastEthernet3/14
no ip address
shutdown
!
interface FastEthernet3/15
no ip address
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

 

SPOKE

hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
!
ip audit po max-events 100
no ip domain lookup
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Tunnel0
ip address 10.1.1.2 255.255.255.0
ip nhrp map 10.1.1.1 15.0.0.1
ip nhrp map multicast 15.0.0.1
ip nhrp network-id 10
ip nhrp nhs 10.1.1.1
tunnel source Serial0/1
tunnel destination 15.0.0.1
!
interface Tunnel1
no ip address
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 25.0.0.2 255.255.255.0
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet3/0
no ip address
shutdown
!
interface FastEthernet3/1
no ip address
shutdown
!
interface FastEthernet3/2
no ip address
shutdown
!
interface FastEthernet3/3
no ip address
shutdown
!
interface FastEthernet3/4
no ip address
shutdown
!
interface FastEthernet3/5
no ip address
shutdown
!
interface FastEthernet3/6
no ip address
shutdown
!
interface FastEthernet3/7
no ip address
shutdown
!
interface FastEthernet3/8
no ip address
shutdown
!
interface FastEthernet3/9
no ip address
shutdown
!
interface FastEthernet3/10
no ip address
shutdown
!
interface FastEthernet3/11
no ip address
shutdown
!
interface FastEthernet3/12
no ip address
shutdown
!
interface FastEthernet3/13
no ip address
shutdown
!
interface FastEthernet3/14
no ip address
shutdown
!
interface FastEthernet3/15
no ip address
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/1
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

R2#ping 15.0.0.1 source serial 0/1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.0.1, timeout is 2 seconds:
Packet sent with a source address of 25.0.0.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/24/28 ms
R2#ping 15.0.0.1 source serial 0/1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.0.1, timeout is 2 seconds:
Packet sent with a source address of 25.0.0.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/24/24 ms



R1#ping 25.0.0.2 source serial 0/0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 25.0.0.2, timeout is 2 seconds:
Packet sent with a source address of 15.0.0.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/24/24 ms
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here