11-24-2020 09:16 AM
I have done with my DMVPN Lab Phase I Configuration. I have found that Hub is able to learn routes of both spokes. But spoke is not able to learn route of other spoke(LAN).EIGRP enabled for Hub and spokes NBMA and LAN Networks.
Static default route is activated from hub and spoke towards SP Network. Please find below the topology image.
Please find below my config. on Hub and Spoke Routers.
Hub:R11
interface Tunnel100
bandwidth 4000
ip address 192.168.100.11 255.255.255.0
no ip redirects
ip mtu 1400
no ip split-horizon eigrp 100
ip nhrp network-id 100
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/1
tunnel mode gre multipoint
tunnel key 100
end
router eigrp DMVPN
address-family ipv4 unicast autonomous-system 100
topology base
exit-af-topology
network 10.0.0.0
network 192.168.100.0
exit-address-family
Spoke-1-R31
interface Tunnel100
bandwidth 4000
ip address 192.168.100.31 255.255.255.0
ip mtu 1400
ip nhrp network-id 100
ip nhrp nhs 192.168.100.11 nbma 172.16.11.1 multicast
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/2
tunnel destination 172.16.11.1
tunnel key 100
end
Spoke-R41
interface Tunnel100
bandwidth 4000
ip address 192.168.100.41 255.255.255.0
ip mtu 1400
ip nhrp map 192.168.100.11 172.16.11.1
ip nhrp map multicast 172.16.11.1
ip nhrp network-id 100
ip nhrp nhs 192.168.100.11
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/3
tunnel destination 172.16.11.1
tunnel key 100
end
Please find below the extract of some show commands from Hub and Spoke.
Hub-R11#sh ip rou | b Gate
Gateway of last resort is 172.16.11.2 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 172.16.11.2
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, GigabitEthernet0/0
L 10.1.1.11/32 is directly connected, GigabitEthernet0/0
D 10.3.3.0/24 [90/26885120] via 192.168.100.31, 13:53:31, Tunnel100
D 10.4.4.0/24 [90/26885120] via 192.168.100.41, 13:53:02, Tunnel100
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.11.0/24 is directly connected, GigabitEthernet0/1
L 172.16.11.1/32 is directly connected, GigabitEthernet0/1
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, Tunnel100
L 192.168.100.11/32 is directly connected, Tunnel100
Spoke-R31#sh ip route | b Gate
Gateway of last resort is 172.16.31.2 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 172.16.31.2
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.1.0/24 [90/26885120] via 192.168.100.11, 14:06:39, Tunnel100
C 10.3.3.0/24 is directly connected, GigabitEthernet0/0
L 10.3.3.31/32 is directly connected, GigabitEthernet0/0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.31.0/24 is directly connected, GigabitEthernet0/2
L 172.16.31.1/32 is directly connected, GigabitEthernet0/2
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, Tunnel100
L 192.168.100.31/32 is directly connected, Tunnel100
Hub-R11#sh ip nhrp
192.168.100.31/32 via 192.168.100.31
Tunnel100 created 14:08:17, expire 00:08:03
Type: dynamic, Flags: registered nhop
NBMA address: 172.16.31.1192.168.100.41/32 via 192.168.100.41
Tunnel100 created 14:07:53, expire 00:08:44
Type: dynamic, Flags: registered nhop
NBMA address: 172.16.41.1
Spoke-2-R41#sh ip nhrp
192.168.100.11/32 via 192.168.100.11
Tunnel100 created 14:09:40, never expire
Type: static, Flags:
NBMA address: 172.16.11.1
Spoke-1-R31#sh ip nhrp
192.168.100.11/32 via 192.168.100.11
Tunnel100 created 14:11:21, never expire
Type: static, Flags:
NBMA address: 172.16.11.1
Solved! Go to Solution.
11-24-2020 11:30 AM
Hello,
use the configs below. I had problems before with EIGRP address families and DMVPN.
Spoke-R41
interface Tunnel100
bandwidth 4000
ip address 192.168.100.41 255.255.255.0
ip mtu 1400
ip nhrp map 192.168.100.11 172.16.11.1
ip nhrp map multicast 172.16.11.1
ip nhrp network-id 100
ip nhrp nhs 192.168.100.11
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/3
tunnel destination 172.16.11.1
tunnel key 100
!
interface GigabitEthernet0/0
ip address 10.4.4.41 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
ip address 172.16.41.1 255.255.255.0
duplex auto
speed auto
media-type rj-45
!
router eigrp 100
network 10.0.0.0
network 192.168.100.0
!
ip route 0.0.0.0 0.0.0.0 172.16.41.2
Spoke-R31
interface Tunnel100
bandwidth 4000
ip address 192.168.100.31 255.255.255.0
ip mtu 1400
ip nhrp map 192.168.100.11 172.16.11.1
ip nhrp map multicast 172.16.11.1
ip nhrp network-id 100
ip nhrp nhs 192.168.100.11
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/2
tunnel destination 172.16.11.1
tunnel key 100
!
interface GigabitEthernet0/0
ip address 10.3.3.31 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
ip address 172.16.31.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
router eigrp 100
network 10.0.0.0
network 192.168.100.0
!
ip route 0.0.0.0 0.0.0.0 172.16.31.2
Hub-R11
interface Tunnel100
bandwidth 4000
ip address 192.168.100.11 255.255.255.0
no ip redirects
ip mtu 1400
no ip split-horizon eigrp 100
ip nhrp network-id 100
ip nhrp map multicast dynamic
ip summary-address eigrp 100 10.0.0.0 255.0.0.0
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/1
tunnel mode gre multipoint
tunnel key 100
!
interface GigabitEthernet0/0
ip address 10.1.1.11 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 172.16.11.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
router eigrp 100
network 10.1.1.11 0.0.0.0
network 192.168.100.11 0.0.0.0
!
ip route 0.0.0.0 0.0.0.0 172.16.11.2
11-24-2020 09:56 AM
Try in EIGRP - no auto-summary
can you post full configuration - both HUB and Spoke to cross check other settings.
11-24-2020 11:03 AM
11-24-2020 11:51 AM
thanks for the config, looks like the trick advised was working making all classic mode rather mixing.
11-24-2020 10:27 AM
Hello,
make the changes marked in bold:
Hub:R11
interface Tunnel100
bandwidth 4000
ip address 192.168.100.11 255.255.255.0
no ip redirects
ip mtu 1400
no ip split-horizon eigrp 100
--> ip summary-address eigrp 100 10.0.0.0 255.0.0.0
--> ip nhrp map multicast
ip nhrp network-id 100
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/1
tunnel mode gre multipoint
tunnel key 100
end
!
--> router eigrp 100
--> network 10.0.0.0
--> network 192.168.100.0
Spoke-1-R31
interface Tunnel100
bandwidth 4000
ip address 192.168.100.31 255.255.255.0
ip mtu 1400
--> ip nhrp map 192.168.100.11 172.16.11.1
ip nhrp network-id 100
--> ip nhrp map multicast 172.16.11.1
--> ip nhrp nhs 192.168.100.11
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/2
tunnel destination 172.16.11.1
tunnel key 100
end
Spoke-R41
interface Tunnel100
bandwidth 4000
ip address 192.168.100.41 255.255.255.0
ip mtu 1400
ip nhrp map 192.168.100.11 172.16.11.1
ip nhrp map multicast 172.16.11.1
ip nhrp network-id 100
ip nhrp nhs 192.168.100.11
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/3
tunnel destination 172.16.11.1
tunnel key 100
end
11-24-2020 11:04 AM
I have changed the commands as you mentioned. But, it didn't work for me.
11-24-2020 11:13 AM
Hi,
Now i am able to ping other spoke and also summary route is added in Routing table.
But in CCNP Book i have found the explicit route for that network.Which command will change this behaviour.
The sh ip route excerpt from ccnp book for the spokes.
R31-Spoke# show ip route
! Output omitted for brevity
Gateway of last resort is 172.16.31.2 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 172.16.31.2
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D 10.1.1.0/24 [90/26885120] via 192.168.100.11, 23:04:48, Tunnel100
C 10.3.3.0/24 is directly connected, GigabitEthernet0/2
D 10.4.4.0/24 [90/52992000] via 192.168.100.11, 23:04:23, Tunnel100
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.31.0/30 is directly connected, GigabitEthernet0/1
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, Tunnel100
R41-Spoke# show ip route
! Output omitted for brevity
Gateway of last resort is 172.16.41.2 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 172.16.41.2
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D 10.1.1.0/24 [90/26885120] via 192.168.100.11, 23:05:01, Tunnel100
D 10.3.3.0/24 [90/52992000] via 192.168.100.11, 23:05:01, Tunnel100
C 10.4.4.0/24 is directly connected, GigabitEthernet0/2
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.41.0/24 is directly connected, GigabitEthernet0/1
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, Tunnel100
11-24-2020 11:30 AM
Hello,
use the configs below. I had problems before with EIGRP address families and DMVPN.
Spoke-R41
interface Tunnel100
bandwidth 4000
ip address 192.168.100.41 255.255.255.0
ip mtu 1400
ip nhrp map 192.168.100.11 172.16.11.1
ip nhrp map multicast 172.16.11.1
ip nhrp network-id 100
ip nhrp nhs 192.168.100.11
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/3
tunnel destination 172.16.11.1
tunnel key 100
!
interface GigabitEthernet0/0
ip address 10.4.4.41 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
ip address 172.16.41.1 255.255.255.0
duplex auto
speed auto
media-type rj-45
!
router eigrp 100
network 10.0.0.0
network 192.168.100.0
!
ip route 0.0.0.0 0.0.0.0 172.16.41.2
Spoke-R31
interface Tunnel100
bandwidth 4000
ip address 192.168.100.31 255.255.255.0
ip mtu 1400
ip nhrp map 192.168.100.11 172.16.11.1
ip nhrp map multicast 172.16.11.1
ip nhrp network-id 100
ip nhrp nhs 192.168.100.11
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/2
tunnel destination 172.16.11.1
tunnel key 100
!
interface GigabitEthernet0/0
ip address 10.3.3.31 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
ip address 172.16.31.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
router eigrp 100
network 10.0.0.0
network 192.168.100.0
!
ip route 0.0.0.0 0.0.0.0 172.16.31.2
Hub-R11
interface Tunnel100
bandwidth 4000
ip address 192.168.100.11 255.255.255.0
no ip redirects
ip mtu 1400
no ip split-horizon eigrp 100
ip nhrp network-id 100
ip nhrp map multicast dynamic
ip summary-address eigrp 100 10.0.0.0 255.0.0.0
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/1
tunnel mode gre multipoint
tunnel key 100
!
interface GigabitEthernet0/0
ip address 10.1.1.11 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 172.16.11.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
router eigrp 100
network 10.1.1.11 0.0.0.0
network 192.168.100.11 0.0.0.0
!
ip route 0.0.0.0 0.0.0.0 172.16.11.2
11-24-2020 11:42 AM
Thanks Georg,
Now it's working. Simply removed Named EIGRP Mode to classic mode and removed Ip summary address command from Hub Tunnel Interface.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide