cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

718
Views
0
Helpful
8
Replies
Highlighted
Beginner

DMVPN using 4g with dynamic public IP address

Hello,

 

We have a medium sized DMVPN network that is working fine in Phase 3.

 

We have a new site that is using 4g as its primary connection. Every 12 hours the public ip address of this 4g connection changes causing the tunnel to drop.

 

By adding this command on the spoke the tunnel re-connects after about 5 minutes:

 

ip nhrp registration no-unique

 

This is not really ideal and wondering if anyone has an understanding of how this can be made better.

 

Manually executing clear ip nhrp also fixes the problem but again not ideal.

 

Using a Cisco 881 running 15.4 for this spoke.

 

Any ideas or suggests?

 

Adam

Everyone's tags (4)
8 REPLIES 8
Highlighted
VIP Mentor

Re: DMVPN using 4g with dynamic public IP address

Hello,

 

you might want to try and set the 'ip nhrp registration timeout' on the spoke tunnel to the lowest value possible...

 

Can you post the configuration of your 881 ?

Highlighted
Beginner

Re: DMVPN using 4g with dynamic public IP address

Hello,

 

Thanks for the suggestion. I just tried that and it did not seem to make any difference. Looks as tho connectivity drops for around 30 minutes. Whats odd is that it does not seem to be off for a consistent amount of time. The router loses internet access for about 20 seconds when the public IP changes. Worth highlighting the public IP address is assigned to a device in front of our router and we receive an NAT'd ip.

 

Tunnel config:

interface Tunnel1
ip address INTERNAL IP
no ip redirects
ip mtu 1400
ip flow monitor NTA input
ip flow monitor NTA output
ip nhrp authentication EXAMPLE
ip nhrp map multicast PUBLIC IP
ip nhrp map INTERNAL IP PUBLIC IP
ip nhrp network-id 1
ip nhrp holdtime 30
ip nhrp nhs HUB IP
ip nhrp registration no-unique
ip nhrp registration timeout 10
ip tcp adjust-mss 1360
tunnel source FastEthernet4
tunnel mode gre multipoint
tunnel key 100
tunnel protection ipsec profile EXAMPLE shared

 

Thanks

Adam

Highlighted
VIP Mentor

Re: DMVPN using 4g with dynamic public IP address

Hello,

 

I have a feeling the problem is related to the 4G. Can you post the full configuration of your router ?

Highlighted
Beginner

Re: DMVPN using 4g with dynamic public IP address

Hi All,

I am trying to build a DMVPN tunnel in a Cisco 892 router connected to a 4g router. So far from the cisco router I can ping Hub public IP address, but the reverse is not working. I also enabled port forwarding in 4g router , but not sure if it is adding any value. The tunnel configs looks like below. Please let me know if I am missing anything or need any details.



interface Tunnel1

description Tunnel

bandwidth 10000





ip address z.z.z.z 255.255.255.0  //Z denotes Tunnel Ip address

no ip redirects

ip mtu 1400

ip pim sparse-dense-mode

ip nat outside

ip nhrp authentication cisco

ip nhrp map multicast x.x.x.x   //X denotes Public Ip address of Hub

ip nhrp map y.y.y.y x.x.x.x        //Y denotes Hub's tunnel Ip address

ip nhrp network-id 1000

ip nhrp holdtime 300

ip nhrp nhs y.y.y.y

ip nhrp registration no-unique

ip nhrp shortcut

ip nhrp redirect

ip virtual-reassembly in

ip tcp adjust-mss 1360

load-interval 30

delay 1000

tunnel source GigabitEthernet8

tunnel mode gre multipoint

end
Highlighted
VIP Mentor

Re: DMVPN using 4g with dynamic public IP address

Hello,

 

the spoke tunnel config looks ok. Post the config of the hub as well. Which routing (protocol) do you have configured ?

Highlighted
Beginner

Re: DMVPN using 4g with dynamic public IP address

I think the problem is in Natting. I tried to debug and found lot of things
related to Nat. I l post the same in a while. When we have to do Natting
outside the device ,anyone can tell me how to do in 4 g router?
Highlighted
VIP Mentor

Re: DMVPN using 4g with dynamic public IP address

Hello,

 

post the full confg of the 4G router as well as the 892 router (sh run). The tunnel is not used as NAT outside, you need to put the NAT outside on the ISP facing interface that has the public IP address...

Highlighted
Participant

Re: DMVPN using 4g with dynamic public IP address

Try contacting the provider and asking them to make the IP static.