cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
373
Views
0
Helpful
4
Replies
mhdganji110
Beginner

DMVPN with just one spoke, tunnel interface not reachable

Hi,

Please help me on this simple DMVPN configuration.

The HUB does not show the spoke, just the spoke shows the hub in show dmvpn

public IP's are reachable and pingable, tunnel becomes up after issuing commands but the tunnel IP cannot be pinged from the other side.

 

I think it's obvious but let's write it down here. Also let's add that a simple GRE tunnel works between them (on tunnel 101 which I shut it down after testing)

 

Many thanks in advance:

 

Hub Public IP : 172.17.125.84

Hub Tunnel IP (Tunnel0) : 172.29.1.1

 

Spoke Public IP and Interface : GigabitEthernet0/0.101 172.26.39.18

Spoke : Tunnel IP : 172.29.1.2

 

 

Hub

interface Tunnel0
ip address 172.29.1.1 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source 172.17.125.84
tunnel mode gre multipoint
end

 

 

Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 172.24.33.1 YES NVRAM up up
GigabitEthernet0/1 172.17.125.84 YES NVRAM up up
GigabitEthernet0/2 unassigned YES NVRAM administratively down down
Tunnel0 172.29.1.1 YES manual up up
Tunnel101 172.29.10.13 YES NVRAM administratively down down
Tunnel102 172.29.11.37 YES NVRAM administratively down down

-----------

 

 

Spoke

Spoke-RT(config-if)#do sh dmvpn
Interface: Tunnel0, IPv4 NHRP Details
Type:Spoke, NHRP Peers:1,

# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 172.17.125.84 172.29.1.1 NHRP 01:08:52 S

 

 

Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES NVRAM up up
GigabitEthernet0/0.101 172.26.39.18 YES NVRAM up up
GigabitEthernet0/1 172.30.101.1 YES NVRAM up up
Tunnel0 172.29.1.2 YES manual up up
Tunnel101 172.29.10.14 YES NVRAM administratively down down


interface Tunnel0
ip address 172.29.1.2 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp map 172.29.1.1 172.17.125.84
ip nhrp map multicast 172.17.125.84
ip nhrp network-id 1
ip nhrp nhs 172.29.1.1
tunnel source GigabitEthernet0/0.101
tunnel mode gre multipoint

1 ACCEPTED SOLUTION

Accepted Solutions

Hello again

My problem is solved just by adding tunnel key X.

I think it was not mandatory from IOS 12 and later..

 

 

View solution in original post

4 REPLIES 4
Georg Pauwen
VIP Expert

Hello,

 

what kind of routing (e.g. static/EIGRP/BGP) do you have confgured ? Post the full configs of both the hub and the spoke...

Tunnel key command missing ..

Hello again

My problem is solved just by adding tunnel key X.

I think it was not mandatory from IOS 12 and later..

 

 

View solution in original post

Hi,

 

   Tunnel key is not a GRE/mGRE/DMVPN requirement, regardless of the IOS. Tunnel key was invent to be able to properly assign a received GRE packet to its proper tunnel in certain designs: like when you have multiple P2P GRE tunnels with same source/destination, or multiple mGRE tunnels with same source (it can happen on a DMVPN hub or DMVPN spoke).

 

Regards,

Cristian Matei.