cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1020
Views
5
Helpful
2
Replies

DMZ-Link bandwidth is not changing the traffic countin the routing table

Hey guys

I'm dong INE labs and bumped into a wierd issue that .

I've configured the dmz-link bandwidtha nd the extended communities to be sent , I'm receiving the bandwidth in the BGP routes , however the routing table doesnt change the traffic share according to the available link bandwidth .

following is my configuration :

Rack1R6(config)#do sh run | sec bgp

router bgp 100

no synchronization

bgp log-neighbor-changes

bgp dmzlink-bw

network 155.1.146.0 mask 255.255.255.0

aggregate-address 155.1.0.0 255.255.0.0 summary-only

neighbor 54.1.1.254 remote-as 54

neighbor 54.1.1.254 dmzlink-bw

neighbor 155.1.67.7 remote-as 300

neighbor 155.1.146.1 remote-as 100

neighbor 155.1.146.1 send-community both

no auto-summary

Rack1R6(config)#

Rack1R6(config)#do sh ip bgp neigh 155.1.146.1 adver

BGP table version is 35, local router ID is 150.1.6.6

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 28.119.16.0/24   54.1.1.254                             0 54 i

*> 28.119.17.0/24   54.1.1.254                             0 54 i

*> 112.0.0.0        54.1.1.254               0             0 54 50 60 i

*> 113.0.0.0        54.1.1.254               0             0 54 50 60 i

*> 114.0.0.0        54.1.1.254               0             0 54 i

*> 115.0.0.0        54.1.1.254               0             0 54 i

*> 116.0.0.0        54.1.1.254               0             0 54 i

*> 117.0.0.0        54.1.1.254               0             0 54 i

*> 118.0.0.0        54.1.1.254               0             0 54 i

*> 119.0.0.0        54.1.1.254               0             0 54 i

r> 155.1.0.0        0.0.0.0                            32768 i

Rack1R6(config)#do sh ip bgp

BGP table version is 35, local router ID is 150.1.6.6

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

* i28.119.16.0/24   204.12.1.254             0    100      0 54 i

*>                  54.1.1.254                             0 54 i

* i28.119.17.0/24   204.12.1.254             0    100      0 54 i

*>                  54.1.1.254                             0 54 i

* i112.0.0.0        204.12.1.254             0    100      0 54 50 60 i

*>                  54.1.1.254               0             0 54 50 60 i

* i113.0.0.0        204.12.1.254             0    100      0 54 50 60 i

*>                  54.1.1.254               0             0 54 50 60 i

* i114.0.0.0        204.12.1.254             0    100      0 54 i

*>                  54.1.1.254               0             0 54 i

* i115.0.0.0        204.12.1.254             0    100      0 54 i

*>                  54.1.1.254               0             0 54 i

* i116.0.0.0        204.12.1.254             0    100      0 54 i

*>                  54.1.1.254               0             0 54 i

* i117.0.0.0        204.12.1.254             0    100      0 54 i

*>                  54.1.1.254               0             0 54 i

* i118.0.0.0        204.12.1.254             0    100      0 54 i

   Network          Next Hop            Metric LocPrf Weight Path

*>                  54.1.1.254               0             0 54 i

* i119.0.0.0        204.12.1.254             0    100      0 54 i

*>                  54.1.1.254               0             0 54 i

r i155.1.0.0        155.1.146.4              0    100      0 i

r>                  0.0.0.0                            32768 i

s> 155.1.146.0/24   0.0.0.0                  0         32768 i

*>i205.90.31.0      155.1.13.3               0    100      0 200 254 ?

*                   155.1.67.7                             0 300 200 254 ?

*>i220.20.3.0       155.1.13.3               0    100      0 200 254 ?

*                   155.1.67.7                             0 300 200 254 ?

*>i222.22.2.0       155.1.13.3               0    100      0 200 254 ?

*                   155.1.67.7                             0 300 200 254 ?

Rack1R6(config)#

######################## now R4 configuration

Rack1R4(config)#do sh run | sec bgp

router bgp 100

no synchronization

bgp log-neighbor-changes

bgp dmzlink-bw

network 155.1.146.0 mask 255.255.255.0

aggregate-address 155.1.0.0 255.255.0.0 summary-only

neighbor 155.1.45.5 remote-as 200

neighbor 155.1.45.5 route-map MATCH-54 out

neighbor 155.1.146.1 remote-as 100

neighbor 155.1.146.1 send-community both

neighbor 204.12.1.254 remote-as 54

neighbor 204.12.1.254 dmzlink-bw

no auto-summary

Rack1R4(config)#

Rack1R4(config)#do sh ip bgp summ

BGP router identifier 150.1.4.4, local AS number 100

BGP table version is 18, main routing table version 18

15 network entries using 1980 bytes of memory

18 path entries using 936 bytes of memory

9/7 BGP path/bestpath attribute entries using 1512 bytes of memory

3 BGP AS-PATH entries using 72 bytes of memory

1 BGP community entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

Bitfield cache entries: current 3 (at peak 5) using 96 bytes of memory

BGP using 4620 total bytes of memory

BGP activity 102/87 prefixes, 243/225 paths, scan interval 60 secs

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

155.1.45.5      4        200    8615    8640       18    0    0 07:38:02        3

155.1.146.1     4        100    8761    8668       18    0    0 00:14:34        3

204.12.1.254    4         54    8724    8595       18    0    0 07:38:02       10

Rack1R4(config)#do sh ip bgp

BGP table version is 18, local router ID is 150.1.4.4

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 28.119.16.0/24   204.12.1.254             0             0 54 i

*> 28.119.17.0/24   204.12.1.254             0             0 54 i

*> 112.0.0.0        204.12.1.254                           0 54 50 60 i

*> 113.0.0.0        204.12.1.254                           0 54 50 60 i

*> 114.0.0.0        204.12.1.254                           0 54 i

*> 115.0.0.0        204.12.1.254                           0 54 i

*> 116.0.0.0        204.12.1.254                           0 54 i

*> 117.0.0.0        204.12.1.254                           0 54 i

*> 118.0.0.0        204.12.1.254                           0 54 i

*> 119.0.0.0        204.12.1.254                           0 54 i

*> 155.1.0.0        0.0.0.0                            32768 i

s> 155.1.146.0/24   0.0.0.0                  0         32768 i

* i205.90.31.0      155.1.13.3               0    100      0 200 254 ?

*>                  155.1.45.5                             0 200 254 ?

* i220.20.3.0       155.1.13.3               0    100      0 200 254 ?

*>                  155.1.45.5                             0 200 254 ?

* i222.22.2.0       155.1.13.3               0    100      0 200 254 ?

   Network          Next Hop            Metric LocPrf Weight Path

*>                  155.1.45.5                             0 200 254 ?

Rack1R4(config)#do sh ip bgp neigh 155.1.146.1 adver

Rack1R4(config)#do sh ip bgp neigh 155.1.146.1 adver

BGP table version is 18, local router ID is 150.1.4.4

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 28.119.16.0/24   204.12.1.254             0             0 54 i

*> 28.119.17.0/24   204.12.1.254             0             0 54 i

*> 112.0.0.0        204.12.1.254                           0 54 50 60 i

*> 113.0.0.0        204.12.1.254                           0 54 50 60 i

*> 114.0.0.0        204.12.1.254                           0 54 i

*> 115.0.0.0        204.12.1.254                           0 54 i

*> 116.0.0.0        204.12.1.254                           0 54 i

*> 117.0.0.0        204.12.1.254                           0 54 i

*> 118.0.0.0        204.12.1.254                           0 54 i

*> 119.0.0.0        204.12.1.254                           0 54 i

*> 155.1.0.0        0.0.0.0                            32768 i

*> 205.90.31.0      155.1.45.5                             0 200 254 ?

*> 220.20.3.0       155.1.45.5                             0 200 254 ?

*> 222.22.2.0       155.1.45.5                             0 200 254 ?

Total number of prefixes 14

Rack1R4(config)#

##################### and where the actual problem is , R1

Rack1R1(config-router)#do sh ip bgp

BGP table version is 15, local router ID is 150.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

* i28.119.16.0/24   54.1.1.254               0    100      0 54 i

*>i                 204.12.1.254             0    100      0 54 i

* i28.119.17.0/24   54.1.1.254               0    100      0 54 i

*>i                 204.12.1.254             0    100      0 54 i

* i112.0.0.0        54.1.1.254               0    100      0 54 50 60 i

*>i                 204.12.1.254             0    100      0 54 50 60 i

* i113.0.0.0        54.1.1.254               0    100      0 54 50 60 i

*>i                 204.12.1.254             0    100      0 54 50 60 i

* i114.0.0.0        54.1.1.254               0    100      0 54 i

*>i                 204.12.1.254             0    100      0 54 i

* i115.0.0.0        54.1.1.254               0    100      0 54 i

*>i                 204.12.1.254             0    100      0 54 i

* i116.0.0.0        54.1.1.254               0    100      0 54 i

*>i                 204.12.1.254             0    100      0 54 i

* i117.0.0.0        54.1.1.254               0    100      0 54 i

*>i                 204.12.1.254             0    100      0 54 i

* i118.0.0.0        54.1.1.254               0    100      0 54 i

   Network          Next Hop            Metric LocPrf Weight Path

*>i                 204.12.1.254             0    100      0 54 i

* i119.0.0.0        54.1.1.254               0    100      0 54 i

*>i                 204.12.1.254             0    100      0 54 i

* i155.1.0.0        155.1.146.6              0    100      0 i

*>i                 155.1.146.4              0    100      0 i

*> 205.90.31.0      155.1.13.3                             0 200 254 ?

* i                 155.1.45.5               0    100      0 200 254 ?

*> 220.20.3.0       155.1.13.3                             0 200 254 ?

* i                 155.1.45.5               0    100      0 200 254 ?

*> 222.22.2.0       155.1.13.3                             0 200 254 ?

* i                 155.1.45.5               0    100      0 200 254 ?

Rack1R1(config-router)# do sh ip bgp 112.0.0.0

BGP routing table entry for 112.0.0.0/8, version 4

Paths: (2 available, best #2, table Default-IP-Routing-Table)

Multipath: eBGP iBGP

  Advertised to update-groups:

     1          2        

  54 50 60, (Received from a RR-client)

    54.1.1.254 (metric 2560002816) from 155.1.146.6 (150.1.6.6)

      Origin IGP, metric 0, localpref 100, valid, internal, multipath

      DMZ-Link Bw 250 kbytes

  54 50 60, (Received from a RR-client)

    204.12.1.254 (metric 2560002816) from 155.1.146.4 (150.1.4.4)

      Origin IGP, metric 0, localpref 100, valid, internal, multipath, best

      DMZ-Link Bw 12500 kbytes

Rack1R1(config-router)#do sh ip route 112.0.0.0

Routing entry for 112.0.0.0/8

  Known via "bgp 100", distance 200, metric 0

  Tag 54, type internal

  Last update from 204.12.1.254 00:15:30 ago

  Routing Descriptor Blocks:

    204.12.1.254, from 155.1.146.4, 00:15:30 ago

      Route metric is 0, traffic share count is 1

      AS Hops 3

      Route tag 54

  * 54.1.1.254, from 155.1.146.6, 00:15:30 ago

      Route metric is 0, traffic share count is 1

      AS Hops 3

      Route tag 54

Rack1R1(config-router)#

as you can see , the BGP process in R1 is receiving the correct DMZ-link bw but is not taking it into effect ...

can you please help me  if i mised anything in my configuration ?

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: DMZ-Link bandwidth is not changing the traffic countin the r

Hi,

Can you please double check you have a bandwidth value on ALL your BGP peering physical interfaces? And also can you include the running-config output from R1 for 'router bgp XXXX' as you haven't included that one (the others are there). Just to make sure you have 'bgp dmzlink-bw' configured on all those peerings and globally in the process - as it will still show it in the community output even if it's not working on it.

View solution in original post

2 REPLIES 2
Highlighted
Beginner

Re: DMZ-Link bandwidth is not changing the traffic countin the r

Hi,

Can you please double check you have a bandwidth value on ALL your BGP peering physical interfaces? And also can you include the running-config output from R1 for 'router bgp XXXX' as you haven't included that one (the others are there). Just to make sure you have 'bgp dmzlink-bw' configured on all those peerings and globally in the process - as it will still show it in the community output even if it's not working on it.

View solution in original post

Highlighted

Re: DMZ-Link bandwidth is not changing the traffic countin the r

Hi Jamie

Great point , you mentioned configuring the DMZ-link bw globally and per neighbor , i knew it should only be on the border routers not across the iBGP neighbours ,however i decided trying to enable it globally on R1 and got the following message :

Rack1R1(config-router)# bgp dmzlink-bw  

Rack1R1(config-router)#

*Sep  2 10:34:09.727: %FIB-4-UNEQUAL: Range of unequal path weightings too large for prefix 28.119.16.0/24. Some available paths may not be used.

Rack1R1(config-router)#do clear ip bgp *

Rack1R1(config-router)#

*Sep  2 10:37:25.443: %BGP-5-ADJCHANGE: neighbor 155.1.13.3 Down User reset

*Sep  2 10:37:25.443: %BGP-5-ADJCHANGE: neighbor 155.1.146.4 Down User reset

*Sep  2 10:37:25.447: %BGP-5-ADJCHANGE: neighbor 155.1.146.6 Down User reset

*Sep  2 10:37:25.491: %BGP-5-ADJCHANGE: neighbor 155.1.146.4 Up

*Sep  2 10:37:25.491: %BGP-5-ADJCHANGE: neighbor 155.1.146.6 Up

*Sep  2 10:37:26.695: %BGP-5-ADJCHANGE: neighbor 155.1.13.3 Up

Rack1R1(config-router)#

*Sep  2 10:37:26.843: %FIB-4-UNEQUAL: Range of unequal path weightings too large for prefix 28.119.16.0/24. Some available paths may not be used.

Rack1R1(config-router)#do sh ip bgp 112.0.0.0

then found the following post :

http://ieoc.com/forums/p/21866/182741.aspx

which advises to decreas the weighting range by increasing R6 interface bandwidth :

Rack1R6(config-if)#do sh int ser 0/0/0

Serial0/0/0 is up, line protocol is up

  Hardware is GT96K Serial

  Internet address is 54.1.1.6/24

  MTU 1500 bytes, BW 4000 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation FRAME-RELAY, loopback not set

  Keepalive set (10 sec)

  CRC checking enabled

  LMI enq sent  108550, LMI stat recvd 108551, LMI upd recvd 0, DTE LMI up

  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0

  LMI DLCI 1023  LMI type is CISCO  frame relay DTE

  FR SVC disabled, LAPF state down

  Broadcast queue 0/64, broadcasts sent/dropped 23622/0, interface broadcasts 0

  Last input 00:00:00, output 00:00:04, output hang never

  Last clearing of "show interface" counters 1w5d

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 3000 kilobits/sec

  5 minute input rate 1000 bits/sec, 2 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     2766148 packets input, 196741763 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     413205 packets output, 16697965 bytes, 0 underruns

     0 output errors, 0 collisions, 9 interface resets

     382292 unknown protocol drops

     382306 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     2 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

straight away the problem got disapeard :

Rack1R1(config-router)#do sh ip bgp 112.0.0.0   

BGP routing table entry for 112.0.0.0/8, version 19

Paths: (2 available, best #1, table Default-IP-Routing-Table)

Multipath: iBGP

  Advertised to update-groups:

     1          2        

  54 50 60, (Received from a RR-client)

    155.1.146.4 from 155.1.146.4 (150.1.4.4)

      Origin IGP, metric 0, localpref 100, valid, internal, multipath, best

      DMZ-Link Bw 12500 kbytes

  54 50 60, (Received from a RR-client)

    155.1.146.6 from 155.1.146.6 (150.1.6.6)

      Origin IGP, metric 0, localpref 100, valid, internal, multipath

      DMZ-Link Bw 500 kbytes

Rack1R1(config-router)#

Rack1R1(config-router)#do sh ip route 112.0.0.0

Routing entry for 112.0.0.0/8

  Known via "bgp 100", distance 200, metric 0

  Tag 54, type internal

  Last update from 155.1.146.6 00:08:52 ago

  Routing Descriptor Blocks:

    155.1.146.6, from 155.1.146.6, 00:08:52 ago

      Route metric is 0, traffic share count is 1

      AS Hops 3

      Route tag 54

  * 155.1.146.4, from 155.1.146.4, 00:08:52 ago

      Route metric is 0, traffic share count is 48

      AS Hops 3

      Route tag 54

Rack1R1(config-router)#

sounds like 1:48 is the maximum weight difference range that the 12.4(24)T can tolerate, whereas before it was 12500/250 which is = 50 , hence unacceptabe for load sharing.

Thanks for your great point and help

CreatePlease to create content