cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4902
Views
0
Helpful
23
Replies
Highlighted
Beginner

Does configuring two VLANs on Cisco 871 router divides the bandwidth (to Internet) into half?

Hi,

I use the cisco 871 router as a firewall to my home-office. I have configured two vlans for each seperate port.

That is, FE0 configured as VLAN 10  ----> connected to Layer 2 Switch

            FE1 configured as VLAN 20 ----> connected to another Cisco Layer 2 Switch

            FE2 not in use

            FE3 not in use

and       FE4 is connected to WAN.

I got 100Mbps speed from the ISP, but I can see that I only get 50mbps even connected to VLAN 10 or VLAN 20.

Does configuring two VLANs on Cisco 871 router divides the bandwidth (to Internet) into half?

Please help me out

Thanks in advance,

Regards

MA

23 REPLIES 23
Highlighted
Advisor

Re: Does configuring two VLANs on Cisco 871 router divides the b

Hi,

Does configuring two VLANs on Cisco 871 router divides the bandwidth (to Internet) into half?

No it doesn't, but if you get traffic from vlan 2 and you test from vlan 1 then you won't get the same result of course.

The bandwidth is used by 2 people from one vlan or 2 people from 2 vlans , it's the same for the WAN interface.

How do you know you get 100 Mbps ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted
Beginner

Does configuring two VLANs on Cisco 871 router divides the bandw

Hello Alain,

Thank you very much for your reply,

I have connected directly to the ISP instead of 871 router. I got 100mbps. but when I connected this router  and checked the speed,  i get only 50mbps.

Please help.

Regards

MA

Highlighted
Beginner

Does configuring two VLANs on Cisco 871 router divides the bandw

Here is the running configuration:

Cisco871#sh run

Building configuration...

Current configuration : 2591 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname cisco871

!

boot-start-marker

boot-end-marker

!

enable secret ********

enable password ******

!

no aaa new-model

!

!

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.1 192.168.0.99

ip dhcp excluded-address 192.168.0.254

!

ip dhcp pool LAN-DHCP-POOL

   import all

   network 192.168.0.0 255.255.255.0

   default-router 192.168.0.1

   dns-server    xx.xx.xx.xx                # DNS IP

!

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group 1

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0

switchport access vlan 10

!

interface FastEthernet1

switchport access vlan 30

shutdown

!

interface FastEthernet2

switchport access vlan 10

!

interface FastEthernet3

switchport access vlan 20

!

interface FastEthernet4

ip address xx.xx.xx.xx  255.255.255.240   #WAN IP

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Virtual-Template1

ip unnumbered FastEthernet4

peer default ip address pool defaultpool

ppp authentication chap ms-chap

!

interface Vlan1

no ip address

ip nat inside

ip virtual-reassembly

shutdown

!

interface Vlan10

description Inside

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan20

description Lab-SW-02

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan100

no ip address

!

interface Vlan200

no ip address

!

interface Vlan30

description IP- Phone

ip address 192.168.2.2 255.255.255.0

ip nat inside

ip virtual-reassembly

shutdown

!

ip local pool defaultpool 192.168.100.1 192.168.100.254

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx      #WAN IP

!

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 permit 192.168.0.0 0.0.255.255

!

!

!

!

control-plane

!

line con 0

exec-timeout 0 0

logging synchronous

no modem enable

line aux 0

line vty 0 4

password ******

login

!

scheduler max-task-time 5000

end

Highlighted
Beginner

Does configuring two VLANs on Cisco 871 router divides the bandw

Hi,

I believe that your interface Fa0/4 speed is 100 Mbps but you will get real speed as per your link bandwidth.

Your ISP device will connect to that port at 100 Mbps only but speed depends upon the link you have purchased.

If you have purchased 2 Mbps link and its terminating on your Fa0/4 via ISP device, it will show that Fa0/4 speed is 100Mbps but you get upto 2Mbps only. It will connect at 100Mbps but link speed will be 2Mbps.

Also creating VLAN never divides the speed into two half, if one user in any VLAN is using some bandwidth, other user will get the rest of the bandwidth. You speed / bandwidth is shared among the number of users currently access it.

Highlighted
Beginner

Does configuring two VLANs on Cisco 871 router divides the bandw

Hi Sakun Sharma,

Thank you very much for your reply,

I have purchased 100 Mbps. And also I have tested by configuring my laptop instead of router with public IP given by ISP, I got 100 Mbps. But, if I connect via this router, then I get only 50 Mbps.

I have copied my router configuration in the previous reply above, please check it and let me know if there exist some configuration which is dividing the bandwidth?

Thanks alot,

Best regards,

MA

Highlighted
Beginner

Re: Does configuring two VLANs on Cisco 871 router divides the b

Hi Ali,

Thanks for your reply and clearification on bandwidth purchased.

There isn't anything in your config due to which bandwidth should be divided between VLANs.

You can try testing the bandwidth from VLAN 10 after shutting down all other VLAN interfaces for test purpose, also same test for other VLAN's. If you are getting complete 100 Mbps on individual VLAN after shutting down other VLANs interfaces, that means there is some device which is using bandwidth. Because its not possible that router itself divides the bandwidth between VLAN's.

Are you getting exactly 50 Mbps on both the VLANs, when tested one by one?????

Highlighted
Beginner

Re: Does configuring two VLANs on Cisco 871 router divides the b

Hi Sakun Sharma,

Thanks for your reply,

yes, I am getting 50 Mbps on vlan10, when tested by shutting down all other vlans except vlan10.

I have not tested by shutting vlan10 and connecting to vlan20. I will test this tomorrow morning.

There are many devices connected in vlan 10. But, I have only two devices connected in vlan20. Hence it was easy for me to shutdown vlan20 and test the vlan10.

I will reply you as soon as I test by shutting down vlan 10.

Thanks once again,

Regards

MA

Highlighted
Beginner

Re: Does configuring two VLANs on Cisco 871 router divides the b

Hi Sharma,

I am getting 50 Mbps even if I tested one by one VLAN.

First, I have shutdown the vlan 20 and tested the bandwidth by connecting to vlan 10. I got the same 50 Mbps

Second, I have shutdown the vlan 10 and tested the bandwidth by connecting to vlan 20. I got the same 50 Mbps.

But I have been allocated 100 Mbps from the ISP. where is the half bandwidth???? which device is using this half bandwidth. I'm totally confused...:(

Please help.

Thank you,

Regards

MA

Highlighted
Beginner

Re: Does configuring two VLANs on Cisco 871 router divides the b

Hi,

Exactly 50 Mbps on both is really confusing. Meanwhile, I see and serach more about this in your config, can you test bandwidth on both VLAN's simultaneously. Run the test simultaneously on two machine in different VLANs.

Also can you directly attach your laptop to internet interface and test again.

Highlighted
Beginner

Re: Does configuring two VLANs on Cisco 871 router divides the b

Hi,

Thank you very much for your reply,

I have tested bandwidth on both the VLANs simultaneosly and got 40-45 Mbps. Also, I have tested directly connecting to the WAN interface and got 95 Mbps.

Please suggest... Any help willl be really appreciated...

Regards

MA

Highlighted
Beginner

Re: Does configuring two VLANs on Cisco 871 router divides the b

Hi,

Working on your config, but nothing such there.

You can try setting speed and duplex from auto to manual configuration on Fe0, Fe2, Fe3 to Full duplex 100 Mbps.

Sometimes duplex and speed autonegotiation creates problem.

Also can you post the output for show interface command for fe0, fe2, fe3, fe4, virutal-template1, and show ip int brief command output.

Message was edited by: Sakun Sharma

Highlighted
Beginner

Does configuring two VLANs on Cisco 871 router divides the bandw

Hi,

Thank you very much for your reply and also sorry for late...

Here is the output of show interface and show ip int br:

Cisco871#sh interfaces fastEthernet 0

FastEthernet0 is up, line protocol is up

  Hardware is Fast Ethernet, address is 0022.55e1.c144 (bia 0022.55e1.c144)

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:23, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 9000 bits/sec, 7 packets/sec

  5 minute output rate 58000 bits/sec, 22 packets/sec

     66711853 packets input, 4102443883 bytes, 0 no buffer

     Received 3054569 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     66940136 packets output, 1626132099 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Cisco871#sh interfaces fastEthernet 1

FastEthernet1 is administratively down, line protocol is down

  Hardware is Fast Ethernet, address is 0022.55e1.c145 (bia 0022.55e1.c145)

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Cisco871#sh interfaces fastEthernet 2

FastEthernet2 is up, line protocol is down

  Hardware is Fast Ethernet, address is 0022.55e1.c146 (bia 0022.55e1.c146)

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Cisco871#sh interfaces fastEthernet 3

FastEthernet3 is up, line protocol is up

  Hardware is Fast Ethernet, address is 0022.55e1.c147 (bia 0022.55e1.c147)

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:03, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 1 packets/sec

  5 minute output rate 0 bits/sec, 1 packets/sec

     11425043 packets input, 3183188727 bytes, 0 no buffer

     Received 2051 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     19751206 packets output, 3365019030 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Cisco871#sh interfaces fastEthernet 4

FastEthernet4 is up, line protocol is up

  Hardware is PQUICC_FEC, address is 0022.55e1.c14e (bia 0022.55e1.c14e)

  Internet address is XX.XX.XX.XX/XX

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:21, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/21315/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 51000 bits/sec, 1 packets/sec

  5 minute output rate 0 bits/sec, 1 packets/sec

     73285985 packets input, 3050327367 bytes

     Received 151035 broadcasts, 0 runts, 0 giants, 1658 throttles

     2485 input errors, 125 CRC, 116 frame, 0 overrun, 2360 ignored

     0 watchdog

     0 input packets with dribble condition detected

     59864030 packets output, 2913176450 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Cisco871#sh ip int br

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0              unassigned      YES unset  up                    up

FastEthernet1              unassigned      YES unset  administratively down down

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    up

FastEthernet4              XX.XX.XX.XX     YES NVRAM  up                    up

Vlan1                      unassigned      YES NVRAM  administratively down down

NVI0                       unassigned      NO  unset  up                    up

Virtual-Template1          XX.XX.XX.XX  YES TFTP   down                  down

Vlan10                     192.168.0.1     YES NVRAM  up                    up

Vlan20                     192.168.1.1     YES NVRAM  up                    up

Vlan100                    unassigned      YES NVRAM  administratively down down

Vlan200                    unassigned      YES NVRAM  administratively down down

Vlan30                     192.168.2.2     YES NVRAM  administratively down down

Virtual-Access1            unassigned      YES unset  down                  down

Highlighted
VIP Expert

Re: Does configuring two VLANs on Cisco 871 router divides the b

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

What's your CPU stats look like when you hit 50 Mbps?  Reason I ask, an 871 is only rated at 25 Kpps.

Highlighted
Beginner

Does configuring two VLANs on Cisco 871 router divides the bandw

Hi Joseph,

Thank you very much for your reply,

sorry, I didn't understand what do you mean?

Can you please explain me, how to check the CPU stats of the router?

Regards,

MA