08-05-2014 11:32 PM - edited 03-04-2019 11:29 PM
Hi,
I am trying to configure the ap on a Cisco 887VAMW router but cannot get the Dot11Radio 0 interface to come up, it is stuck on 'reset'
Here is my config:
ap(config)#do sh run
Building configuration...
Current configuration : 2964 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
logging rate-limit console 9
enable secret 5 $1$E0no$MTZp.nseyRv.1m0Q.Rx4N.
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid XXX
vlan 1
authentication open
authentication key-management wpa version 2
guest-mode
mbssid guest-mode dtim-period 1
wpa-psk ascii 7 113C4A2733400909366931
!
!
!
username admin secret 5 $1$eYC5$ePSDBvwD6VLzMrZxKtBus.
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 1 mode ciphers aes-ccm
!
broadcast-key vlan 1 change 3600 membership-termination capability-change
!
!
ssid XXX
!
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
no ip address
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface BVI1
ip address dhcp client-id GigabitEthernet0
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
banner exec ^CC
% Password change notice.
-----------------------------------------------------------------------
Default username/password setup on AP is cisco/cisco with privilege level 15.
It is strongly suggested that you create a new username with privilege level
15 using the following command for console security.
username <myuser> privilege 15 secret 0 <mypassword>
no username cisco
Replace <myuser> and <mypassword> with the username and password you want to
use. After you change your username/password you can turn off this message
by configuring "no banner login" and "no banner exec" in privileged mode.
-----------------------------------------------------------------------
^C
banner login ^CC
% Password change notice.
-----------------------------------------------------------------------
Default username/password setup on AP is cisco/cisco with privilege level 15.
It is strongly suggested that you create a new username with privilege level
15 using the following command for console security.
username <myuser> privilege 15 secret 0 <mypassword>
no username cisco
Replace <myuser> and <mypassword> with the username and password you want to
use. After you change your username/password you can turn off this message
by configuring "no banner login" and "no banner exec" in privileged mode.
-----------------------------------------------------------------------
^C
!
line con 0
privilege level 15
login local
no activation-character
line vty 0 4
login local
!
Can anyone assist me on this one?
Thanks alot
Solved! Go to Solution.
08-06-2014 05:47 AM
If you want an MBSSID setup, you have lacking configuration and incorrect as well:
I'll give you a new sample:
dot11 ssid TEST
vlan 1
authentication mode open
authentication key-management wpa version 2
wpa-psk ascii <yourpassword>
mbssid guest-mode -One of your mistakes, if you want mbssid, only this line is required
interface dot11radio 0
encryption vlan 1 mode ciphers tkip
ssid TEST
mbssid
no shutdown
interface dot11radio 0.1
encapsulation dot1q 1 native
bridge-group 1
interface gigabitethernet0.1
encapsulation dot1q 1 native
bridge-group 1
Done!
In your setup, the AP does not know that VLAN1 is the native, its native is the native radio,
that is why we create a sub-interface for it :)
Also 'bridge-group 1' should always exist in the native VLAN,
If you want to add more SSID, just do the same (of course skipping the 'native' on the rest) and adding another bridge-group ex; bridge-group 2 vice versa
08-06-2014 04:18 AM
08-06-2014 05:47 AM
If you want an MBSSID setup, you have lacking configuration and incorrect as well:
I'll give you a new sample:
dot11 ssid TEST
vlan 1
authentication mode open
authentication key-management wpa version 2
wpa-psk ascii <yourpassword>
mbssid guest-mode -One of your mistakes, if you want mbssid, only this line is required
interface dot11radio 0
encryption vlan 1 mode ciphers tkip
ssid TEST
mbssid
no shutdown
interface dot11radio 0.1
encapsulation dot1q 1 native
bridge-group 1
interface gigabitethernet0.1
encapsulation dot1q 1 native
bridge-group 1
Done!
In your setup, the AP does not know that VLAN1 is the native, its native is the native radio,
that is why we create a sub-interface for it :)
Also 'bridge-group 1' should always exist in the native VLAN,
If you want to add more SSID, just do the same (of course skipping the 'native' on the rest) and adding another bridge-group ex; bridge-group 2 vice versa
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide