cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
104
Views
0
Helpful
2
Replies
Highlighted
Beginner

download and upload rate is not symmetry in DMVPN

Hi all,

I met a problem recently, I have spent many time to solve it but unfortunately  I still have no clue to solve it.  below is the appearance of problem:

1.  We have a dmvpn network,    the HUB and the SPOKE are in the different city.   the server is connected to HUB router and the client is connected to the SPOKE router. both router are cisco router.  

2.  I test the bandwidth with iPerf tool between client and server,  the result is strange,   the download rate is 20Mbits/s and the upload rate is 80Mbits/s on client,    the transport rate is no symmetry.

3.  If I bypass the DMVPN network,  but still use the same internet link to public network,   the downaload rate and upload rate both are 90Mbits/s,   that means there is no rate limitation on the outside link.

do you have any idea why the DMVPN has such asymmetry performance ?

Everyone's tags (1)
2 REPLIES 2
VIP Mentor

Re: download and upload rate is not symmetry in DMVPN

Hello,

 

hard to say...can you post the configs of both the hub and the spoke ? How many spokes are connected to the hub ?

Beginner

Re: download and upload rate is not symmetry in DMVPN

HUB

interface Tunnel542
description Management
ip vrf forwarding MGMT
ip flow monitor NetflowV9 input
ip flow monitor NetflowV9 output
ip address 172.17.97.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication xxxxx
ip nhrp map 172.17.97.2 91.186.183.30
ip nhrp map multicast 91.186.183.30
ip nhrp network-id 542
ip nhrp holdtime 300
ip tcp adjust-mss 1360
ip ospf network broadcast
ip ospf priority 200
ip ospf cost 125
qos pre-classify
tunnel source GigabitEthernet0/0/3.141
tunnel mode gre multipoint
tunnel key 542
tunnel vrf DMVPN_Internet
tunnel protection ipsec profile DMVPN_IPSec shared





SPOKE 1

interface Tunnel542
ip vrf forwarding MGMT
ip address 172.17.97.101 255.255.255.0
no ip redirects
ip mtu 1400
ip flow ingress
ip flow egress
ip nhrp authentication xxxxxx
ip nhrp map multicast dynamic
ip nhrp map 172.17.97.2 91.186.183.30
ip nhrp map multicast 91.186.183.30
ip nhrp map multicast 91.186.183.29
ip nhrp map 172.17.97.1 91.186.183.29
ip nhrp network-id 542
ip nhrp nhs 172.17.97.2
ip nhrp nhs 172.17.97.1
ip tcp adjust-mss 1360
ip ospf network broadcast
ip ospf priority 0
ip ospf cost 1000
qos pre-classify
tunnel source GigabitEthernet0/2.18
tunnel mode gre multipoint
tunnel key 542
tunnel vrf DMVPN_Internet
tunnel protection ipsec profile DMVPN_IPSec shared




SPOKE 2

interface Tunnel542
ip vrf forwarding MGMT
ip address 172.17.97.131 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication XXXX
ip nhrp map multicast dynamic
ip nhrp map 172.17.97.2 91.186.183.30
ip nhrp map multicast 91.186.183.30
ip nhrp map 172.17.97.1 91.186.183.29
ip nhrp map multicast 91.186.183.29
ip nhrp network-id 542
ip nhrp nhs 172.17.97.1
ip nhrp nhs 172.17.97.2
ip tcp adjust-mss 1360
ip ospf network broadcast
ip ospf priority 0
ip ospf cost 1000
tunnel source GigabitEthernet0/1
tunnel mode gre multipoint
tunnel key 542
tunnel vrf DMVPN_Internet
tunnel protection ipsec profile DMVPN_IPSec shared
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards