cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
837
Views
5
Helpful
6
Replies
Kaushik Ray
Beginner

E1 Sub interface not coming up

Hello

I am having an issue with an E1 Connection where one of the subinterface is up but the other one stays down.

The configs are as follows:

Router A

-----------------------

!

controller E1 0/1/0

channel-group 0 timeslots 1-28

channel-group 1 timeslots 29-31

!

!

interface Multilink2

bandwidth 1984

ip address 192.168.10.1 255.255.255.252

ip tcp header-compression iphc-format

load-interval 30

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

ppp multilink group 2

ip rtp header-compression iphc-format

!

interface Multilink3

bandwidth 64

ip address 10.10.10.1 255.255.255.252

ip tcp header-compression iphc-format

load-interval 30

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

ppp multilink group 3

ip rtp header-compression iphc-format

!

!

interface Serial0/1/0:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 2

!

interface Serial0/1/0:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 3

!

Serial0/1/0:0              unassigned      YES manual up                    up

Serial0/1/0:1              unassigned      YES unset  up                    down

Virtual-Access1            unassigned      NO  TFTP   down                  down

Multilink2                 192.168.10.1    YES NVRAM  up                    up

Multilink3                 10.10.10.1      YES manual down                  down

Router B

-----------------------

!

controller E1 0/2/0

channel-group 0 timeslots 1-28

channel-group 1 timeslots 29-31

!

!

interface Multilink2

bandwidth 1984

ip address 192.168.10.2 255.255.255.252

ip tcp header-compression iphc-format

load-interval 30

ppp multilink

ppp multilink interleave

ppp multilink group 2

ppp multilink fragment delay 10

ip rtp header-compression iphc-format

!

interface Multilink3

bandwidth 64

ip address 10.10.10.2 255.255.255.252

ip tcp header-compression iphc-format

load-interval 30

ppp multilink

ppp multilink interleave

ppp multilink group 3

ppp multilink fragment delay 10

ip rtp header-compression iphc-format

!

!

interface Serial0/2/0:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 2

!

interface Serial0/2/0:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 3

!

Serial0/2/0:0              unassigned      YES unset  up                    up

Serial0/2/0:1              unassigned      YES unset  up                    down

Loopback0                  10.183.32.4     YES NVRAM  up                    up

Multilink2                 192.168.10.2    YES NVRAM  up                    up

Multilink3                 10.10.10.2      YES manual down                  down

6 REPLIES 6
Giuseppe Larosa
Hall of Fame Master

Hello Kaushik,

I'm afraid you should use two channel-group numbers like 1 and 2, channel-group 0 is fine when associating all the timeslots to it, or for unframed operation.

I would not use channel-group 0 in this scenario

Hope to help

Giuseppe

Thanks Giuseppe

I changed to following but the issue remains:

Router A

---------------------------

!

controller E1 0/1/0

channel-group 1 timeslots 1-29

channel-group 2 timeslots 30-31

!

interface Multilink2

bandwidth 1984

ip address 192.168.10.1 255.255.255.252

ip tcp header-compression iphc-format

load-interval 30

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

ppp multilink group 2

ip rtp header-compression iphc-format

!

interface Multilink3

bandwidth 64

ip address 10.10.10.1 255.255.255.252

ip tcp header-compression iphc-format

load-interval 30

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

ppp multilink group 3

ip rtp header-compression iphc-format

!

interface Serial0/1/0:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 2

!

interface Serial0/1/0:2

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 3

!

Serial0/1/0:1              unassigned      YES manual up                    up

Serial0/1/0:2              unassigned      YES manual up                    down

Multilink2                 192.168.10.1    YES manual up                    up

Multilink3                 10.10.10.1      YES manual down                  down

Router B

---------------------------

!

controller E1 0/2/0

channel-group 1 timeslots 1-29

channel-group 2 timeslots 30-31

!

!

interface Multilink2

bandwidth 1984

ip address 192.168.10.2 255.255.255.252

ip tcp header-compression iphc-format

load-interval 30

ppp multilink

ppp multilink interleave

ppp multilink group 2

ppp multilink fragment delay 10

ip rtp header-compression iphc-format

!

interface Multilink3

bandwidth 64

ip address 10.10.10.2 255.255.255.252

ip tcp header-compression iphc-format

load-interval 30

ppp multilink

ppp multilink interleave

ppp multilink group 3

ppp multilink fragment delay 10

ip rtp header-compression iphc-format

!

!

interface Serial0/2/0:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 2

!

interface Serial0/2/0:2

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 3

Serial0/2/0:1              unassigned      YES unset  up                    up

Serial0/2/0:2              unassigned      YES unset  up                    down

Loopback0                  10.183.32.4     YES NVRAM  up                    up

Multilink2                 192.168.10.2    YES NVRAM  up                    up

Multilink3                 10.10.10.2      YES manual down                  down

Flaps a lot

Dec  6 11:15:41.283 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to down

Dec  6 11:16:03.439 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to up

Dec  6 11:16:03.451 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to down

Dec  6 11:16:07.471 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to up

Dec  6 11:16:07.483 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to down

Dec  6 11:16:11.503 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to up

Dec  6 11:16:13.523 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to down

Dec  6 11:16:17.551 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to up

Dec  6 11:16:19.571 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to down

Dec  6 11:16:23.599 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to up

Dec  6 11:16:23.611 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:2, changed state to down

When i shut down the Mu3

the serial interface comes up!!

Serial0/2/0:1              unassigned      YES unset  up                    up

Serial0/2/0:2              unassigned      YES unset  up                    up

Loopback0                  10.183.32.4     YES NVRAM  up                    up

Multilink2                 192.168.10.2    YES NVRAM  up                    up

Multilink3                 10.10.10.2      YES manual administratively down down

Hello Kaushik,

I see

I hadn't used the multilink bundles the derived serial interfaces se0/2/0:1 and se0/2/0:2 can be used directly as L3 interfaces.

Hope to help

Giuseppe

Thanks Giuseppe

i removed the multilink and set it directly as L3 interfaces and it now looks like it is working.

Many Thanks for all your help with this.

Kaushik

Hi Kaushik

In order to have multiple multilinks beween two routers, you need to configure different authenticated usernames for each bundle.

http://www.cisco.com/en/US/tech/tk713/tk507/technologies_configuration_example09186a0080093c1d.shtml

Thank you

Raju