cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
266
Views
0
Helpful
5
Replies

EHWIC-VA-DSL-A Configuration for MTE

Hi there,

 

It's been a while since I've posted here, I was just wondering if somebody could help me. I'm attempting to replace my ISPs shocking modem/router/AP with some spare gear I have. Namely a 1921 ISR with a EHWIC-VA-DSL-A card, I know that my ISP is using MTE on their VDSL network. But this isn't something I've dealt with in the past.

 

Would anybody be able to tell me what I need to configure i order to get this to work? 

 

Thanks in advance for any replies!

 

-Yanni

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: EHWIC-VA-DSL-A Configuration for MTE

Hi, 

 

I managed to get it working using a sample config, from someone who did the same, as inspiration!

The config applied, shown below, is working just fine now. But out of curiosity it seems to use the IP address of the next hop for gateway of last resort and default gateway... If I try to remove that and do 'no ip default gateway' and then use the interface for gateway of last resort it doesn't work.

The WAN IP is in a /22 subnet and this seems change every week or so, and of course the gateway IP keeps changing after a reboot meaning I have to manually reconfigure my static route. Is there a way to do this automatically? 

 

controller VDSL 0/0/0

interface GigabitEthernet0/0
no ip address
duplex auto
speed auto

interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.254 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
no cdp enable

interface ATM0/0/0
no ip address
shutdown
no atm ilmi-keepalive

interface Ethernet0/0/0
mac-address 7050.afb7.c5da
no ip address
ip nat outside
ip virtual-reassembly in

interface Ethernet0/0/0.101
encapsulation dot1Q 101
ip dhcp client request classless-static-route
ip dhcp client client-id hex ************************************
ip dhcp client hostname ******************|********
ip address dhcp
no ip redirects
no ip proxy-arp
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly in

ip route 0.0.0.0 0.0.0.0 94.11.162.36

ip nat inside source list 100 interface Ethernet0/0/0.101 overload
access-list 100 permit ip 192.168.10.0 0.0.0.255 any

5 REPLIES 5
Highlighted
VIP Mentor

Re: EHWIC-VA-DSL-A Configuration for MTE

Hello,

 

typcally you would configure the card as below. You need to find out from your ISP (who is your ISP ?) what VLAN tag you are required to configure:

 

controller VDSL 0/0/0
operating mode vdsl2
firmware filename flash:vdsl.bin-xxxxxxxx
!
interface Ethernet0/0/0
no ip address
!
interface Ethernet0/0/0.x
encapsulation dot1Q x
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
load-interval 30
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname hostname
ppp chap password password
ppp pap sent-username username password password

Re: EHWIC-VA-DSL-A Configuration for MTE

Hi, 

 

I managed to get it working using a sample config, from someone who did the same, as inspiration!

The config applied, shown below, is working just fine now. But out of curiosity it seems to use the IP address of the next hop for gateway of last resort and default gateway... If I try to remove that and do 'no ip default gateway' and then use the interface for gateway of last resort it doesn't work.

The WAN IP is in a /22 subnet and this seems change every week or so, and of course the gateway IP keeps changing after a reboot meaning I have to manually reconfigure my static route. Is there a way to do this automatically? 

 

controller VDSL 0/0/0

interface GigabitEthernet0/0
no ip address
duplex auto
speed auto

interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.254 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
no cdp enable

interface ATM0/0/0
no ip address
shutdown
no atm ilmi-keepalive

interface Ethernet0/0/0
mac-address 7050.afb7.c5da
no ip address
ip nat outside
ip virtual-reassembly in

interface Ethernet0/0/0.101
encapsulation dot1Q 101
ip dhcp client request classless-static-route
ip dhcp client client-id hex ************************************
ip dhcp client hostname ******************|********
ip address dhcp
no ip redirects
no ip proxy-arp
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly in

ip route 0.0.0.0 0.0.0.0 94.11.162.36

ip nat inside source list 100 interface Ethernet0/0/0.101 overload
access-list 100 permit ip 192.168.10.0 0.0.0.255 any

VIP Mentor

Re: EHWIC-VA-DSL-A Configuration for MTE

Hello,

 

if you change the default route to:

 

ip route 0.0.0.0 0.0.0.0 dhcp

 

you should be able to deal with changing, DHCP assigned addresses...

 

Out of curiosity, who is your ISP ?

Re: EHWIC-VA-DSL-A Configuration for MTE

Thanks Georg,

 

I'll give that a try when I get home later!

And my ISP is Now TV, just a re-brand of Sky Broadband in the UK.

Re: EHWIC-VA-DSL-A Configuration for MTE

Hey Georg,
I've tested
'ip route 0.0.0.0 0.0.0.0 dhcp'
and that seems to work just fine, however I'm also using
'ip nat inside source static tcp 192.168.10.202 80 interface Ethernet0/0/0.101 8080'
This worked fine before I change the static route but now I can't access the web server from the outside :/
Any ideas as to what might be causing this?

-Yanni
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards