cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
503
Views
0
Helpful
3
Replies

Eigrp and Bandwith

sahari67671
Level 1
Level 1

Hi,

Here is a scenario example...

screentshot.png

The problem is with the EIGRP route decision at the egress.

Site PT outgoing interface to Branch is configured with BW of 45M,

Site AH outgoing interface to Branch is configured with BW of 30M.

PT router is being connected to ILPTCRCOVSS switch which runs EIGRP and redistributes statics + connected from the Nexus (ILPT-N9K01,2).

AH router is being connected to ILAH-N9K01,2 which runs EIGRP and redistribute statics + connected.

 

AH & PT is connected with the L2 line between ILPTCRCOVSS & AH Nexuses.

 

 

Packet to network: 10.7.0.0 is being sent to AH router(because he advertises it with the lowest metric) and then reaches 10.7.0.0 severs through ILAH-N9K switches.

The problem occurs when the Packet needs to be sent back.
Because PT is the main site (BW is bigger results in Better metric) it is being sent over there and loads the L2 line between to sites.

The question is what can I do to minimize the traffic that is being sent to AH to go over PT , or to prevent it from being sent to PT even if it has much better BW?

 

Here is the relevant configuration:

 

SITES_ROUTER_PT -

 

interface GigabitEthernet0/1
bandwidth 46080
ip address 172.18.100.37 255.255.255.252
duplex auto
speed auto
media-type rj45
service-policy output 45M

 

interface GigabitEthernet0/2
description <<< TO BB switch 4500X Tengig 2/1/7 >>>
ip address 10.25.27.1 255.255.255.252
load-interval 30
duplex auto
speed auto
media-type rj45

 

router eigrp 1

network 10.25.26.0 0.0.0.7
network 10.25.27.1 0.0.0.0

network 172.0.0.0 0.255.255.255

 

ILPTCRCOVSS -

 

vlan 2338

interface GigabitEthernet1/0
description **TO SITES_ROUTER_PT**
no switchport
ip address 10.25.26.3 255.255.255.248
negotiation auto
!
interface GigabitEthernet1/1
description **TO SITES_ROUTER_PT**
no switchport
ip address 10.25.27.2 255.255.255.248
negotiation auto

 

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode active
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode active
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode active

 

router eigrp 1

network 10.25.26.3 0.0.0.0
network 10.25.27.2 0.0.0.0

network 17.17.17.254 0.0.0.0

passive-interface default

no passive-interface Vlan2338

no passive-interface GigabitEthernet1/0
no passive-interface GigabitEthernet1/1

 

interface GigabitEthernet3/2
description **TO AH**
switchport trunk allowed vlan 11,60,77,101,121,122,126,130,131,300,400,401,405
switchport trunk allowed vlan add 450,460,500,501,600-604,2338
switchport trunk encapsulation dot1q
switchport mode trunk
bandwidth 2097152
load-interval 30
media-type rj45
speed 1000
duplex full
no negotiation auto
udld port aggressive
!
interface GigabitEthernet3/3
description **TO AH**
switchport trunk allowed vlan 11,60,77,101,121,122,126,130,131,222,300,400,401
switchport trunk allowed vlan add 405,450,460,500,501,600-604,2338
bandwidth 2097152
load-interval 30
media-type rj45
speed 1000
duplex full
no negotiation auto
udld port aggressive

 

 

 

 

SITES_ROUTER_ACHIHUD -

 

interface GigabitEthernet0/2
description <<< TO BRANCH >>>
bandwidth 30960
ip address 172.18.101.37 255.255.255.252
delay 1000
duplex auto
speed auto
media-type rj45
service-policy output 30M

 

 

interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
media-type rj45

 

interface GigabitEthernet0/0.2339
encapsulation dot1Q 2339
ip address 17.17.20.1 255.255.255.248

 

 

router eigrp 1
network 17.17.20.1 0.0.0.0
network 172.0.0.0 0.255.255.255

 

ILAH-N9K01 -

vlan 300

interface Vlan300
description 10.7.0.0 NETWORK
no shutdown
no ip redirects
ip address 10.7.3.10/16
no ipv6 redirects
ip eigrp 1 shutdown

 

interface Vlan2338
description "L3 to PT"
no shutdown
no ip redirects
ip address 17.17.17.251/24
no ipv6 redirects

 

interface Vlan2339
description "TO_SITES_ROUTER_AH"
no shutdown
no ip redirects
ip address 17.17.20.3/24
no ipv6 redirects

interface Ethernet1/1
description "Connection to AH_ROUTER_SITES"
switchport mode trunk
switchport trunk allowed vlan 2339

 

interface Ethernet1/2

description **TO PT ILPTCRCOVSS**

switchport mode trunk
switchport trunk allowed vlan 2338
speed 1000
duplex full
bandwidth 2097152

 

router eigrp 1

network 17.17.17.0/24

 

 

Ty

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3 Replies 3

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @sahari67671 ,

with EIGRP you can use interface delay setting it with command delay to manipulate routing.

 

EIGRP composite metric is cumulative on delay in tens of microseconds  and inversally proportional to the lowest BW in kbps in the path.

 

So the best results are achieved changing delay and not bandwitdth

 

Hope to help

Giuseppe

 

Hello @Giuseppe Larosa ,

thanks for answering.

The reason behind Bandwith is to prefer the PT site as the MAIN site for all the traffic that comes and goes.

My problem is when some branch needs to reach the only segments that live behind AH nexuses, for example, Network 10.7.0.0/16.

In that case, packet flow will be :

In: Shaar_Hanegev -> AH_ROUTER - > AH_Nexus -> server(10.7.0.0/16)

Out: Server(10.7.0.0/16) -> AH_Nexus -> ILPTCRCOVSS -> PT_ROUTER -> Shaar_Hanegev

 

The reason that the packet goes from AH_Nexus -> ILPTCRCOVSS is that PT is the preferred site (with BW or Delay.. it doesn't really change which K value I will change).

 

By the way, I have edited the scheme in the post.

 

Hello @sahari67671 ,

to make a path secondary in EIGRP we can increase the delay from the value we see on show interface type x/y

In this way, doing this in both directions ( both involved routers on the same link ) you should be able to make the path via PT_ROUTER secondary in both directions.

 

Hope to help

Giuseppe

 

Review Cisco Networking products for a $25 gift card