cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
197
Views
10
Helpful
4
Replies
Highlighted
Contributor

EIGRP and OSPF routes not being advertised between eBGP

See attached diagram diagram of lab topology.

So OSPF 100 routes/interfaces communicate fine with BGP 65001, and likewise between EIGRP100 and BGP65000. 

But routes from OSPF and EIGRP are not being shared through the 2 BGP Autonomous Systems meaning nothing from EIGRP 100 can ping anything from OSPF 100 and vise versa. The 2 BGP AS communicate just fine.

I just have basic BGP configs and know I am missing something just not sure what - see below.

 

R5#sh running-config | section bgp
redistribute bgp 65000
router bgp 65000
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
redistribute eigrp 100
neighbor 203.1.1.2 remote-as 65001

 

R2#sh running-config | section bgp
redistribute bgp 65001 subnets
router bgp 65001
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
redistribute ospf 100
redistribute eigrp 100
neighbor 203.1.1.1 remote-as 65000

 

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Enthusiast

Re: EIGRP and OSPF routes not being advertised between eBGP

Hello CiscoBlueBelt,

 

Did you configure mutual redistribution at R2 and R5? That is under R5 did you redistribute BGP into EIGRP after redistributing EIGRP into BGP and in R2 did you do same for both OSPF and BGP?

 

Also why are you redistributing EIGRP in R2 since R2 is not participating in EIGRP AS?

4 REPLIES 4
Enthusiast

Re: EIGRP and OSPF routes not being advertised between eBGP

Hello CiscoBlueBelt,

 

Did you configure mutual redistribution at R2 and R5? That is under R5 did you redistribute BGP into EIGRP after redistributing EIGRP into BGP and in R2 did you do same for both OSPF and BGP?

 

Also why are you redistributing EIGRP in R2 since R2 is not participating in EIGRP AS?

Contributor

Re: EIGRP and OSPF routes not being advertised between eBGP

Actually figured it out. Not at home right now and can update what I forgot to do.
The EIGRP redistribution probably an oversight I forgot to delete. I will update you shortly. You nailed it on the money so I Accept Solution and thanks!
Enthusiast

Re: EIGRP and OSPF routes not being advertised between eBGP

You're welcome. HTH

Contributor

Re: EIGRP and OSPF routes not being advertised between eBGP

I spoke to soon. I think I dreamed I fixed it...seriously.

Yes I did redistribute ospf/eigrp/bgp. See something wrong below?

 

 

R5#sh running-config | section eigrp
router eigrp 100
network 5.5.5.5 0.0.0.0
network 203.2.2.0
redistribute bgp 65000
redistribute eigrp 100
R5#sh running-config | section bgp
redistribute bgp 65000
router bgp 65000
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
network 203.1.1.1
network 203.3.3.0 mask 255.255.255.252
redistribute eigrp 100
neighbor 203.1.1.2 remote-as 65001
neighbor 203.3.3.2 remote-as 65000

 

 

----------------------------------------

 

 

R2#sh run | section ospf
router ospf 100
redistribute bgp 65001 subnets
network 4.4.4.4 0.0.0.0 area 1
network 10.3.3.0 0.0.0.255 area 1
R2#sh run | section bgp
redistribute bgp 65001 subnets
router bgp 65001
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 10.3.3.2
neighbor 203.1.1.1 remote-as 65000

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards