cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2163
Views
0
Helpful
1
Replies
Highlighted
Beginner

EIGRP BGP REDISTRIBUTION ISSUE

Hi All,

i have a doubt what will happen under such scenario.. pls refer the R1 configs and topology diagram..

SCENARIO 1:

****************

LOOPBACK > Advertised into Eigrp 123 via network 128.166.0.0 > REDISTRIBUTED INTO BGP 123 > ADV SUMMARY via aggregate-address 128.166.128.0 255.255.224.0 summary-only

in the above scenario under any circumstance the summary will be advertised as loopback will be up even though the all the downlinks F0/0 are down..

SCENARIO 2:

****************

LOOPBACK > Redistribute connected in EIGRP 123 network 128.166.130.177 0.0.0.0  no auto-summary > REDISTRIBUTED INTO BGP 123 > ADV SUMMARY via aggregate-address 128.166.128.0 255.255.224.0 summary-only

Now i cant see the loopback subnet in the bgp table ????????

SCENRIO 3:

STATIC ROUTE  to reach a 128.166 subnet > Redistribute static in EIGRP 123 > REDISTRIBUTED INTO BGP 123 > ADV SUMMARY via aggregate-address 128.166.128.0 255.255.224.0 summary-only

what will happen now, wil the route still got advertised if the static next hop ip goes down ????????????

ROUTER CONFIG

**********************

R1

interface Loopback0

  ip address 128.166.130.246 255.255.255.255

!

interface FastEthernet0/0

ip address 128.166.130.177 255.255.255.248

!

interface Serial1/0

ip address 192.124.75.53 255.255.255.252

!

router eigrp 123

network 128.166.0.0

auto-summary

!

router bgp 123

bgp log-neighbor-changes

neighbor 192.124.75.54 remote-as 1

redistribute eigrp 123

network 192.124.75.52 mask 255.255.255.252

aggregate-address 128.166.128.0 255.255.224.0 summary-only

!

Everyone's tags (3)
1 REPLY 1
Cisco Employee

Re: EIGRP BGP REDISTRIBUTION ISSUE

Hi,

scenario 2 and 3 cannot work as you expect. When you redistribute EIGRP into BGP you actually redistibute the EIGRP routes which are in the routing table plus the subnets that are included in the "network" commands under EIGRP. Scenario 1 works because you used "network 128.166.0.0" under EIGRP.

When you do "redistribute connected/static" under EIGRP and then redistribute EIGRP into BGP, the connected/static routes are not redistributed into BGP.

hope this helps,

Fabrizio

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards