cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
178
Views
5
Helpful
5
Replies
Highlighted
Beginner

EIGRP DMVPN retry time exceed

Hello guys ,

I am lab up a topology of Hub and Spoke (Phase 1) Dynamic Multiprotocol Virtual Private Network

I have used full-forms because page was not allowing to post shortcut keywords

 

 

dmvpn.png

 

 


I advertised all the underlay address in AREA 0 , all (underlay) for Hub-to-spoke and vice-versa reachable

Then i tried advertised Tunnel(overlay) and other address of hub and spokes using Enhanced Interior Gateway Routing Protocol, Spoke Tunnels formed neighbors with HUB, but after some time its going down with retry time exceeded logs

%DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 192.168.10.3 (Tunnel1) is down: retry limit exceeded


I read some of the article regarding this issue ,they suggests to change Maximum transmission unit and Maximum segment size of Tunnels to 1400 and 1360 respectively ,tried that too , but still same issue

 

Any suggestions and Solutions ?


Thanks in Advance

5 REPLIES 5
Highlighted
Enthusiast

Hi,

Please kindly share your configuration of DMVPN as well as the OSPF & EIGRP on both Hub and Spoke.

Without seeing your configuration and based on your description, I guess you didn't disable split-horizontal on Hub router.
Highlighted

btw, I have done a quick lab for your reference. Thanks for let me revisiting my Cisco exam material.

 

HUB:


IOU4# show run int t0 interface Tunnel0 ip address 172.16.0.1 255.255.255.0 no ip split-horizon eigrp 1 ip nhrp map multicast dynamic ip nhrp network-id 12345 ip nhrp holdtime 300 [Not a must, but enhance the stability issue due to IOU's bug] ip nhrp redirect tunnel source Ethernet0/0 tunnel mode gre multipoint tunnel protection ipsec profile IP end IOU4#sh run | s router router eigrp 1 network 172.16.0.0 router ospf 1 IOU4#sh run int e0/0 interface Ethernet0/0 ip address 192.168.1.1 255.255.255.0 ip ospf 1 area 0 end

Spoke

interface Tunnel0
 ip address 172.16.0.3 255.255.255.0
 ip nhrp map multicast 192.168.1.1
 ip nhrp map 172.16.0.1 192.168.1.1
 ip nhrp network-id 12345
 ip nhrp holdtime 300
 ip nhrp nhs 172.16.0.1
 ip nhrp shortcut
 tunnel source Ethernet0/0
 tunnel mode gre multipoint
 tunnel protection ipsec profile IP
end

IOU3(config-router)#do sh run | s router
router eigrp 1
 network 172.16.0.0
router ospf 1

IOU3(config-router)#do sh run int e0/0
interface Ethernet0/0
 ip address 192.168.3.1 255.255.255.0
 ip ospf 1 area 0
end

 

Highlighted

Thanks for the suggestion,but it did not work 

 

i am using IOS 7200 ,  i did a another lab with 1-----2-----3 ,Point-to_Point connectivity between 3 routers ,and then configured same Enhanced Interior Gateway protocol for Overlay (Tunnel) , and Open Shortest Path First protocol for Underlay  , just to confirm the issue was not with some sort of recursive routing , and the result is it worked fine , Neighbor-ship was stable

Then what's the issue?

 

Thanks

Highlighted

Hi,

Kindly share your configuration of DMVPN, OSPF & EIGRP on both Hub and Spoke.

Highlighted

Solved , man i think IOS as some type of BUG ,now i mirrored the same setup but this time with IOU images ,

it worked fine , previously every 80 seconds it use to go down ,Now its stable

 

Output :

Screenshot from 2020-04-30 14-57-03.png

 

 

Thanks