cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
132
Views
0
Helpful
0
Replies
Highlighted
Beginner

eigrp filter for new neighbors

Hello all,

we're having a question.

We have a cisco isr(router) device with eigrp AS 300 knowing remote client networks. In our eigrp AS 300 is distributed for an eigrp AS 1000, within the eigrp 1000 we have 2 neighbor.

 

We need to be able to send certain prefixes through one interface, but not through the other within the eigrp 1000. We installed a new neighbor in the device. 10.112.5.1.

 

 

ISR-PROV-TEST#show running-config | section eigrp

router eigrp 300

 !

 address-family ipv4 vrf mexico_prov autonomous-system 300

  redistribute eigrp 1000 metric 10000 10 255 1 1500

  network 172.21.240.129 0.0.0.0

  distribute-list prefix from_ibm_prov_to_mexico_out out

  distribute-list prefix from_mexico_to_ibm_prov_in in

  autonomous-system 300

  eigrp router-id 172.21.240.129

 exit-address-family

router eigrp 1000

 !

 address-family ipv4 vrf mexico_prov autonomous-system 1000

  redistribute eigrp 300 metric 10000 10 255 1 1500 route-map from_mexico

  network 10.112.5.4 0.0.0.0

  network 10.112.11.45 0.0.0.0

  distribute-list route-map core_to_mexico in GigabitEthernet0/0.1509

  eigrp router-id 10.112.11.45

 exit-address-family

 

EIGRP-IPv4 Neighbors for AS(1000) VRF(mexico_prov)

H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq

                                                   (sec)         (ms)       Cnt Num

0   10.112.5.1              Gi0/0.1600               10 07:23:10    1   100  0  230

2   10.112.11.46            Gi0/0.1509               14 07:26:12    1   100  0  325

 

 

we need to send certain prefixes for  neighbors 10.112.5.1 and  neighbors 10.112.11.46.

!

for example, this networks(prefix) we need send only for 10.112.5.1 and not 10.112.11.46.  How can you do that?.                 

ip prefix-list from_mexico_to_ibm_prov_in seq 10 permit 192.168.30.0/24

ip prefix-list from_ibm_prov_to_mexico_out seq 10 permit 10.112.5.0/29

!

!

!

route-map core_to_mexico deny 10

 match tag 3108

!

route-map core_to_mexico deny 11

 match tag 3208

!

route-map core_to_mexico deny 12

 match tag 3209

!

route-map core_to_mexico permit 100

!

route-map from_mexico permit 20

0 REPLIES 0