cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
965
Views
0
Helpful
17
Replies

EIGRP internal routes to WAN MPLS/BGP router

Amafsha1
Level 2
Level 2

Hello, with the help of great people here at the community forums I've gotten farther with our MPLS router failover project to connect all our branches.  

 

In this project, I am trying to get a second router to connect to the same ISP AS# to provide redundancy to all our branches in case the first circuit or Router goes down.  All branches have to come to the main hub (here main office) via MPLS to use the internet, we use this MPLS circuit only for connecting our branches (internet router is somewhere else).  But aside from that, my question is a little different and is regards to getting the internal EIGRP routes to choose which Router to use when exiting our network to go out the MPLS circuit(s).   The 2 files attached show the story.  1 is the current design of how we are now; the other is what we would like for the future design.  I'm not worried about the inbound/outbound BGP configs because those are happening by someone else, but I did need to work on the configs for how the internal routes in the network choose whether they want to use Router 1 or Router 2.  From my understanding, we need to tweak the EIGRP metrics in the Route-map that specifies all routes that are being redistrbiuted from BGP to EIGRP.  As you can see in the configs I've posted below that everything from EIGRP is allowed to BGP and everything from BGP is allowed to EIGRP.  I've tweaked the reliability on the CE2 router because I would like that to be the backup router in case CE1 fails.  Does this config look correct?  I've bolded the changes. 

 

If anyone suggests any other changes or sees anything else wrong, please, I am all ears :)

 

Thank you in advance

 


-----------------------------------------------------------------------------------
hostname CE1
!
!
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
!
interface GigabitEthernet0/0/1
description // MPLS to ISP
ip address 63.63.140.154 255.255.255.252
no negotiation auto
!
interface GigabitEthernet0/0/2
description to Core1
ip address 172.31.255.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet0/0/3
description to Core2
ip address 172.31.255.5 255.255.255.252
negotiation auto
!
!
router eigrp 200
network 172.31.255.0 0.0.0.3
network 172.31.255.4 0.0.0.3
redistribute bgp 65000 route-map bgp-to-eigrp
!
router bgp 65000
bgp log-neighbor-changes
neighbor 63.63.140.153 remote-as 200
neighbor 10.0.0.2 remote-as 65000
neighbor 10.0.0.2 update-source Loopback0
neighbor 10.0.0.2 soft-reconfiguration inbound
!
address-family ipv4
redistribute connected
redistribute static
redistribute eigrp 1 route-map eigrp-to-bgp
neighbor 63.63.140.153 activate
neighbor 63.63.140.153 soft-reconfiguration inbound
default-information originate
exit-address-family
!
ip route 0.0.0.0 0.0.0.0 172.31.255.2 name to Core1
ip route 0.0.0.0 0.0.0.0 172.31.255.6 name to Core2
!
!
ip prefix-list bgp-to-eigrp seq 100 permit 0.0.0.0/0 le 32
!
!
ip prefix-list eigrp-to-bgp seq 100 permit 0.0.0.0/0
ip prefix-list eigrp-to-bgp seq 320 permit 0.0.0.0/0 le 32
!
!
!
route-map bgp-to-eigrp permit 100
match ip address prefix-list bgp-to-eigrp
set metric 100 1 255 1 1500
!
route-map eigrp-to-bgp permit 100
match ip address prefix-list eigrp-to-bgp
!

--------------------------------------------------------------------------------
hostname CE2
!
!
!
!
interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
!
interface GigabitEthernet0/0/1
description // MPLS to ISP
ip address 64.64.140.154 255.255.255.252
no negotiation auto
!
interface GigabitEthernet0/0/2
description to Core1
ip address 172.31.255.10 255.255.255.252
negotiation auto
!
interface GigabitEthernet0/0/3
description to Core2
ip address 172.31.255.14 255.255.255.252
negotiation auto
!
!
router eigrp 200
network 172.31.255.9 0.0.0.3
network 172.31.255.13 0.0.0.3
redistribute bgp 6500 route-map bgp-to-eigrp
!
router bgp 65000
bgp log-neighbor-changes
neighbor 64.64.140.153 remote-as 200
neighbor 10.0.0.1 remote-as 65000
neighbor 10.0.0.1 update-source Loopback0
neighbor 10.0.0.1 soft-reconfiguration inbound
!
address-family ipv4
redistribute connected
redistribute static
redistribute eigrp 1 route-map eigrp-to-bgp
neighbor 64.64.140.153 activate
neighbor 64.64.140.153 soft-reconfiguration inbound
default-information originate
exit-address-family
!
ip route 0.0.0.0 0.0.0.0 172.31.255.9 name to Core1
ip route 0.0.0.0 0.0.0.0 172.31.255.13 name to Core2
!
!
ip prefix-list bgp-to-eigrp seq 100 permit 0.0.0.0/0 le 32
!
!
ip prefix-list eigrp-to-bgp seq 100 permit 0.0.0.0/0
ip prefix-list eigrp-to-bgp seq 320 permit 0.0.0.0/0 le 32
!
!
!
route-map bgp-to-eigrp permit 100
match ip address prefix-list bgp-to-eigrp
set metric 100 1 155 1 1500
!
route-map eigrp-to-bgp permit 100
match ip address prefix-list eigrp-to-bgp
!

 

17 Replies 17

disregard what I wrote, I was able to get it to work...but not properly.  if the neighborship shuts down between WAN 2 router and ISP 1 router, now the cores can reach the branch router, but pings get missed because of it getting confused which way to go since both the interfaces for the back of the network from WAN2 to two nexus have routing problems.  

Please share the RIB from the source and destination device with source and destination IP addresses.

I was able to fix the issue and got it to pretty much work...at least I think so.  I tested by trying different scenarios, like shutting down 1 of the BGP neighborships, or taking down the interface, or rebooting the router, or shutting down one of the back end interfaces to the cores..  So far everything has worked and the failovers were solid, can ping find, traceroutes show it going down the intended path.  I still feel strange about how I made it work.  Tonight, i'll show you the configs in case you see anything I dont.  THank you

Review Cisco Networking products for a $25 gift card