cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
879
Views
0
Helpful
14
Replies
Highlighted
Beginner

EIGRP is not advertising routes with different masks

Hi everyone

 

We are advertising the 172.30.240.0/20 subnet to a neighbor 1.

 

We need to advertise 172.30.240.0/24 to another neighbor 2.

 

This is the configuration we have, but it is not working

 

Neighbor 1 (It´s working)

 

interface TenGigabitEthernet0/1/2.163
encapsulation dot1Q 163
ip address 192.168.92.177 255.255.255.248
standby 163 ip 192.168.92.180
standby 163 priority 120
standby 163 preempt
standby 163 name HSRP_BNA_Iplan
standby 163 track 2 decrement 25
end
!
ip route 192.168.93.184 255.255.255.252 192.168.92.181 name Peer
!
interface Tunnel163
bandwidth 1500
ip address 192.168.89.221 255.255.255.252
ip tcp adjust-mss 1300
keepalive 20 3
tunnel source 192.168.92.180
tunnel destination 192.168.93.186
end
!
ip access-list standard OUT
permit 172.30.240.0 0.0.15.255
!
ip access-list standard IN
permit 192.168.93.176 0.0.0.7
!
router eigrp 1
distribute-list OUT out Tunnel163
distribute-list IN in Tunnel163
network 172.30.240.0 0.0.15.255

 

Neighbor B (not working)

interface TenGigabitEthernet0/1/2.219
encapsulation dot1Q 219
ip address 10.113.254.41 255.255.255.252
crypto map cm
!
crypto map cm 10 ipsec-isakmp
set peer 10.113.254.42
set transform-set AES256-SHA1
match address ACL
reverse-route
!
ip access-list extended ACL
permit gre host 10.113.254.41 host 10.113.254.42
!
interface Tunnel136
bandwidth 1024
ip address 10.113.254.13 255.255.255.252
keepalive 20 3
tunnel source 10.113.254.41
tunnel destination 10.113.254.42
!
router eigrp 1
distribute-list IN in Tunnel136
distribute-list OUT out Tunnel136
network 172.30.0.0
network 172.30.240.2 0.0.0.0
network 172.30.240.3 0.0.0.0
network 172.30.240.8 0.0.0.0
network 172.30.240.12 0.0.0.0
network 172.30.240.69 0.0.0.0
network 172.30.240.70 0.0.0.0
network 172.30.240.101 0.0.0.0
network 172.30.240.102 0.0.0.0
network 172.30.240.193 0.0.0.0
network 172.30.240.194 0.0.0.0
network 172.30.240.225 0.0.0.0
network 172.30.240.226 0.0.0.0
network 172.30.240.227 0.0.0.0
network 172.30.240.237 0.0.0.0
!
ip access-list standard IN
permit 10.112.0.160 0.0.0.31
ip access-list standard OUT
permit 172.30.240.70
permit 172.30.240.69
permit 172.30.240.102
permit 172.30.240.101
permit 172.30.240.2
permit 172.30.240.3
permit 172.30.240.8
permit 172.30.240.12
permit 172.30.240.194
permit 172.30.240.193
permit 172.30.240.226
permit 172.30.240.227
permit 172.30.240.225
permit 172.30.240.237
!
ip route 172.30.240.0 255.255.240.0 192.168.5.218 name Servicios
ip route 172.30.240.0 255.255.240.0 Null0 name Publicacion_EIGRP
ip route 172.30.240.2 255.255.255.255 192.168.5.218 name Tandem-
ip route 172.30.240.3 255.255.255.255 192.168.5.202 name Tandem-
ip route 172.30.240.69 255.255.255.255 192.168.5.218 name Servicio_MKP_
ip route 172.30.240.70 255.255.255.255 192.168.5.218 name Servicio_MKP_
ip route 172.30.240.101 255.255.255.255 192.168.5.28 name Stratus_MKP_PRO
ip route 172.30.240.102 255.255.255.255 192.168.5.28 name Stratus_MKP_DES
ip route 172.30.240.193 255.255.255.255 192.168.5.218 name FW
ip route 172.30.240.194 255.255.255.255 192.168.5.218 name XCOM
ip route 172.30.240.225 255.255.255.255 192.168.5.213 name XCOM
ip route 172.30.240.226 255.255.255.255 192.168.5.213 name EMULACION

 

 

Thank you very much for the help

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hello Everyone

 

We configured redistribution static with route-maps. It worked

 

Thanks for your help

View solution in original post

14 REPLIES 14
Highlighted
Beginner

The configuration I showed you is with / 32, it doesn't work either. When replacing it with / 24, which is the goal, it doesn't work either

Highlighted

just to understand the topology here.

 

is this tunnel between these device ? also neighbour ship between this devices ?

 

you already have network anounced onside, why you need to anounce on other side ? trying to understand what is the goal ?

 



BB


*** Rate All Helpful Responses ***

Highlighted

The configurations that I have shown are configured in a single router

Highlighted

if this is single router, can you provide other router configuration and neighbour details with eigrp ? is this formed?

 



BB


*** Rate All Helpful Responses ***

Highlighted

EIGRP is formed

 

We need see on the debug ip eigrp that the /24 is advertising

Highlighted

Hello Everyone

 

We configured redistribution static with route-maps. It worked

 

Thanks for your help

View solution in original post

Highlighted
Hall of Fame Expert

Try "no auto-summary" in your "router eigrp 1."
Highlighted

it was already configured. Not working

 

Automatic Summarization: disabled

Highlighted

Oops, that's what happens without really studying the OP - especially since later IOS versions make no auto-summary the default for EIGRP.

So, actually studying the OP, and your follow ups, OP information is all on just one router, correct? There are three routers involved, correct? If so, could you provide the relevant configuration information (interface, EIGRP) for all three routers, and clarify the physical/logically connections between them?
Highlighted

This router connects with two other routers, neighbor A and neighbor B.

 

We need advertise for the neighbor A /20, for the neighbor B /24

Highlighted

Right, believe I understood that from your OP. However, it might be very helpful to have the information requested.
Highlighted

Hello @148784 ,

you have written that your initial post reports the configuration of a single router and you would like to advertise different prefixes to different neighbors.

I would expect the ACLs invoked in the distribute-list command for neighbor A and neighbor B to be different  I see that both are named IN and OUT.

You need different ACLs applied to different tunnels to achieve the desired behaviour

 

Or the real names of these ACLs are different ?

 

Hope to help

Giuseppe

 

Highlighted

Hi Giuseppe

 

The real names of these ACLs are different

 

Highlighted
Enthusiast

I do not see a route for the /24. It can't advertise what it doesn't have.

 

from your config:

ip route 172.30.240.0 255.255.240.0 192.168.5.218 name Servicios
ip route 172.30.240.0 255.255.240.0 Null0 name Publicacion_EIGRP
i

 

this is why the summary advertisement works.

my hunch is that the mask for the static route for servicios should be 24 bits.