cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
324
Views
1
Helpful
2
Replies

EIGRP neighboring failure in DMVPN

yellowswan
Beginner
Beginner

According to the topology, R1 is hub while R2 & R3 are spokes. R4 is only used for underlay connectivity

R1 configuration:

interface Loopback0
  ip address 172.16.1.1 255.255.255.0
interface Tunnel0
  ip address 192.168.1.1 255.255.255.0
  ip nhrp map multicast dynamic
  ip nhrp network-id 100
  ip nhrp redirect
  tunnel source FastEthernet0/0
  tunnel mode gre multipoint
router ospf 1
  router-id 2.2.2.2
  network 10.10.0.0 0.0.255.255 area 0

R2 configuration

interface Loopback0
  ip address 172.16.2.1 255.255.255.0
interface Tunnel0
  ip address 192.168.1.2 255.255.255.0
  ip nhrp network-id 100
  ip nhrp nhs 192.168.1.1 nbma 10.10.11.1 multicast
  ip nhrp shortcut
  tunnel source FastEthernet0/0
  tunnel mode gre multipoint
router ospf 1
  router-id 2.2.2.2
  network 10.10.0.0 0.0.255.255 area 0
ip route 172.16.3.0 255.255.255.0 192.168.1.3

R3 Configuration

interface Loopback0
  ip address 172.16.3.1 255.255.255.0
interface Tunnel0
  ip address 192.168.1.3 255.255.255.0
  ip nhrp network-id 100
  ip nhrp nhs 192.168.1.1 nbma 10.10.11.1 multicast
  ip nhrp shortcut
  tunnel source FastEthernet0/0
  tunnel mode gre multipoint
router ospf 1
  router-id 3.3.3.3
  network 10.10.0.0 0.0.255.255 area 0
ip route 172.16.2.0 255.255.255.0 192.168.1.2
the DMVPN works OK

Hub#sh dmvpn
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1     10.10.12.2     192.168.1.2     UP     01:10:31     D
1     10.10.13.3     192.168.1.3     UP     01:09:56     D

R2#traceroute 172.16.3.1 source 172.16.2.1
Tracing the route to 172.16.3.1
VRF info: (vrf in name/id, vrf out name/id)
1     192.168.1.3    80 msec    60 msec    36 msec

however, when I want to enable EIGRP for R1/R2/R3

router eigrp 1
  network 192.168.1.0 0.0.0.255
  network 172.16.x.0 0.0.255.255

the EIGRP neighbor can no be established, on R2 & R3, it displays

%DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.1.1 (Tunnel0) is down: retry limit exceeded
%DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.1.1 (Tunnel0) is up: new adjacency
%DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.1.1 (Tunnel0) is down: retry limit exceeded
%DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.1.1 (Tunnel0) is up: new adjacency
%DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.1.1 (Tunnel0) is down: retry limit exceeded

and there is nothing in R1 for the

show ip eigrp neighbor

command

I wonder why it happened, and how to handle this problem?

1 Accepted Solution

Accepted Solutions

Remove

static route

you add in each spoke.

That what you need only 

View solution in original post

2 Replies 2

Remove

static route

you add in each spoke.

That what you need only 

Thanks, guy, I guess I forgot to remove the

static route

after I enable the EIGRP......

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: