cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
864
Views
0
Helpful
6
Replies
Highlighted

EIGRP not fully passing routes after introducing a 3750

We've put in a 3750 at our corp hq (Detroit).  We did this to break up the current flat 172.16.0.0 /16 network into separate VLAN's for various purposes.  We plan on doing that at another site (Farmington), which will become a DR site.  We are running EIGRP throughout the organization over an OPTEMAN netowrk and also sending routes to a managed MPLS network which uses BGP.  BGP redistributes into EIGRP and vice versa.  I've attached a pdf of the network.  The 3750 core at the corp hq is a temp core, hopefully upgrading to Nexus within a year or two.  This problem didn't exist until the 3750 was introduced and became the gateway for the site.  The OPTEMAN router was the gateway and was on the same VLAN as the MPLS router.

So, in detroit we have an Detroit-MPLS router, Detroit-3750, and Detroit-OPTEMAN.  What I'm seeing is that the routers I'm getting from the MPLS router make it to the 3750.  The 3750 advertises those routes to the Detroit-OPTEMAN router.  However, the OPTEMAN router doesn't advertise these routes any further..

In Farmington, it is currently set up like Detroit used to be set up.  There is a flat network and both routers are on the same VLAN, no L3 core switch.  Routes come in from the MPLS, get advertised to the Farmington-OPTEMAN router, distributes the routes out to all OPTEMAN connected routers, including Detroit.  However, Detroit is not passing that route to the 3750.

When we made the 3750 stack the core, we didn't change anything else, except for some IP changes.

Can anyone help me figure out why these routes aren't fully redistributing?

Detroit-3750 Stack

WS-C3750G-24TS-S   <-Stack master running c3750-ipservicesk9-mz.122-55.SE7.bin

WS-C3750X-12S-E  <-Running c3750e-universalk9-mz.122-55.SE7

show sdm prefer

The current template is "desktop routing" template.

router eigrp 1

network 172.16.0.0 0.0.63.255

network 172.16.255.0 0.0.0.3

redistribute static route-map static-to-eigrp

passive-interface default

no passive-interface Vlan255

no passive-interface Vlan1

show ip eigrp topology 172.18.154.0/24

EIGRP-IPv4 Topology Entry for AS(1)/ID(172.16.255.2) for 172.18.154.0/24

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 256512

  Descriptor Blocks:

  172.16.0.36 (Vlan1), from 172.16.0.36, Send flag is 0x0

      Composite metric is (256512/256256), route is External

      Vector metric:

        Minimum bandwidth is 10000 Kbit

        Total delay is 20 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 1

      External data:

        Originating router is 172.16.0.36 

        AS number of route is 7014

        External protocol is BGP, external metric is 0

        Administrator tag is 2828 (0x00000B0C)

Detroit-OPTEMAN

ASR1002 <-Running asr1000rp1-adventerprisek9.02.01.01.122-33.XNA1.bin

router eigrp 1

network 10.255.255.0 0.0.0.15

network 172.16.255.0 0.0.0.3

no auto-summary

passive-interface default

no passive-interface GigabitEthernet0/0/1

no passive-interface GigabitEthernet0/0/2

show ip eigrp topology 172.18.154.0/24

EIGRP-IPv4 (AS 1): Topology default(0) entry for 172.18.154.0/24

  State is Passive, Query origin flag is 1, 2 Successor(s), FD is 256768

  Routing Descriptor Blocks:

  10.255.255.4 (GigabitEthernet0/0/2), from 10.255.255.4, Send flag is 0x0

      Composite metric is (256768/256512), Route is External

      Vector metric:

        Minimum bandwidth is 10000 Kbit

        Total delay is 30 microseconds

        Reliability is 255/255

        Load is 2/255

        Minimum MTU is 1500

        Hop count is 2

      External data:

        Originating router is 172.17.150.252 

        AS number of route is 7014

        External protocol is BGP, external metric is 0

        Administrator tag is 2828 (0x00000B0C)

  172.16.255.2 (GigabitEthernet0/0/1), from 172.16.255.2, Send flag is 0x0

      Composite metric is (256768/256512), Route is External

      Vector metric:

        Minimum bandwidth is 10000 Kbit

        Total delay is 30 microseconds

        Reliability is 255/255

        Load is 9/255

        Minimum MTU is 1500

        Hop count is 2

      External data:

        Originating router is 172.16.0.36 

        AS number of route is 7014

        External protocol is BGP, external metric is 0

        Administrator tag is 2828 (0x00000B0C)

Farmington-OPTEMAN

3845 <-Running c3845-entservicesk9-mz.124-3.bin

router eigrp 1

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet0/1

network 10.255.255.0 0.0.0.15

network 172.17.0.0

no auto-summary

show ip eigrp topology 172.18.154.0/24

IP-EIGRP (AS 1): Topology entry for 172.18.154.0/24

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 256512

  Routing Descriptor Blocks:

  172.17.150.252 (GigabitEthernet0/1), from 172.17.150.252, Send flag is 0x0

      Composite metric is (256512/256256), Route is External

      Vector metric:

        Minimum bandwidth is 10000 Kbit

        Total delay is 20 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 1

      External data:

        Originating router is 172.17.150.252 

        AS number of route is 7014

        External protocol is BGP, external metric is 0

        Administrator tag is 2828 (0x00000B0C)

6 REPLIES 6
Highlighted
VIP Mentor

Hello

how are canton and Farmington receiving routes from Detriot-Opteman
have you tried originating a default from Detriot-Opteman ?

Is auto-summarisation disabled on canton and Farmington?

Res
Paul


Sent from Cisco Technical Support iPad App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

The default route is a static route on the 3750 that is redistributed via an EIGRP route-map which is filtered with a prefix-list.  It makes it out to all sites with no issues.

no auto-summary is on every eigrp config.  It's default on some IOS's so it doesn't show up in the show run.

Canton recieves all routes from Detroit and farmington from EIGRP 1 that originate from the sites.  Meaning any static redistributed routes from Detroit and Farmington make it to Canton just fine, as well as any VLAN's I create at Detroit.  The LAN's at these sites work just fine as well.  It's only the routes that come in from the MPLS BGP redistribution.

Routes from the MPLS that come in from farmington hills make it to Canton and Detroit.

Routes from the MPLS that come into Detroit don't make it farther than the opteman router. 

If you look at the pdf, the green lines are where the routes are succesfully being redistributed and the red is where they are failing to get redistributed. 

Before the 3750, the detroit opteman router would pass the routes to canton and farmington just fine and whenever you did a show ip eigrp topoloy for a remote MPLS site, it would have two routes on every opteman router.  Now we only see farmington as an option for 172.18.154.0/24, or any remote site connected to MPLS.

Highlighted

Hello
On routers
Debug ip eigrp

On 3750
Try changing the sdm template to routing?
Is the ios applicable for full routing.



Res
paul


Sent from Cisco Technical Support iPad App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

SDM temp is routing

I tried the debug command but nothing shows up and I don't want to bounce the connection during business hours.

The IOS is the very latest version and it's ipservices so it should be good for full eigrp.

Highlighted

I guess a good way to put this is that the Detroit OPTEMAN router will not advertise any route that came from the MPLS network, but it will accept them into it's own routing table.  Which seems really odd since it did before the 3750 installation.  This router did crash when I reconfigured the EIGRP when we put in the 3750, but it came back up and I put the commands in a few lines at a time and it took.

Highlighted


Hello
In topology
172.17.0.0/ 16
172.17.0.0/ 18
172.16.255.0/30


Farmington-OPTEMAN
network 172.17.0.0 (major net boundary 16 bit)


Opteman
172.17.0.0/ 18
172.16.255.0/30

I would try and tidy this up and be more specific with your advertisement

Res
Paul

Sent from Cisco Technical Support iPad App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future