02-24-2011 10:30 PM - edited 03-04-2019 11:33 AM
Hi All,
We have 2x 3750G L3 switches and I am trying to set them up to use EIGRP but for some reason it’s not working, I created 2 routed ports on each switch and I want to route vlan10 traffic to vlan20 to S2. I also enable EIGRP as the routing protocol but I still cannot ping between VLAN 10 and VLAN20 , here are the configs for both switches. What am I doing wrong? Any help would be much appreciated!!!
S1
Current configuration : 1943 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S1
!
no aaa new-model
switch 1 provision ws-c3750g-24ps
system mtu routing 1500
ip subnet-zero
ip routing
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
interface GigabitEthernet2/0/23
description ROUTED_PORT23
no switchport
ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet2/0/24
description ROUTED_PORT24
no switchport
ip address 192.168.2.1 255.255.255.0
vlan internal allocation policy ascending
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
router eigrp 10
redistribute connected
network 192.168.10.0
network 192.168.20.0
no auto-summary
!
ip default-gateway 192.168.1.1
ip classless
ip http server
!
!
control-plane
S2
Current configuration : 1820 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S2
!
!
no aaa new-model
switch 2 provision ws-c3750g-24ps
ip subnet-zero
ip routing
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
interface GigabitEthernet2/0/23
description ROUTED_PORT23
no switchport
ip address 192.168.1.2 255.255.255.0
!
interface GigabitEthernet2/0/24
description ROUTED_PORT24
no switchport
ip address 192.168.2.2 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
!
router eigrp 10
redistribute connected
network 192.168.10.0
network 192.168.20.0
no auto-summary
!
ip default-gateway 192.168.1.1
ip classless
ip http server
ip classless
ip http server
!
control-plane
Thank you
Solved! Go to Solution.
02-24-2011 11:22 PM
why did you set those interfaces as passive? your EIGRP neighborship is not coming up because of this. You want to remove those commands.
02-24-2011 10:33 PM
you need a network statement under EIGRP for the subnet used on the routed link between two switches
02-24-2011 11:17 PM
Hi Roman,
Thanks for the fast reply, I've done the following on both switches:
router eigrp 10
redistribute connected
passive-interface GigabitEthernet1/0/23
passive-interface GigabitEthernet1/0/24
network 192.168.10.0
network 192.168.20.0
network 192.168.1.0
network 192.168.2.0
no auto-summary
router eigrp 10
redistribute connected
passive-interface GigabitEthernet2/0/23
passive-interface GigabitEthernet2/0/24
network 192.168.10.0
network 192.168.20.0
network 192.168.1.0
network 192.168.2.0
no auto-summary
Still no luck, I can ping everything from both switches except the for vlan interfaces.
02-24-2011 11:22 PM
why did you set those interfaces as passive? your EIGRP neighborship is not coming up because of this. You want to remove those commands.
02-24-2011 11:45 PM
new adjancy is UP Thank you very much for you help!
passive interface command was a mistake, it will actually prevent hello packets and the EIGRP network flow to neighbors
interesting but still cannot ping VLAN 10/20 interfaces
Regards,
02-25-2011 06:45 AM
Hi,
Can you post show ip route eigrp.
Regards.
Alain.
02-25-2011 07:43 AM
Hey Alain, everything is working now thanks!!
Regards,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide