cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
280
Views
0
Helpful
3
Replies
Gucamole
Beginner

EIGRP redistribution & summary route

I have a simple EIGRP topology with 3 routers and 2 AS. I have created a summary route for 192.168.X.X network with /21 and advertised on R2 both serial interfaces(s2/0,s2/1). I have also redistributed both EIGRP AS into each other. However, when R3 receives route for 192.168.x.x network it shows it's learned via external route. Why is that happening even though I have summarized the same route out of both interfaces on R2?

eigrp.png

R1#sh ip route eigrp

D    192.168.0.0/21 [90/2297856] via 10.2.2.2, 00:00:11, Serial2/0

R3#sh ip route eigrp

D EX 192.168.0.0/21 [170/2297856] via 10.4.4.1, 00:00:05, Serial2/1

*****************************************************************************

R2#sh run int s2/0

interface Serial2/0

ip address 10.2.2.2 255.255.255.252

ip summary-address eigrp 100 192.168.0.0 255.255.248.0 5

serial restart-delay 0

end

R2#sh run int s2/1

interface Serial2/1

ip address 10.4.4.1 255.255.255.252

ip summary-address eigrp 200 192.168.0.0 255.255.248.0 5

serial restart-delay 0

end

 

*****************************************************************************

R2#sh run | sec router

router eigrp 100

redistribute eigrp 200

network 10.0.0.0

network 192.168.0.0 0.0.255.255

no auto-summary

 

router eigrp 200

redistribute eigrp 100

network 10.0.0.0

network 192.168.0.0 0.0.255.255

no auto-summary

******************************************

 

3 REPLIES 3
Abzal
Rising star

Hi @Gucamole 

It seems that's how EIGRP behaves -  only one summary route gets installed whichever EIGRP process has lower AS number. In your case it's AS 100 so the summary route for AS 200 will be redistributed hence it shows up as external.

The best way would be redistributing static route on both AS.

Best regards,
Abzal
Samer Saleem
Enthusiast

Hi
do the following
1. dont enable EIGRP on R2 for 10.0.0.0 but use the exact subnet mask (because 10.0.0.0 will enable both AS numbers on each serial interface which is wrong)
2. when you redistribute on R2 between the two EIGRP AS's use the route-map option
and the route-map should match access list for the IP's of the EIGRP AS IP's only.
check the configs attached

 

paul driver
VIP Mentor

Hello

Given that topology, you could simplify by removing the redistribution from both eigrp processes and make each AS spoke a stub and advertised a default to each rtr rom R2

 

R2
router eigrp 100
no redistributie eigrp 200
eigrp stub summary

router eigrp 200
no redistributie eigrp 100
eigrp stub summary

R1/R3
router eigrp x00
eigrp stub



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future