11-19-2022 04:03 PM - last edited on 11-22-2022 11:04 PM by Translator
Hy Guys, i have a problem with Redistribution in EIGRP, this is Topology:
R1 has attached the subnet 192.168.100/24,192.168.10/24, 192.168.20/24 and 10.0.0.0/30
R2 has attached the subnet 192.168.200/24,192.168.50/24, and 10.0.0.0/30
R1 and R2 are in the same Routing Domain EIGRP 12, the adjacency is UP, this is configuration of EIGRP:
R1:
router eigrp 12
network 10.0.0.0 0.0.0.3
passive-interface GigabitEthernet0/0
distribute-list route-map PERMITTED out
eigrp router-id 1.1.1.1
EIGRP-IPv4 Neighbors for AS(12)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.0.0.2 Gi0/1 13 00:27:52 1 100 0 52
R2:
router eigrp 12
network 10.0.0.0 0.0.0.3
passive-interface GigabitEthernet0/0
eigrp router-id 2.2.2.2
EIGRP-IPv4 Neighbors for AS(12)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.0.0.1 Gi0/1 10 00:28:09 1 100 0 20
This is
Prefix-List
and
Route-Map
for redistribution from R1 to R2:
ip prefix-list PERMIT seq 10 permit 192.168.10.0/24
ip prefix-list PERMIT seq 20 permit 192.168.100.0/24
route-map PERMITTED permit 10
match ip address prefix-list PERMIT
route-map PERMITTED deny 20
But R1 does not advertise the subnets contained in the
prefix-list
PERMITTED.
Why?
Maybe because the network 192.168.0.0 0.0.255.255 is missing within the EIGRP process?
I understood that the
route-map
also regulates the interfaces participating in the EIGRP process, am I wrong?
Thx
Solved! Go to Solution.
11-20-2022 03:12 AM - last edited on 11-22-2022 11:33 PM by Translator
redistribute connect
then use
distribute-list
redistribute connected will add all prefix connect to EIGRP topology
and you only distribute some of them to other peer.
check my above comment I use both commend
11-20-2022 02:02 PM
Another way to look at this is that in the original configuration R1 in its routing table did know about networks 192.168.10.0 and 192.168.100.0 but eigrp on R1 did NOT know about those networks. If R1 does not know about the networks then it can not advertise those networks to R2. There are 2 ways for eigrp to know about the networks. One way is to use network statements for the 2 networks. When you use network statements then eigrp will advertise the networks as Internal networks. The other way for eigrp to know about the networks is to redistribute connected. When you redistribute connected then eigrp advertises the subnets as External networks.
11-19-2022 04:19 PM - edited 11-19-2022 04:24 PM
what is R1-SW1 link config ??
11-20-2022 02:13 AM - last edited on 11-22-2022 11:14 PM by Translator
Thanks for your help.
The interface on R1
interface GigabitEthernet0/0
no ip address
full duplex
speed auto
media-type rj45
The interface on SW1:
interface GigabitEthernet0/0
description R1
switchport trunk encapsulation dot1q
switchport mode trunk
negotiation auto
Interface GigabitEthernet0/0 on R1
is configured as passive to not be able to send/receive Hello packets.
11-20-2022 02:21 AM - last edited on 11-22-2022 11:15 PM by Translator
that what I guess first time,
show ip route
you will see only 10.0.0.0/30, other prefix behind the SW not learn from R1 and hence R1 can not advertise it.
you need to config link R1 subinterface (one subinterface for each VLAN).
Note:- apply it to both Side R1 and R2
11-20-2022 02:53 AM - last edited on 11-22-2022 11:22 PM by Translator
i know, i've configured subinterface for alla VLAN,
this is sh ip route or R1:
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/30 is directly connected, GigabitEthernet0/1
L 10.0.0.1/32 is directly connected, GigabitEthernet0/1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/0.10
L 192.168.10.1/32 is directly connected, GigabitEthernet0/0.10
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/24 is directly connected, GigabitEthernet0/0.20
L 192.168.20.1/32 is directly connected, GigabitEthernet0/0.20
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, GigabitEthernet0/0.100
L 192.168.100.1/32 is directly connected, GigabitEthernet0/0.100
This is sh ip route on R2:
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/30 is directly connected, GigabitEthernet0/1
L 10.0.0.2/32 is directly connected, GigabitEthernet0/1
192.168.50.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.50.0/24 is directly connected, GigabitEthernet0/0.50
L 192.168.50.1/32 is directly connected, GigabitEthernet0/0.50
192.168.200.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.200.0/24 is directly connected, GigabitEthernet0/0.200
L 192.168.200.1/32 is directly connected, GigabitEthernet0/0.200
11-20-2022 03:03 AM - last edited on 11-22-2022 11:30 PM by Translator
OMG we miss the first step in any routing protocol
router eigrp 12
network 10.0.0.0 0.0.0.3
redistribute connected <<- need this friend only or add each prefix with network command
passive-interface GigabitEthernet0/0
distribute-list route-map PERMITTED out
eigrp router-id 1.1.1.1
route-map
after you add prefix will filter it, permit some and deny other
11-20-2022 03:09 AM - last edited on 11-22-2022 11:31 PM by Translator
Yes, i know we can use the command too :
redistribute connected
route-map
PERMITTED
It's work!
But I was convinced that with
route-map
I could redistribute as many prefixes as I wanted even if they weren't connected
11-20-2022 03:12 AM - last edited on 11-22-2022 11:33 PM by Translator
redistribute connect
then use
distribute-list
redistribute connected will add all prefix connect to EIGRP topology
and you only distribute some of them to other peer.
check my above comment I use both commend
11-20-2022 03:18 AM
Yes it's work!
11-20-2022 03:21 AM - last edited on 11-22-2022 11:39 PM by Translator
This is NOW the
sh ip route on R2
D EX 192.168.10.0/24 [170/3072] via 10.0.0.1, 00:07:40, GigabitEthernet0/1
D EX 192.168.100.0/24 [170/3072] via 10.0.0.1, 00:07:40, GigabitEthernet0/
Another question, why the AD of this Prefix is 170? Like a Route learn External EIGRP?
I expected the learned routes to be internal with AD90!
11-20-2022 03:29 AM
the EIGRP as you know have two AD 90 and 170
but why 170 ?
answer is the R1 see the redistribute connect prefix as external so it give it 170
you can change the behave by use network command instead of redistribute connect. and the prefix will be 90.
11-20-2022 03:36 AM
ok, i don't know that all prefix redistributed with redistributed connected command, they have AD170.
Thanks for everything!
11-20-2022 03:37 AM
You are so so welcome.
11-20-2022 02:02 PM
Another way to look at this is that in the original configuration R1 in its routing table did know about networks 192.168.10.0 and 192.168.100.0 but eigrp on R1 did NOT know about those networks. If R1 does not know about the networks then it can not advertise those networks to R2. There are 2 ways for eigrp to know about the networks. One way is to use network statements for the 2 networks. When you use network statements then eigrp will advertise the networks as Internal networks. The other way for eigrp to know about the networks is to redistribute connected. When you redistribute connected then eigrp advertises the subnets as External networks.
11-21-2022 05:02 AM
Thanks.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide