cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
594
Views
1
Helpful
16
Replies

EIGRP retry limit reached tunnel is down. DMVPN.

linus-ardstal
Level 1
Level 1

Hi! I am having some trouble with EIGRP adjacency flapping over my DMVPN network.

*Dec 5 12:55:29.412: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.0.5 (Tunnel0) is down: retry limit exceeded
*Dec 5 12:55:32.919: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.0.5 (Tunnel0) is up: new adjacency

 

:::R2:::

interface Tunnel0
ip address 192.168.0.2 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication CCNP
ip nhrp map 192.168.0.5 10.10.5.1
ip nhrp map multicast 192.168.0.5
ip nhrp network-id 1
ip nhrp holdtime 300
ip nhrp nhs 192.168.0.5
ip tcp adjust-mss 1360
delay 1000
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 1
!

interface Loopback0

ip add 2.2.2.2 255.255.255.255
interface GigabitEthernet0/0
ip address 10.10.200.1 255.255.255.0
duplex auto
speed auto
media-type rj45

router eigrp 1
network 1.1.1.1 0.0.0.0
network 192.168.0.0
!
ip route 0.0.0.0 0.0.0.0 10.10.200.2

:::HUB:::

interface Tunnel0
ip address 192.168.0.5 255.255.255.0
no ip redirects
ip mtu 1400
no ip next-hop-self eigrp 1
no ip split-horizon eigrp 1
ip nhrp authentication CCNP
ip nhrp network-id 1
ip nhrp holdtime 300
ip tcp adjust-mss 1360
delay 1000
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 1
!

interface Loopback0
ip address 5.5.5.5 255.255.255.255

interface GigabitEthernet0/0
ip address 10.10.5.1 255.255.255.0
!
router eigrp 1
network 5.5.5.5 0.0.0.0
network 192.168.0.0
!
ip route 0.0.0.0 0.0.0.0 10.10.5.2

 

 :::WAN:::

interface GigabitEthernet0/0
ip address 10.10.5.2 255.255.255.0
!
interface GigabitEthernet0/1
ip address 10.10.100.2 255.255.255.0
!
interface GigabitEthernet0/2
ip address 10.10.200.2 255.255.255.0

1 Accepted Solution

Accepted Solutions

ip nhrp map multicast dynamic <<- add this to Hub tunnel 

MHM

View solution in original post

16 Replies 16

ip nhrp map multicast dynamic <<- add this to Hub tunnel 

MHM

This also need to correct.

ip nhrp map 192.168.0.5 10.10.5.1
ip nhrp map multicast 10.10.5.1

MHM

Good catch! I think that is the issue.

Happy to help! Please mark as helpful/solution if applicable.
Get in touch: https://torbjorn.dev

This is certainly it. For some reason my IOSv in CML wont accept the command, no errors or anything. It does not show up in the running-config.

It is enabled by default, hence it does not show in the configuration. You can verify this by creating another DMVPN tunnel interface and viewing it's complete configuration with "show run all"

Happy to help! Please mark as helpful/solution if applicable.
Get in touch: https://torbjorn.dev

Then I do not know what is wrong. The adjacency goes down after the holdtimer has expired, then it comes back up a few seconds later.

If issue still' can you share last config 

MHM

I remade the lab, there might be some configuration changes from my original post.

R1:

interface Tunnel0
ip address 192.168.0.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication CCNP
ip nhrp map 192.168.0.5 10.50.1.1
ip nhrp map multicast 192.168.0.5
ip nhrp network-id 1
ip nhrp holdtime 300
ip nhrp nhs 192.168.0.5
ip tcp adjust-mss 1360
delay 1000
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 1

router eigrp 100
network 10.10.1.0 0.0.0.255
router eigrp 1
network 1.1.1.1 0.0.0.0
network 192.168.0.0
passive-interface GigabitEthernet0/0

Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 10.10.1.1 YES manual up up
Loopback0 1.1.1.1 YES manual up up
Tunnel0 192.168.0.1 YES manual up up

WAN:

router eigrp 100
network 10.10.1.0 0.0.0.255
network 10.20.1.0 0.0.0.255
network 10.50.1.0 0.0.0.255
router eigrp 1
passive-interface GigabitEthernet0/0
passive-interface GigabitEthernet0/1
passive-interface GigabitEthernet0/2

Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 10.50.1.2 YES manual up up
GigabitEthernet0/1 10.10.1.2 YES manual up up
GigabitEthernet0/2 10.20.1.2 YES manual up up

HUB:

interface Tunnel0
ip address 192.168.0.5 255.255.255.0
no ip redirects
ip mtu 1400
no ip next-hop-self eigrp 1
no ip split-horizon eigrp 1
ip nhrp authentication CCNP
ip nhrp network-id 1
ip nhrp holdtime 300
ip tcp adjust-mss 1360
delay 1000
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 1

no ip next-hop-self eigrp 1
no ip split-horizon eigrp 1
router eigrp 100
network 10.50.1.0 0.0.0.255
router eigrp 1
network 5.5.5.5 0.0.0.0
network 192.168.0.0
passive-interface GigabitEthernet0/0

Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 10.50.1.1 YES manual up up
Loopback0 5.5.5.5 YES manual up up
Tunnel0 192.168.0.5 YES manual up up

ip nhrp map 192.168.0.5 10.10.5.1
ip nhrp map multicast 10.10.5.1 <<- this need to correct 

MHM

I replied with new configs in your other comment, please check that one

Torbjørn
VIP
VIP

This configuration should work as far as I can see.
How often do the adjacencies flap? Which image are you using?

Happy to help! Please mark as helpful/solution if applicable.
Get in touch: https://torbjorn.dev

The adjacencies flap very un-evenly. 08:54:22, 08:55:44, 08:57:07, 08:58:27, around every 90 seconds it seems.

I am running this in CML with IOSv images.

Hello
Its possible the underlay is causing the issue with your default static routes on the hub and spokes

can you try the following:


Hub/Spoke/WAN rtrs
either remove the default static routes tand add more specific statics for the transit network 
               or
remove all static default routes ,
enable eigrp 100 ONLY on the transit interfaces 

Hub/Spoke/rtrs
router eigrp 1
passive interface the transit interfaces


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

I tried putting the underlay in another EIGRP 100  and passive-interfaces in EIGRP 1, but I still get the same problem

Review Cisco Networking for a $25 gift card