cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1292
Views
0
Helpful
12
Replies

EIGRP Through GRE Tunnel

tomjansen1
Level 1
Level 1

Hi All,

 

I'm having trouble forming neighours with EIGRP through a GRE tunnel. I have 4 routers R1, R2, R3 and R4 and the tunnel is between R1 and R4. I have a loopback interface on R1 and R4 which are 1.1.1.1/32 and 4.4.4.4/32 respectively. I have a tunnel address of 192.168.1.1/30 and 192.168.1.2/30 on the routers and the tunnel is in in the up/up state. I have then enabled EIGRP for networks 1.0.0.0 on R1 and 4.0.0.0 on R4. I know that they will not become neighours because they are not on the same subnet but I thought that I should not advertise the 192.168.1.0/30 network through EIGRP to avoid a recursive routing issue. Please could you let me know what the best way to do this is ?Thanks, Tom

12 Replies 12

Hello,

 

you need to advertise the tunnel networks in EIGRP and configure a static route on each router pointing to the loopbacks with the outgoing physical interface as the next hop...

Hello,

 

if need be, post the config of R1 and R4, so we can fill in the necessary bits and pieces...

Hi George, still have trouble with, I have put the configs for R1 and R4 below.

R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
ip address 192.168.0.1 255.255.255.252
mtu 1476
tunnel source Loopback0
tunnel destination 4.4.4.4
!
!
interface GigabitEthernet0/0
ip address 200.1.1.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 1
network 192.168.1.0
network 200.1.1.0 0.0.0.3
!
ip classless
ip route 4.4.4.4 255.255.255.255 200.1.1.2

R4
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Tunnel0
ip address 192.168.1.2 255.255.255.252
mtu 1476
tunnel source Loopback0
tunnel destination 1.1.1.1
!
!
interface GigabitEthernet0/0
ip address 200.1.1.10 255.255.255.252
duplex auto
speed auto
!
router eigrp 1
network 192.168.1.0
network 200.1.1.8 0.0.0.3

!
ip classless
ip route 1.1.1.1 255.255.255.255 200.1.1.9

R2 and R3 have EIGRP configured on them as well, advertising the physical interfaces.

In the original post you describe advertising the loopback interface addresses in EIGRP over the tunnel (and it was not clear what the tunnel source and destination would be). Now you have changed and are using the loopbacks as tunnel source and destination. This is fine but it is a change from the original description.

 

For the tunnel to work correctly there must be ip connectivity between the tunnel source and destination. Test it by having R1 ping the loopback of R4 and specify the source address for the ping as its loopback. Do the same type of ping from R4 loopback to R1 loopback. I predict that the pings will fail. Based on what you have told us so far it appears that R2 and R3 do not have routing information for 1.1.1.1 or for 4.4.4.4.

 

HTH

 

Rick

HTH

Rick

Sorry for next explaining correctly. You were right, I did the extended ping and it wasn't working so I have updated the commands on R2 and R3 so they know about the loopbacks on R1 and R4 and they can now reach each other.

Thanks for the update that you have solved the problem. I am glad that my suggestion pointed you in the right direction.

 

What you described in your original post was a valid approach. What you have implemented now is a some what different but also valid approach. GRE tunnels are quite flexible and there can be multiple approaches to implementing them.

 

HTH

 

Rick

HTH

Rick

Hello,

 

the recursive routing would occur if you would have a static route for the tunnel source and destination with the tunnel as the next hop:

 

R1

ip route 4.4.4.4 255.255.255.255 Tunnel0

 

R4

ip route 1.1.1.1 255.255.255.255 Tunnel0

 

As long as you advertise the loopbacks in EIGRP you should be fine...

 

R1

 

router eigrp 1
network 1.1.1.1 0.0.0.0
network 192.168.1.0
network 200.1.1.0 0.0.0.3

 

R4

 

router eigrp 1
network 4.4.4.4 0.0.0.0
network 192.168.1.0
network 200.1.1.8 0.0.0.3

Hello,

 

my bad, I missed the updates from Richard while I was labbing this in GNS3...

Glad that you got it resolved...

Thanks George, I will try this.

tomjansen1
Level 1
Level 1

Hi,

 

Thanks for all your help so far. So I have advertised the loopbacks in EIGRP and can now ping across but I still cannot ping across the tunnel interface ips. When I ping 192.168.1.1/30 from R4 is it unreachable.

Hi,

Try the below configuration:

 

R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
ip address 192.168.0.1 255.255.255.252
mtu 1476
tunnel source Loopback0
tunnel destination 4.4.4.4
!
!
interface GigabitEthernet0/0
ip address 200.1.1.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 1

no auto-summary
network 1.1.1.1 0.0.0.0
network 200.1.1.0 0.0.0.3 
!

router eigrp 2

no auto-summary
network 192.168.0.0 0.0.0.3

!
ip classless


R4
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Tunnel0
ip address 192.168.0.2 255.255.255.252
mtu 1476
tunnel source Loopback0
tunnel destination 1.1.1.1
!
!
interface GigabitEthernet0/0
ip address 200.1.1.10 255.255.255.252
duplex auto
speed auto
!
router eigrp 1

no auto-summary
network 4.4.4.4 0.0.0.0
network 200.1.1.8 0.0.0.3
!

router eigrp 2

no auto-summary
network 192.168.0.0 0.0.0.3

!
ip classless

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

Hello,

 

your original config had an error in the IP addressing of the tunnel, was that a typo ?

 

R1
!
interface Tunnel0
ip address 192.168.0.1 255.255.255.252
mtu 1476
tunnel source Loopback0
tunnel destination 4.4.4.4

R4
!
interface Tunnel0
ip address 192.168.1.2 255.255.255.252
mtu 1476
tunnel source Loopback0
tunnel destination 1.1.1.1

 

Either way, post the configs you currently have...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card