cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1302
Views
4
Helpful
8
Replies
Octavio Alfageme
Beginner

Enforced 'dynamic' OSPF cost in Etherchannel

Dear all,

I'm working in a network of Catalyst 4948Es. I want to enforce the ospf cost of a port-channel interface, but at the same time I want the port-channel cost to change when any of the member links fails. If I use commands like 'bandwidth' or 'ip ospf cost' on the port-channel interface the cost remains the same when a link comes down. I thought that maybe changing ospf cost of the members could influence in any way the cost of the port-channel, but it has no impact. Changing the global reference bandwidth is not an option either. At present time the only option I see is using the embeded event manager, but I would be grateful if you could suggest me another way to get this 'dynamically modified' OSPF cost for a port-channel.

Thank you

Octavio

8 REPLIES 8
Rolf Fischer
Engager

Hi Octavio,

did you configure the port-channel interfaces as a layer 3 interfaces or layer 2 + SVIs?

Regards

Rolf

Hi Rolf,

As a layer 3 interface:

interface Port-channel60

vrf forwarding DIST

ip address 10.10.10.5 255.255.255.252

ip pim query-interval 500 msec

ip pim sparse-mode

ip ospf network point-to-point

load-interval 30

carrier-delay msec 0

end

interface GigabitEthernet1/1

no switchport

dampening

load-interval 30

carrier-delay msec 0

channel-group 60 mode active

end

interface GigabitEthernet1/2

no switchport

dampening

load-interval 30

carrier-delay msec 0

channel-group 60 mode active

end

Thanks in advance

Octavio

Could you please also post a 'show ip ospf interface po60', I'd be interested in the cost for this 2Gig port-channel interface.

Did you increase the OSPF reference-bandwidth (otherwise every link >= FastEthernet will have an OSPF cost of 1) ?

Both member ports are bundled?

Regards

Rolf

Hi Rolf,

Both 4948Es have the same outputs, so I send the ones of one of them.

* Reference bw is 1Tbps

C4900A#sh run | i reference

auto-cost reference-bandwidth 1000000

* Both members are GE interfaces, son 1Tbps/2Gbps=500

C4900A#sh ip ospf interface port-channel 60

Port-channel60 is up, line protocol is up (connected)

  Internet Address 10.10.10.1/30, Area 0, Attached via Network Statement

  Process ID 1, Router ID 10.0.0.1, Network Type POINT_TO_POINT, Cost: 500

  Topology-MTID    Cost    Disabled    Shutdown      Topology Name

        0           500      no          no            Base

  Transmit Delay is 1 sec, State POINT_TO_POINT

  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

    oob-resync timeout 40

    Hello due in 00:00:01

  Supports Link-local Signaling (LLS)

  Cisco NSF helper support enabled

  IETF NSF helper support enabled

  Index 2/2, flood queue length 0

  Next 0x0(0)/0x0(0)

  Last flood scan length is 1, maximum is 1

  Last flood scan time is 0 msec, maximum is 0 msec

  Neighbor Count is 1, Adjacent neighbor count is 1

    Adjacent with neighbor 10.0.0.3

  Suppress hello for 0 neighbor(s)

* Both members are bundled:

C4900A#sh lacp internal       

Flags:  S - Device is requesting Slow LACPDUs

        F - Device is requesting Fast LACPDUs

        A - Device is in Active mode       P - Device is in Passive mode    

Channel group 60

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Gi1/1     SA      bndl      32768         0x3C      0x3C    0x3B        0x3D 

Gi1/2     SA      bndl      32768         0x3C      0x3C    0x3C        0x3D 

C4900A#sh lacp internal detail

Flags:  S - Device is requesting Slow LACPDUs

        F - Device is requesting Fast LACPDUs

        A - Device is in Active mode       P - Device is in Passive mode    

Channel group 60

Actor (internal) information:

          Actor                 Actor                       Actor

Port      System ID             Port Number     Age         Flags

Gi1/1     32768,78da.6ecb.9540  0x3B             22s        SA

          LACP Actor           Actor           Actor

          Port Priority        Oper Key        Port State

          32768                0x3C            0x3D

          Port State Flags Decode:

          Activity:   Timeout:   Aggregation:   Synchronization:

          Active      Long       Yes            Yes

          Collecting:   Distributing:   Defaulted:   Expired:

          Yes           Yes             No           No

          Actor                 Actor                       Actor

Port      System ID             Port Number     Age         Flags

Gi1/2     32768,78da.6ecb.9540  0x3C              1s        SA

          LACP Actor           Actor           Actor

          Port Priority        Oper Key        Port State

          32768                0x3C            0x3D

          Port State Flags Decode:

          Activity:   Timeout:   Aggregation:   Synchronization:

          Active      Long       Yes            Yes

          Collecting:   Distributing:   Defaulted:   Expired:

          Yes           Yes             No           No

Thanks a lot. I really appreciate your help.

Regards

Octavio

Rolf Fischer
Engager

Octavio,

you're welcome.
From what I see, everything looks like expected.
I'd assume that the cost increases to 1000 when one of the member-ports unbundles? Would that solve your reqirements?

HTH
Rolf

Sent from Cisco Technical Support Android App

Hi Rolf,

It's as you described. If I shut down one GE interface, the cost is 1000.

The point is that I would like to go one step beyond. I would like to have a cost for the same port-channel of 4000 and, if one GE fails, I want it to be 8000. I tried several things:

* "ip ospf cost 4000" on the port-channel. If one GE comes down, the cost remains the same

* "ip ospf cost 8000" on both GE members. It has no impact on the cost of the port-channel, as it is 500

* "banwidth 250Mbps" on both GE members to get a cost of 4000 per link. It has no impact on the cost of the port-channel, as it is 500

I can not change the cost of the port-channel and, at the same time, keep its dependancy with the number of active member links.

The only option I find is making a script with the Embedded Event Manager to track both GE members and, if one fails, change the cost of the port-channel.

Thank you

Octavio

Octavio,

o.k., now I understand. Sorry for beeing somewhat slow-witted.

Perhaps somebody else can provide a solution, but I think you've already tried everything possible with standard-IOS.

If the all-or-nothing approach of the port-channel min-links command is no option, I'd also use EEM to solve this.

The EC-5-BUNDLE/UNBUNDLE syslog messages look promising to trigger an applet/script.

Regards

Rolf

Thank you very much, Rolf. I really appreciate your guidance to verify that everything was as it should be. Thanks a lot for the syslog message to track, too. Really useful.

Thanks a lot

Octavio