cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
115
Views
0
Helpful
0
Replies
Highlighted
Beginner

Failover does not happen for the traffic from remote sites when using OSPF default route originate

Failover does not happen for the traffic from remote sites when using OSPF default route originate

 

Basically, I have OSPF configured to send the default route to 2 other building routers. And that works, but this main site has 2 ISPs, and when the primary stops working, and the track makes it failover to the secondary ISP, then something is amiss and the traffic coming from the other buildings keeps being sent over the primary ISP interface (FA0), and being NATed to it, instead of starting being sent through the secondary ISP(FA1) and NATed to the new destination. 

 

About traffic from the main building, when the failover happens, it does failover and the traffic goes through and get nated with the secondary ISP information:

 

Here is related information: 

ip route 0.0.0.0 0.0.0.0 50.231.19.233 track 10
ip route 0.0.0.0 0.0.0.0 50.244.85.54 100 track 20

 

ip nat inside source route-map NAT_ADSL interface FastEthernet1 overload
ip nat inside source route-map NAT_ADSL_2 interface FastEthernet0 overload
ip nat inside source route-map NAT_OTHER_SITES interface FastEthernet1 overload
ip nat inside source route-map NAT_OTHER_SITES_2 interface FastEthernet0 overload

 


route-map NAT_ADSL permit 1
 match ip address NAT_OVER_ADSL
 match interface FastEthernet1
!
route-map NAT_OTHER_SITES_2 permit 1
 match ip address NAT_FROM_OTHER_SITES
 match interface FastEthernet1
!
route-map NAT_OTHER_SITES permit 1
 match ip address NAT_FROM_OTHER_SITES
 match interface FastEthernet0
!
route-map NAT_ADSL_2 permit 1
 match ip address NAT_OVER_ADSL
 match interface FastEthernet0

 

 


ip access-list extended NAT_FROM_OTHER_SITES
 deny   ip 10.1.1.0 0.0.0.255 any
 deny   ip 10.89.51.0 0.0.0.255 10.87.145.0 0.0.0.255
 deny   ip 10.89.51.0 0.0.0.255 10.87.144.0 0.0.0.255
 deny   ip 10.89.51.0 0.0.0.255 10.87.10.0 0.0.0.255
 deny   ip 10.89.51.0 0.0.0.255 10.95.146.0 0.0.0.255
 deny   ip 10.89.51.0 0.0.0.255 10.89.82.0 0.0.0.255
 deny   ip 10.89.51.0 0.0.0.255 10.89.100.0 0.0.0.255
 deny   ip 10.89.51.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.89.51.0 0.0.0.255 10.87.122.0 0.0.0.255
 permit ip 10.89.51.0 0.0.0.255 any
 deny   ip 10.89.90.0 0.0.0.255 10.87.145.0 0.0.0.255
 deny   ip 10.89.90.0 0.0.0.255 10.87.144.0 0.0.0.255
 deny   ip 10.89.90.0 0.0.0.255 10.87.10.0 0.0.0.255
 deny   ip 10.89.90.0 0.0.0.255 10.95.146.0 0.0.0.255
 deny   ip 10.89.90.0 0.0.0.255 10.89.82.0 0.0.0.255
 deny   ip 10.89.90.0 0.0.0.255 10.89.100.0 0.0.0.255
 deny   ip 10.89.90.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.89.90.0 0.0.0.255 10.87.122.0 0.0.0.255
 permit ip 10.89.90.0 0.0.0.255 any
 deny   ip 10.68.71.0 0.0.0.255 10.87.145.0 0.0.0.255
 deny   ip 10.68.71.0 0.0.0.255 10.87.144.0 0.0.0.255
 deny   ip 10.68.71.0 0.0.0.255 10.87.10.0 0.0.0.255
 deny   ip 10.68.71.0 0.0.0.255 10.95.146.0 0.0.0.255
 deny   ip 10.68.71.0 0.0.0.255 10.89.82.0 0.0.0.255
 deny   ip 10.68.71.0 0.0.0.255 10.89.100.0 0.0.0.255
 deny   ip 10.68.71.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.68.71.0 0.0.0.255 10.87.122.0 0.0.0.255
 permit ip 10.68.71.0 0.0.0.255 any
 deny   ip 10.89.62.0 0.0.0.255 10.87.145.0 0.0.0.255
 deny   ip 10.89.62.0 0.0.0.255 10.87.144.0 0.0.0.255
 deny   ip 10.89.62.0 0.0.0.255 10.87.10.0 0.0.0.255
 deny   ip 10.89.62.0 0.0.0.255 10.95.146.0 0.0.0.255
 deny   ip 10.89.62.0 0.0.0.255 10.89.82.0 0.0.0.255
 deny   ip 10.89.62.0 0.0.0.255 10.89.100.0 0.0.0.255
 deny   ip 10.89.62.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.89.62.0 0.0.0.255 10.87.122.0 0.0.0.255
 permit ip 10.89.62.0 0.0.0.255 any
 deny   ip 10.89.250.0 0.0.0.255 10.87.145.0 0.0.0.255
 deny   ip 10.89.250.0 0.0.0.255 10.87.144.0 0.0.0.255
 deny   ip 10.89.250.0 0.0.0.255 10.87.10.0 0.0.0.255
 deny   ip 10.89.250.0 0.0.0.255 10.95.146.0 0.0.0.255
 deny   ip 10.89.250.0 0.0.0.255 10.89.82.0 0.0.0.255
 deny   ip 10.89.250.0 0.0.0.255 10.89.100.0 0.0.0.255
 deny   ip 10.89.250.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.89.250.0 0.0.0.255 10.87.122.0 0.0.0.255
 permit ip 10.89.250.0 0.0.0.255 any
 deny   ip 10.89.147.0 0.0.0.255 10.87.145.0 0.0.0.255
 deny   ip 10.89.147.0 0.0.0.255 10.87.144.0 0.0.0.255
 deny   ip 10.89.147.0 0.0.0.255 10.87.10.0 0.0.0.255
 deny   ip 10.89.147.0 0.0.0.255 10.95.146.0 0.0.0.255
 deny   ip 10.89.147.0 0.0.0.255 10.89.82.0 0.0.0.255
 deny   ip 10.89.147.0 0.0.0.255 10.89.100.0 0.0.0.255
 deny   ip 10.89.147.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.89.147.0 0.0.0.255 10.87.122.0 0.0.0.255
 permit ip 10.89.147.0 0.0.0.255 any
 deny   ip 10.89.132.0 0.0.0.255 10.87.145.0 0.0.0.255
 deny   ip 10.89.132.0 0.0.0.255 10.87.144.0 0.0.0.255
 deny   ip 10.89.132.0 0.0.0.255 10.87.10.0 0.0.0.255
 deny   ip 10.89.132.0 0.0.0.255 10.95.146.0 0.0.0.255
 deny   ip 10.89.132.0 0.0.0.255 10.89.82.0 0.0.0.255
 deny   ip 10.89.132.0 0.0.0.255 10.89.100.0 0.0.0.255
 deny   ip 10.89.132.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.89.132.0 0.0.0.255 10.87.122.0 0.0.0.255
 permit ip 10.89.132.0 0.0.0.255 any
 deny   ip 10.89.10.0 0.0.0.255 10.87.145.0 0.0.0.255
 deny   ip 10.89.10.0 0.0.0.255 10.87.144.0 0.0.0.255
 deny   ip 10.89.10.0 0.0.0.255 10.87.10.0 0.0.0.255
 deny   ip 10.89.10.0 0.0.0.255 10.95.146.0 0.0.0.255
 deny   ip 10.89.10.0 0.0.0.255 10.89.82.0 0.0.0.255
 deny   ip 10.89.10.0 0.0.0.255 10.89.100.0 0.0.0.255
 deny   ip 10.89.10.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.89.10.0 0.0.0.255 10.87.122.0 0.0.0.255
 permit ip 10.89.10.0 0.0.0.255 any
ip access-list extended NAT_OVER_ADSL
 remark **NAT Over ISP**
 deny   ip 10.1.1.0 0.0.0.255 any
 deny   ip 10.87.145.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.87.145.0 0.0.0.255 10.87.122.0 0.0.0.255
 deny   ip 10.87.144.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.87.144.0 0.0.0.255 10.87.122.0 0.0.0.255
 deny   ip 10.87.10.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.87.10.0 0.0.0.255 10.87.122.0 0.0.0.255
 deny   ip 10.95.146.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.95.146.0 0.0.0.255 10.87.122.0 0.0.0.255
 deny   ip 10.89.82.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.89.100.0 0.0.0.255 10.90.82.0 0.0.0.255
 deny   ip 10.89.100.0 0.0.0.255 10.87.122.0 0.0.0.255
 permit ip 10.87.122.0 0.0.0.255 any
 permit ip 10.89.82.0 0.0.0.255 any
 permit ip 10.89.100.0 0.0.0.255 any
 permit ip 10.87.145.0 0.0.0.255 any
 permit ip 10.87.144.0 0.0.0.255 any
 permit ip 10.95.146.0 0.0.0.255 any
 permit ip 10.87.10.0 0.0.0.255 any

 

It seems to be a problem with the routing of the traffic coming from the additional buildings after it reached the primary building

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards