cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1742
Views
5
Helpful
8
Replies
Highlighted
Beginner

Frame Relay Help!! (CCIE Voice Lab)

Hello everyone, this is my first post so sorry if I posted in the wrong area, but here is a little info on my situation:

I have (3) 2811 connected via frame relay switch (3745).

The 3745 has (3) VWIC-2MFT-T1's

HQ 2811 has (1) VWIC2-2MFT-T1/E1

Branch1 2811 has (1) WIC-1DSU-T1 V2 and (1) VWIC2-1MFT-T1/E1

Branch1 2811 has (1) WIC-1DSU-T1 V2 and (1) VWIC2-1MFT-T1/E1

The plan was to have the 3745 as my PSTN and Frame Relay switch. I have tried to use the DSU card and the VWIC on the 2811 for frame relay and neither of them ends up working. I also tried setting the clock rate on the frame relay switch interfaces, but I keep getting the "This command applies only to DCE interfaces" error even though I have the "frame-relay intf-type dce" command on all of the interfaces. So right now I have the individual sites suppling the clock rate. Any help would be greatly appreciated!!!

Here is the config below for my frame relay topology:

Frame-Relay Switch:

frame-relay switching

!

!

!

controller T1 0/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 0/2

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

interface Serial0/0:0

description Link to HQ-RTR

no ip address

encapsulation frame-relay

frame-relay intf-type dce

frame-relay route 102 interface Serial0/2:0 201

!

interface Serial0/2:0

description Link to B1

no ip address

encapsulation frame-relay

frame-relay intf-type dce

frame-relay route 201 interface Serial0/0:0 102

------------------------------------------------------------------------

HQ:

interface Serial0/0/0:0

no ip address

encapsulation frame-relay

frame-relay lmi-type cisco

frame-relay intf-type dce

!

interface Serial0/0/0:0.12 point-to-point

ip address 10.1.1.1 255.255.255.252

frame-relay interface-dlci 102  

------------------------------------------------------------------------

Branch1:

interface Serial0/1/0:0

no ip address

encapsulation frame-relay

frame-relay lmi-type cisco

frame-relay intf-type dce

!

interface Serial0/1/0:0.12 point-to-point

ip address 10.1.1.2 255.255.255.252

frame-relay interface-dlci 201

8 REPLIES 8
Highlighted
Hall of Fame Master

Hello Rashad,

only the side that has the DCE cable can provide the clock. This is not related to the OSI layer 2 FR  DCE role as you have seen

You can check with

show controller serial

it tells you what type of cable is connected to it.

(note not all platforms support this)

>> I have tried to use the DSU card and the VWIC on the 2811 for frame relay and neither of them ends up working

I'm not a VOIP expert but that initial V stands for Voice so the modules are not thought for data services like FR is, but for voice related services. So I would say it is expected what you see.

see

http://www.cisco.com/en/US/products/ps5854/products_data_sheets_list.html

Hope to help

Giuseppe

Highlighted

Hello Giuseppe,

Well since I am just using a T1 crossover cable, does it still matter which side plugs int the other? I have tried switching ends around but I still can't get a connection.

I read some other post of people actually using these cards for FR, so I think they can be used successfully....

Here is a output from "show frame-relay lmi" and "show frame-relay pvc" It appears as there hasn't been any lmi's sent.. Do you have any other pointers I can try?

HQ-RTR#sho frame-relay lmi

LMI Statistics for interface Serial0/0/0:0 (Frame Relay DCE) LMI TYPE = CISCO

  Invalid Unnumbered info 0             Invalid Prot Disc 0

  Invalid dummy Call Ref 0              Invalid Msg Type 0

  Invalid Status Message 0              Invalid Lock Shift 0

  Invalid Information ID 0              Invalid Report IE Len 0

  Invalid Report Request 0              Invalid Keep IE Len 0

  Num Status Enq. Rcvd 0                Num Status msgs Sent 0

  Num Update Status Sent 0              Num St Enq. Timeouts 446

HQ-RTR#sho fram

HQ-RTR#sho frame-relay pvc

PVC Statistics for interface Serial0/0/0:0 (Frame Relay DCE)

              Active     Inactive      Deleted       Static

  Local          0            1            0            0

  Switched       0            0            0            0

  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0/0/0:0.12

  input pkts 0             output pkts 2            in bytes 0        

  out bytes 728            dropped pkts 0           in pkts dropped 0        

  out pkts dropped 0                out bytes dropped 0        

  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        

  out BECN pkts 0          in DE pkts 0             out DE pkts 0        

  out bcast pkts 2         out bcast bytes 728      

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  pvc create time 01:51:55, last time pvc status changed 01:51:24

Highlighted

Hello
Have a look at this link

http://dreamforccie.wordpress.com/2010/03/22/convert-your-e1t1-pri-to-serial-interface/

Res
Paul

Sent from Cisco Technical Support iPad App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Hi,

That is getting me closer to the finish line. On the branch routers I am actually able to see LMI packets being sent to the frame relay switch:

HQ-RTR#sho frame-relay lmi

LMI Statistics for interface Serial0/0/0:0 (Frame Relay DTE) LMI TYPE = ANSI

  Invalid Unnumbered info 0             Invalid Prot Disc 0

  Invalid dummy Call Ref 0              Invalid Msg Type 0

  Invalid Status Message 0              Invalid Lock Shift 0

  Invalid Information ID 0              Invalid Report IE Len 0

  Invalid Report Request 0              Invalid Keep IE Len 0

  Num Status Enq. Sent 207              Num Status msgs Rcvd 0

  Num Update Status Rcvd 0              Num Status Timeouts 207

  Last Full Status Req 00:00:06         Last Full Status Rcvd never

HQ-RTR#

However, the Frame relay switch (below) is not receiving or sending LMI packets.....Any ideas about that? I think a major reason is because I can't change the clocking on the frame relay switch interfaces.

PSTN_FR_Router#sho frame-relay lmi

LMI Statistics for interface Serial0/0:0 (Frame Relay DCE) LMI TYPE = ANSI

  Invalid Unnumbered info 0             Invalid Prot Disc 0

  Invalid dummy Call Ref 0              Invalid Msg Type 0

  Invalid Status Message 0              Invalid Lock Shift 0

  Invalid Information ID 0              Invalid Report IE Len 0

  Invalid Report Request 0              Invalid Keep IE Len 0

  Num Status Enq. Rcvd 0                Num Status msgs Sent 0

  Num Update Status Sent 0              Num St Enq. Timeouts 486

LMI Statistics for interface Serial0/2:0 (Frame Relay DCE) LMI TYPE = ANSI

  Invalid Unnumbered info 0             Invalid Prot Disc 0

  Invalid dummy Call Ref 0              Invalid Msg Type 0

  Invalid Status Message 0              Invalid Lock Shift 0

  Invalid Information ID 0              Invalid Report IE Len 0

  Invalid Report Request 0              Invalid Keep IE Len 0

  Num Status Enq. Rcvd 0                Num Status msgs Sent 0

  Num Update Status Sent 0              Num St Enq. Timeouts 488


Highlighted

Hello

sh controllers T1 | in Clock

  Framing is ESF, Line Code is B8ZS, Clock Source is Line

controller T1 0/0/0

clock source line primary

channel-group 0 timeslots 1-24 speed 64

sh controllers T1 | in Clock

  Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Hello Paul,

let me add that one side L1 DTE is configured with clock source line and the other side L1 DCE is configured with clock source internal at controller E1/T1 level.

I have checked my old tests and with old E1 ports I was able to use channel-group unframed to get a sync serial interface from an E1.

controller E1 2/4

channel-group 0 unframed

!

controller E1 2/5

channel-group 0 unframed

!

interface Serial2/4:0

ip address 40.40.40.1 255.255.255.252

no ip directed-broadcast

!

interface Serial2/5:0

ip address 50.50.50.1 255.255.255.252

no ip directed-broadcast

!

I don't remember why CEF was disabled

Some of the modern cards do not support the unframed option.

This was  an 8 E1 port adapter installed in a C7200 standard non VXR with NPE 200.

Hope to help

Giuseppe

Highlighted

Cheers Giuseppe

Truthfully honest never setup e/t1 for frs.

Just trying to assist rashad if possible by thinking in terms of hardwiring the controller to dce.

Nice to learn something from this posting.

Res
Paul

Sent from Cisco Technical Support iPad App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Advisor

Hi,

the clock-rate command is configured on L1 DCE seen with sh controllers command.

the frame-relay intf-type dce is a L2 DCE not a L1 DCE config and it can be configured on a L1 DTE side.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.