cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1325
Views
0
Helpful
2
Replies

Frame Relay on NBMA

abhijit379
Level 1
Level 1

I am trying to simulate a Frame Relay topology on a NBMA network.

I am posting the details of sh Running config, sh Frame-relay Map, sh ip int brief, show ip route and ping result of all three routers. Could any one please give me any idea, why East router cant ping west router. Show ip route is showing all the routes properly.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------

HQ#show running-config
Building configuration...

Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 multipoint
ip address 172.16.124.1 255.255.255.248
no ip split-horizon eigrp 25
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 103 broadcast
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 25
network 10.1.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
!
no ip http server
ip classless
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

HQ#show frame-relay map
Serial0/0.1 (up): ip 172.16.124.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial0/0.1 (up): ip 172.16.124.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active

HQ#show ip int brief
Interface                      IP-Address        OK?  Method  Status                Protocol


FastEthernet0/0            unassigned      YES NVRAM    administratively down down


Serial0/0                       unassigned      YES NVRAM    up                    up


Serial0/0.1                    172.16.124.1    YES NVRAM    up                    up


FastEthernet0/1            unassigned      YES NVRAM    administratively down down


Serial0/1                       unassigned      YES NVRAM    administratively down down


Loopback1                    10.1.1.1          YES NVRAM    up                    up 
Loopback2                    10.1.2.1          YES NVRAM    up                    up 
Loopback3                    10.1.3.1          YES NVRAM    up                    up

HQ#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0.1
     10.0.0.0/24 is subnetted, 9 subnets
D       10.3.1.0 [90/2297856] via 172.16.124.3, 00:08:37, Serial0/0.1
C       10.1.3.0 is directly connected, Loopback3
D       10.2.1.0 [90/2297856] via 172.16.124.2, 00:08:37, Serial0/0.1
C       10.1.2.0 is directly connected, Loopback2
D       10.3.3.0 [90/2297856] via 172.16.124.3, 00:08:37, Serial0/0.1
D       10.2.2.0 [90/2297856] via 172.16.124.2, 00:08:37, Serial0/0.1
C       10.1.1.0 is directly connected, Loopback1
D       10.3.2.0 [90/2297856] via 172.16.124.3, 00:08:37, Serial0/0.1
D       10.2.3.0 [90/2297856] via 172.16.124.2, 00:08:37, Serial0/0.1
HQ#

HQ#ping 172.16.124.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/42/108 ms

HQ#ping 172.16.124.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/30/72 ms
HQ#

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

East#show run
Building configuration...

Current configuration : 1077 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname East
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
!
interface Loopback1
ip address 10.2.1.1 255.255.255.0
!
interface Loopback2
ip address 10.2.2.1 255.255.255.0
!
interface Loopback3
ip address 10.2.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 multipoint
ip address 172.16.124.2 255.255.255.248
no ip split-horizon eigrp 25
frame-relay map ip 172.16.124.1 201 broadcast
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 25
network 10.2.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
!
no ip http server
ip classless
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

East#show frame-relay map
Serial0/0.1 (up): ip 172.16.124.1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active

East#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
Serial0/0                  unassigned      YES NVRAM  up                    up 
Serial0/0.1                172.16.124.2    YES NVRAM  up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/1                  unassigned      YES NVRAM  administratively down down
Loopback1                  10.2.1.1        YES NVRAM  up                    up 
Loopback2                  10.2.2.1        YES NVRAM  up                    up 
Loopback3                  10.2.3.1        YES NVRAM  up                    up

East#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0.1
     10.0.0.0/24 is subnetted, 9 subnets
D       10.3.1.0 [90/2809856] via 172.16.124.1, 00:12:16, Serial0/0.1
D       10.1.3.0 [90/2297856] via 172.16.124.1, 00:12:16, Serial0/0.1
C       10.2.1.0 is directly connected, Loopback1
D       10.1.2.0 [90/2297856] via 172.16.124.1, 00:12:16, Serial0/0.1
D       10.3.3.0 [90/2809856] via 172.16.124.1, 00:12:16, Serial0/0.1
C       10.2.2.0 is directly connected, Loopback2
D       10.1.1.0 [90/2297856] via 172.16.124.1, 00:12:16, Serial0/0.1
D       10.3.2.0 [90/2809856] via 172.16.124.1, 00:12:16, Serial0/0.1
C       10.2.3.0 is directly connected, Loopback3

East#ping 172.16.124.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/66/112 ms

East#ping 172.16.124.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

East#

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------

West#show running-config
Building configuration...

Current configuration : 1077 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname West
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
!
interface Loopback1
ip address 10.3.1.1 255.255.255.0
!
interface Loopback2
ip address 10.3.2.1 255.255.255.0
!
interface Loopback3
ip address 10.3.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 multipoint
ip address 172.16.124.3 255.255.255.248
no ip split-horizon eigrp 25
frame-relay map ip 172.16.124.1 301 broadcast
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 25
network 10.3.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
!
no ip http server
ip classless
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

West#show frame-relay map
Serial0/0.1 (up): ip 172.16.124.1 dlci 301(0x12D,0x48D0), static,
              broadcast,
              CISCO, status defined, active

West#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
Serial0/0                  unassigned      YES NVRAM  up                    up 
Serial0/0.1                172.16.124.3    YES NVRAM  up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/1                  unassigned      YES NVRAM  administratively down down
Loopback1                  10.3.1.1        YES NVRAM  up                    up 
Loopback2                  10.3.2.1        YES NVRAM  up                    up 
Loopback3                  10.3.3.1        YES NVRAM  up                    up

West#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0.1
     10.0.0.0/24 is subnetted, 9 subnets
C       10.3.1.0 is directly connected, Loopback1
D       10.1.3.0 [90/2297856] via 172.16.124.1, 00:17:02, Serial0/0.1
D       10.2.1.0 [90/2809856] via 172.16.124.1, 00:16:51, Serial0/0.1
D       10.1.2.0 [90/2297856] via 172.16.124.1, 00:17:02, Serial0/0.1
C       10.3.3.0 is directly connected, Loopback3
D       10.2.2.0 [90/2809856] via 172.16.124.1, 00:16:51, Serial0/0.1
D       10.1.1.0 [90/2297856] via 172.16.124.1, 00:17:02, Serial0/0.1
C       10.3.2.0 is directly connected, Loopback2
D       10.2.3.0 [90/2809856] via 172.16.124.1, 00:16:51, Serial0/0.1

West#ping 172.16.124.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/28/40 ms

West#ping 172.16.124.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Why my East router cant ping West router and vice versa..???

Split-Horizon has been disabled.

Please reply back.

1 Accepted Solution

Accepted Solutions

cadet alain
VIP Alumni
VIP Alumni

Hi,

You have a Hub and spoke topology so you also need to put a frame-relay map statement for the other spoke on each spoke:

on EAST: frame-relay map ip 172.16.124.3 201 broadcast

on WEST: frame-relay map ip 172.16.124.2 301 broadcast

with these 2 your pings will work.

Regards.

Alain.

Don't forget to rate helpful posts.

View solution in original post

2 Replies 2

cadet alain
VIP Alumni
VIP Alumni

Hi,

You have a Hub and spoke topology so you also need to put a frame-relay map statement for the other spoke on each spoke:

on EAST: frame-relay map ip 172.16.124.3 201 broadcast

on WEST: frame-relay map ip 172.16.124.2 301 broadcast

with these 2 your pings will work.

Regards.

Alain.

Don't forget to rate helpful posts.

Thankyou... You are 100% right..

Thanks

Review Cisco Networking products for a $25 gift card