cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
275
Views
0
Helpful
6
Replies
a.khosravani1
Beginner

GRE-PROMBLEM

Two tunnel is configured on a router the source and destination of the tunnel is on one destination
And we have one vrf That one of these tunnels inside to vrf
And dynamic routing configure On two tunnels
But one of tunnel down then when configure mode ipip on one of tunnel is becomes up

 

what is the problem???

 

 

Router-2

interface Tunnel3
ip vrf forwarding src
ip address 10.10.23.2 255.255.255.0
tunnel source 192.168.24.1
tunnel destination 192.168.34.1
!
interface Tunnel10
ip vrf forwarding ali
ip address 172.20.20.1 255.255.255.0
ip virtual-reassembly in
tunnel source 192.168.24.1
tunnel destination 192.168.34.1
!
interface GigabitEthernet0/0
ip address 192.168.24.1 255.255.255.0
ip mtu 1400
duplex auto
speed auto
media-type rj45

media-type rj45
!
!
router eigrp 10
network 2.2.2.0 0.0.0.255
network 10.10.12.0 0.0.0.255
network 10.10.23.0 0.0.0.255
!
router ospf 10 vrf ali
network 172.20.20.0 0.0.0.255 area 0

 

 

 

 

 


Router-3
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Loopback1
no ip address
!
interface Tunnel0
ip address 10.10.23.3 255.255.255.0
tunnel source 192.168.34.1
tunnel destination 192.168.24.1
!
interface Tunnel10
ip vrf forwarding ali
ip address 172.20.20.2 255.255.255.0
ip virtual-reassembly in
tunnel source 192.168.34.1
tunnel destination 192.168.24.1
!
interface GigabitEthernet0/0
ip address 192.168.34.1 255.255.255.0
ip mtu 1400
duplex auto
speed auto
media-type rj45
!

media-type rj45
!
router eigrp 10
network 10.10.23.0 0.0.0.255
!
router ospf 10 vrf ali
network 172.20.20.0 0.0.0.255 area 0
!

 

6 REPLIES 6
MHM Cisco World
Collaborator

eigrp must be also in VRF since the tunnel is VRF.

I configure tunnel key and my problem solve

many thanks for help me

Harold Ritter
Cisco Employee

You should use a different src/dest pair for each tunnel. Configure a separate loopback interface for each tunnel and use it as the source.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

I configure tunnel key and my problem solve.

many thanks for help me.

Georg Pauwen
VIP Expert

Hello,

 

I lab tested this, looks like the route replication marked in bold brings all tunnels up. I have made some assumptions about the rd values being used, but give the below a try:

 

Router-2

 

ip vrf ali
rd 2:2
--> route-replicate from vrf src unicast all
--> route-replicate from vrf global unicast all
!
ip vrf src
rd 1:1
--> route-replicate from vrf ali unicast all
--> route-replicate from vrf global unicast all

 

Router-3

 

ip vrf ali
rd 2:2
--> route-replicate from vrf global unicast all

I configure tunnel key and my problem solve.

many thanks for help me