cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
7620
Views
20
Helpful
15
Replies
Highlighted
Beginner

Re: GRE Tunnel on HSRP

this is eleven years old, i know - since the accepted solution is not 100% correct anymore, i'd like to add

* using a HSRP-IP as Tunnel-Source at a DMVPN-Hub works at least in IOS-XE 16.9 as a charm

 

My setup provides a backup-vpn-solution which has to be first as simple as possible and it should provide some level of redundancy within this backup-hubs - dual-dmvpn-hub-setup [usually prefererred] would add an unnecessary level of complexity.

 

 

interface GigabitEthernet0/0/0
 ip address 172.16.0.3 255.255.255.248
 ip mtu 1456
 standby 0 ip 172.16.0.2
 standby 0 priority 252
 standby 0 preempt
 service-policy output PM_SHAPE_300

interface Tunnel0
 ip address 172.17.0.1 255.255.248.0
 no ip redirects
 ip mtu 1500
 ip nhrp network-id 1
 ip ospf network broadcast
 ip ospf flood-reduction
 ip ospf 1 area 0
 nhrp map group DSL50 service-policy output PM50
 cdp enable
 tunnel source 172.16.0.2
 tunnel mode gre multipoint
 tunnel key 1
end