cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
294
Views
0
Helpful
1
Replies

Help me to configure MPLS VPN 1 site Rip and 1 site OSPF

cuongbenky
Beginner
Beginner

Hi everybody.

I have a problem with my assignment. Can you help me?

I have a topology of MPLS VPN like this

And my problem is my teacher ask me to configure one site with RIP routing protocol between PE1 and CPE1; another one with OSPF routing protocol between PE2 and CPE2. And this is my problem, i dont know how to do that. If configure two site RIP-RIP or OSPF-OSPF, i can practice immetately but with this problem, i dont know how to start.

Anyone can help me? I'm very apreciate your help.

This is my basic configuration:

Configuration PE1(RIP):



hostname PE1

no ip domain lookup

ip http server



interface loopback 0

ip address 10.0.1.1 255.255.255.255

exit



interface serial 1/0

ip address 10.0.12.1 255.255.255.0

clock rate 64000

no shutdown

exit


router ospf 1

network 10.0.0.0 0.255.255.255 area 0

exit



mpls ldp router-id loopback0 force



interface serial1/0ư

mpls label protocol ldp

mpls ip

exit



ip vrf A

rd 100:1

route-target both 1:100

exit



interface fastethernet 0/0

ip vrf forwarding A

ip address 172.16.100.1 255.255.255.0

no shut

exit



router rip

version 2

address-family ipv4 vrf A

no auto-summary

network 172.16.0.0

redistribute bgp 100 metric transpa

exit

exit



router bgp 100

neighbor 10.0.4.1 remote-as 100

neighbor 10.0.4.1 update-source loopback0

address-family vpnv4

neighbor 10.0.4.1 activate

neighbor 10.0.4.1 send-community both

exit

address-family ipv4 vrf A

redistribute rip

no auto-summary

exit

exit



Configuration PE2 (OSPF):



hostname PE1

no ip domain lookup

ip http server



interface loopback 0

ip address 10.0.4.1 255.255.255.255

exit



interface serial 1/0

ip address 10.0.23.1 255.255.255.0

clock rate 64000

no shutdown

exit


router ospf 1

network 10.0.0.0 0.255.255.255 area 0

exit



mpls ldp router-id loopback0 force



interface serial1/0

mpls label protocol ldp

mpls ip

exit



ip vrf A

rd 100:1

route-target both 1:100

exit



interface fastethernet 0/0

ip vrf forwarding A

ip address 172.16.200.1 255.255.255.0

no shut

exit



router ospf 2 vrf A

network 172.16.0.0 0.0.255.255 area 0

redistribute bgp 100 subnets

exit



router bgp 100

neighbor 10.0.1.1 remote-as 100

neighbor 10.0.1.1 update-source loopback0

address-family vpnv4

neighbor 10.0.1.1 activate

neighbor 10.0.1.1 send-community both

exit

address-family ipv4 vrf A

redistribute ospf 2

no auto-summary

exit

exit

1 Reply 1

lmediavilla
Beginner
Beginner

oh interesting, try this on PE2


router ospf 2 vrf A

network 172.16.0.0 0.0.255.255 area 0

redistribute bgp 100 subnets

capability vrf-lite

exit


interface serial 1/0

ip vrf forwarding A

ip address 10.0.23.1 255.255.255.0

clock rate 64000

no shutdown

exit

And on PE1

interface serial 1/0

ip vrf forwarding A

ip address 10.0.12.1 255.255.255.0

clock rate 64000

no shutdown

exit

router rip

version 2

address-family ipv4 vrf A

no auto-summary

network 172.16.0.0

redistribute bgp 100 metric 10 ! transparent not a good idea since rip max metric is 15

exit

Kind regards

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers