cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3261
Views
18
Helpful
13
Replies

help with a 2621 cisco router

richard pititto
Level 1
Level 1

hello ive been running into a serious problem with  my router.  Im inexeperienced with cisco routers and learned a little bit in college.  What i was wondering was how to get the internet to my computer with my router.  My setup is

Internet -> router -> switch -> cisco 2621  -> pc

and i was first wondering is this really possible, i have a good feeling it is but its weird i could not find anying on it on the internet, atleast that would be helpful.  I was recently on a chat room and they told me that i have to setup a static route with the first router to the 2621 and setup a defualt route back to the first router.  Now i tried doing that with my E1200 cisco linksys router but it keeps saying invalid static router.  If that is the basic idea than could someone please tell my how to do this or if its not could you again tell me how to do it mor give me some commands or pointers.  My main problem is I have two ethernet ports, fa0/0 and fa0/1 and im not sure how to get my router to communicate these two ports so my pc can get the internet, any questions please ask and if you want to see my show run you can but im prob gonna change it anyway

thanks for the help

1 Accepted Solution

Accepted Solutions

Hi,

Internet -> router -> switch -> cisco 2621  -> pc

Your linksys router is a dhcp server with a scope in same subnet as the LAN interface( I suppose it is 192.168.1.0/24) so on the Cisco router interface connecting to the switch configure this:

int f0/0

ip address dhcp

on the other interface connected to your PC:

int f0/1

ip address 192.168.2.254 255.255.255.0

no shut

Now to NAT on the Cisco router:

int f0/1

ip nat inside

int f0/0

ip nat outside

access-list 1 permit 192.168.2.0 0.0.0.255

ip nat inside source list 1 interface f0/0

ip route 0.0.0.0 0.0.0.0 dhcp

to configure dhcp for the PC on the Cisco router:

ip dhcp excluded-address 192.168.2.254

no ip dhcp conflict

ip dhcp pool mypool

network 192.168.2.0 255.255.255.0

default-router 192.168.2.254

dns-server x.x.x.x y.y.y.y  where x.x.x.x and y.y.y.y  are  ISP dns servers or if linksys is configured as cache server then put the LAN IP of the linksys router

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

13 Replies 13

Abzal
Level 7
Level 7

Hi,

Here is simple config as example.

PCs config:

192.168.0.2/24

gateway: 192.168.0.1

2621 config:

conf t

int f0/0

desc Connected to PC

ip add 192.168.0.1 255.255.255.0

no shut

int f0/1

desc Connected to switch

ip add 192.168.1.2 255.255.255.248

no shut

ip route 0.0.0.0 0.0.0.0 192.168.1.1

end

Router config (connected to Internet):

conf t

int f0/0

desc LAN

ip add 192.168.1.1 255.255.255.248

no shut

ip nat inside

int f0/1

desc Internet

ip add 1.1.1.2 255.255.255.252

no shut

ip nat outside

access-list 10 permit 192.168.0.0 0.0.0.255

ip nat inside source list 10 interface f0/1 overload

ip route 0.0.0.0 0.0.0.0 1.1.1.1

ip route 192.168.0.0 0.0.0.255 192.168.1.2

end

On switch you just need to make sure that ports of both routers on the same VLAN. For example:

conf t

vlan 10

int g1/0/2

desc Connected to 2621

switchport mode access

switchport access vlan 10

spanning-tree portfast

int g1/0/1

desc Connected Internet router

switchport mode access

switchport access vlan 10

spanning-tree portfast

int vlan 10

desc Mgmt

ip add 192.168.1.3 255.255.255.248

no shut

end

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal

ok thats good thanks for the help i must have forgot to menthion however the router conneected to the internet and the switch are regular equipment and are not programmable, the router is a E1200 linksys and the switch is a FVS318 netgear and im have problems setting up the static route with the E1200 and im not sure how to do the switch too

thanks

also i dont think my witch sees my 2621 is there a reason why that is?

First check your e1200 router.
Wich subnet is used there?
Possibly you need to configure your interface facing the e1200 as dhcp client?
And reconfigure the other interface to use a different subnet than the e1200.

Sent from Cisco Technical Support iPad App

thanks for the advice, i tried setting up nat on the 2621, no luck, the subnet on the 2621 is 255.255.255.0

how would i go about configuring the interface as dhcp and would that get the e1200 or switch to see my 2621 also why would i configure the other interface to use a different subnet?

thanks

Hi,

Internet -> router -> switch -> cisco 2621  -> pc

Your linksys router is a dhcp server with a scope in same subnet as the LAN interface( I suppose it is 192.168.1.0/24) so on the Cisco router interface connecting to the switch configure this:

int f0/0

ip address dhcp

on the other interface connected to your PC:

int f0/1

ip address 192.168.2.254 255.255.255.0

no shut

Now to NAT on the Cisco router:

int f0/1

ip nat inside

int f0/0

ip nat outside

access-list 1 permit 192.168.2.0 0.0.0.255

ip nat inside source list 1 interface f0/0

ip route 0.0.0.0 0.0.0.0 dhcp

to configure dhcp for the PC on the Cisco router:

ip dhcp excluded-address 192.168.2.254

no ip dhcp conflict

ip dhcp pool mypool

network 192.168.2.0 255.255.255.0

default-router 192.168.2.254

dns-server x.x.x.x y.y.y.y  where x.x.x.x and y.y.y.y  are  ISP dns servers or if linksys is configured as cache server then put the LAN IP of the linksys router

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

that helped alot Alain thank you now my switch sees the 2621 but my pc is coming up with a error because its not "getting internet" in some way

"your computer appears to be coprretly configured, but the device or source(www.mircrosoft.com) is not responsing"

but when i load my browser website do come up not all of them though is there anything i could do?

again thank you alot

Hi,

post running config of the router and the output of ipconfig/all on the PC.

Can you ping 8.8.8.8 and www.google.com from the PC ?

Can you add these 2 commands on the cisco router:

int f0/0

ip mtu 1492

ip tcp-mss-adjust 1452

And tell us if your web browsing experience is bettered

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

hello

running config

http://pastebin.com/DMa6c1Xa

ipconfig/all (couldnent copy and paste so tell me if you need more info)

ethernet

ipv4 address 192.168.2.1

subnet       255.255.255.0

default gateway 192.168.2.254

dhcp server     192.168.2.254

i tried to ping them both and got 'request timed out'

i put the one command in since the other one was not compatible with my router and there was no difference

thank you

Hi,

Yes i did a typo for second command, it should be ip tcp adjust-mss 1452.

So you can't ping  8.8.8.8  from PC ? Can you do it from the cisco router ?

ok , I looked at your config, you should do this

no ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

no ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

ip route 0.0.0.0 0.0.0.0 dhcp

You'll be able to ping 8.8.8.8 from your router and from your PC

try to ping www.google.com from PC and tell me if it works now and add second command too if you still got some problems with browsing some sites.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

again thanks for the help

the reason i did those ip routes, since i forgot to mention it before, is because 'ip route 0.0.0.0 0.0.0.0 dhcp' was not recognized, these are the only options for 'ip route 0.0.0.0 0.0.0.0 ?'

A.B.C.D            Forwarding router's address

  Async              Async interface

  BVI                Bridge-Group Virtual Interface

  CTunnel            CTunnel interface

  Dialer             Dialer interface

  FastEthernet       FastEthernet IEEE 802.3

  Lex                Lex interface

  Loopback           Loopback interface

  Multilink          Multilink-group interface

  Null               Null interface

  Tunnel             Tunnel interface

  Vif                PGM Multicast Host interface

  Virtual-Template   Virtual Template interface

  Virtual-TokenRing  Virtual TokenRing

also

ip tcp adjust-mss1452 was not recognized either but it has compression-connections and header-compressions i dont know if that helps

and no i cant ping 8.8.8.8 from my 2621

thanks

Hi,

ok then still delete those 2 static  default routes and you should have a default route from DHCP which willlet you ping 8.8.8.8 from the cisco router.

if you stil can't then post following:

-show ip int br | exc unassigned

-sh ip route static

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

yes that worked i am now getting internet thanks alot for the help that really helped

richard

Review Cisco Networking products for a $25 gift card