cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
503
Views
30
Helpful
13
Replies
Highlighted
Beginner

how to advertise iBGP route to eBGP neighbor.

Hi All,

 

Can someone help me to get is resolved as in my scenario iBGP learn route in getting advertise to eBGP neighbor.

I am doing MPLS setup in GNS3 so i have design this topology like one ISP backbone and two customer site. i have enable mpls on PE and P router inside ISP zone. all are showing good but one thing is not being clear why iBGP learn route is not getting advertise to eBGP neighbor. 

 

Please see below command output.

----------------------------------------------------------------------------------

PE1#sh run | s router
router eigrp 111
network 10.10.10.0 0.0.0.255
network 10.10.11.0 0.0.0.255
network 11.11.11.11 0.0.0.0
auto-summary
router bgp 111
no synchronization
bgp log-neighbor-changes
neighbor 10.10.0.1 remote-as 100
neighbor 22.22.22.22 remote-as 111
neighbor 22.22.22.22 update-source Loopback1
no auto-summary
PE1#sh ip bgp sum

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.0.1 4 100 209 234 85 0 0 03:09:42                                        1
22.22.22.22 4 111 215 220 85 0 0 03:12:53                                    1
----------------------------------------------------------------------------------

PE2#sh run | s router
router eigrp 111
network 10.10.12.0 0.0.0.255
network 10.10.13.0 0.0.0.255
network 22.22.22.22 0.0.0.0
auto-summary
router bgp 111
no synchronization
bgp log-neighbor-changes
neighbor 10.11.0.2 remote-as 100
neighbor 11.11.11.11 remote-as 111
neighbor 11.11.11.11 update-source Loopback1
no auto-summary
PE2#sh ip bgp sum

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.11.0.2 4 100 210 235 94 0 0 03:12:17 1
11.11.11.11 4 111 222 217 94 0 0 03:12:33 1
-----------------------------------------------------------------------------

CE1#sh run | s router
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 10.10.0.2 remote-as 111
no auto-summary
CE1#sh ip bgp sum
BGP router identifier 1.1.1.1, local AS number 100
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.0.2 4 111 236 211 19 0 0 03:07:38 0

-------------------------------------------------------------------------

CE2#sh run | s router
router bgp 100
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
neighbor 10.11.0.1 remote-as 111
no auto-summary
CE2#sh ip bgp sum
BGP router identifier 2.2.2.2, local AS number 100
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.11.0.1 4 111 236 211 17 0 0 03:08:49 0

 

 

 

3 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Participant

Re: how to advertise iBGP route to eBGP neighbor.

Hi,

 

Both CE are having same AS number, did you try to add the following command to allow CE router accept the routing update with as number 100 inside the as-path:

 

CE1#sh run | s router
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 10.10.0.2 remote-as 111
neighbor 10.10.0.2 allowas-in 1
no auto-summary
CE1#sh ip bgp sum
BGP router identifier 1.1.1.1, local AS number 100
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.0.2 4 111 236 211 19 0 0 03:07:38 0

-------------------------------------------------------------------------

CE2#sh run | s router
router bgp 100
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
neighbor 10.11.0.1 remote-as 111
neighbor 10.11.0.1 allowas-in 1
no auto-summary
CE2#sh ip bgp sum
BGP router identifier 2.2.2.2, local AS number 100
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.11.0.1 4 111 236 211 17 0 0 03:08:49 0

 

Also, as your PE routers didn't advertise the 10.11.x.x network into your ISP backbone (which is normal and fine), so, even PE1 router will receive the 2.2.2.2/32 from PE2, but the next-hop is not reachable. You do need a next-hop-self on both PE routers as follow to resolve the problem:

 

PE1#
router bgp 111
neighbor 22.22.22.22 next-hop-self

PE2#sh run | s router
router bgp 111
neighbor 11.11.11.11 next-hop-self

 

View solution in original post

Highlighted
Participant

Re: how to advertise iBGP route to eBGP neighbor.

Hi,

First, please try to ping with source interface, otherwise, the CE router would use the closest interface (that is your 10.11.x.x) which is not known (advertised) to your backbone network.

And also, I have spotted the RIB failure in your "show ip bgp summary" output of CE routers.

Please check the reason by "sh ip bgp rib-failure".

 

I also see that your result "sh mpls ip binding" on PE1 and PE2 didn't see each other's loopback address.

 

E.g. PE1's "show mpls ip binding" not seeing 22.22.22.22

E.g. PE2's "show mpls ip binding" not seeing 11.11.11.11

 

Please check the MPLS LDP neighborship are correctly formed in your backbone. (show mpls ldp neighbor | include Peer)

Also check the loopback address of 22.22.22.22 and 11.11.11.11 are advertise through the EIGRP in your backbone. 

View solution in original post

Highlighted
Participant

Re: how to advertise iBGP route to eBGP neighbor.

Hi,

According to your output result, the LDP neighbors are fine.

Previously from your output result of "show mpls ip binding" on PE1, I was curious that why "22.22.22.22/32" have no label assigned. But I didn't realized that your loopback interface is using /8 subnet mask, and missed the 22.0.0.0/8 entry in the output result of "show mpls ip binding".

So, in fact, your MPLS is running without anything wrong.

View solution in original post

13 REPLIES 13
Highlighted
VIP Mentor

Re: how to advertise iBGP route to eBGP neighbor.

Hello,

 

are the loopbacks on the CE routers configured with /32 masks ?

Highlighted
Beginner

Re: how to advertise iBGP route to eBGP neighbor.

yes...

Highlighted
Participant

Re: how to advertise iBGP route to eBGP neighbor.

Hi,

 

Both CE are having same AS number, did you try to add the following command to allow CE router accept the routing update with as number 100 inside the as-path:

 

CE1#sh run | s router
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 10.10.0.2 remote-as 111
neighbor 10.10.0.2 allowas-in 1
no auto-summary
CE1#sh ip bgp sum
BGP router identifier 1.1.1.1, local AS number 100
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.0.2 4 111 236 211 19 0 0 03:07:38 0

-------------------------------------------------------------------------

CE2#sh run | s router
router bgp 100
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
neighbor 10.11.0.1 remote-as 111
neighbor 10.11.0.1 allowas-in 1
no auto-summary
CE2#sh ip bgp sum
BGP router identifier 2.2.2.2, local AS number 100
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.11.0.1 4 111 236 211 17 0 0 03:08:49 0

 

Also, as your PE routers didn't advertise the 10.11.x.x network into your ISP backbone (which is normal and fine), so, even PE1 router will receive the 2.2.2.2/32 from PE2, but the next-hop is not reachable. You do need a next-hop-self on both PE routers as follow to resolve the problem:

 

PE1#
router bgp 111
neighbor 22.22.22.22 next-hop-self

PE2#sh run | s router
router bgp 111
neighbor 11.11.11.11 next-hop-self

 

View solution in original post

Highlighted
Beginner

Re: how to advertise iBGP route to eBGP neighbor.

Hi ngkin,

Now customer's route getting update to each other after running this command mention below. please see below command output. even i have also configure next-hop-self on both PE router for iBGP neighbor. 

CE1#sh run | s router
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 10.10.0.2 remote-as 111
neighbor 10.10.0.2 allowas-in 1
no auto-summary
CE1#sh ip bgp
BGP table version is 7, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 0.0.0.0 0 32768 i
r> 2.2.2.2/32 10.10.0.2 0 111 100 i

 

CE2#sh run | s router
router bgp 100
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
neighbor 10.11.0.1 remote-as 111
neighbor 10.11.0.1 allowas-in 1
no auto-summary
CE2#sh ip bgp
BGP table version is 4, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
r> 1.1.1.1/32 10.11.0.1 0 111 100 i
*> 2.2.2.2/32 0.0.0.0 0 32768 i

 

CE1 is not reachable to CE2 and vice-versa.  please see below ping & tracerout output of series router CE1,PE1,PE2 to reach to CE2.

 

CE1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
CE1#trace 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 10.10.0.2 76 msec 60 msec 60 msec
2 * * *
3 * * *
4 * * *

-------------------

PE1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
PE1#trace 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 10.10.10.2 [MPLS: Label 19 Exp 0] 68 msec
10.10.11.2 [MPLS: Label 19 Exp 0] 64 msec
10.10.10.2 [MPLS: Label 19 Exp 0] 72 msec
2 10.10.13.2 60 msec
10.10.12.2 68 msec
10.10.13.2 60 msec
3 * * *
4 * * *
5 * * *

--------------------------

PE2#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/62/80 ms
PE2#trace 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 10.11.0.2 64 msec 64 msec 84 msec

---------------------------------------------------------------------------------------------------I have configure the command "mpls ip" on every router;s global mode as well as interface. this command is enough for this setup or need some more command to get it resolve. please help me on this. please see below ISP backbone router's MPLS command configuration.

 

PE1#sh mpls interfaces
Interface IP Tunnel BGP Static Operational
Serial2/0 Yes (ldp) No No No Yes
Serial2/1 Yes (ldp) No No No Yes
PE1#sh mpls ip binding
10.0.0.0/8
in label: imp-null
10.10.0.0/24
in label: imp-null
10.10.10.0/24
in label: imp-null
out label: imp-null lsr: 10.10.12.1:0
out label: 16 lsr: 10.10.13.1:0
10.10.11.0/24
in label: imp-null
out label: 16 lsr: 10.10.12.1:0
out label: imp-null lsr: 10.10.13.1:0
10.10.12.0/24
in label: 16
out label: imp-null lsr: 10.10.12.1:0 inuse
out label: 17 lsr: 10.10.13.1:0
10.10.13.0/24
in label: 17
out label: 17 lsr: 10.10.12.1:0
out label: imp-null lsr: 10.10.13.1:0 inuse
11.0.0.0/8
in label: imp-null
out label: 18 lsr: 10.10.12.1:0
out label: 18 lsr: 10.10.13.1:0
11.11.11.11/32
in label: imp-null
22.0.0.0/8
in label: 18
out label: 19 lsr: 10.10.12.1:0 inuse
out label: 19 lsr: 10.10.13.1:0 inuse

-----------------------------------------------

PE2#sh mpls interfaces
Interface IP Tunnel BGP Static Operational
Serial2/0 Yes (ldp) No No No Yes
Serial2/1 Yes (ldp) No No No Yes
PE2#sh mpls ip binding
10.0.0.0/8
in label: imp-null
10.10.10.0/24
in label: 16
out label: imp-null lsr: 10.10.12.1:0 inuse
out label: 16 lsr: 10.10.13.1:0
10.10.11.0/24
in label: 17
out label: 16 lsr: 10.10.12.1:0
out label: imp-null lsr: 10.10.13.1:0 inuse
10.10.12.0/24
in label: imp-null
out label: imp-null lsr: 10.10.12.1:0
out label: 17 lsr: 10.10.13.1:0
10.10.13.0/24
in label: imp-null
out label: 17 lsr: 10.10.12.1:0
out label: imp-null lsr: 10.10.13.1:0
10.11.0.0/24
in label: imp-null
11.0.0.0/8
in label: 18
out label: 18 lsr: 10.10.12.1:0 inuse
out label: 18 lsr: 10.10.13.1:0 inuse
22.0.0.0/8
in label: imp-null
out label: 19 lsr: 10.10.12.1:0
out label: 19 lsr: 10.10.13.1:0
22.22.22.22/32
in label: imp-null

---------------------------------------------------------------------------

P1#sh mpls interfaces
Interface IP Tunnel BGP Static Operational
Serial2/0 Yes (ldp) No No No Yes
Serial2/1 Yes (ldp) No No No Yes
P1#sh mpls ip binding
10.0.0.0/8
out label: imp-null lsr: 11.11.11.11:0
out label: imp-null lsr: 22.22.22.22:0
10.10.0.0/24
out label: imp-null lsr: 11.11.11.11:0
10.10.10.0/24
in label: imp-null
out label: imp-null lsr: 11.11.11.11:0
out label: 16 lsr: 22.22.22.22:0
10.10.11.0/24
in label: 16
out label: imp-null lsr: 11.11.11.11:0 inuse
out label: 17 lsr: 22.22.22.22:0
10.10.12.0/24
in label: imp-null
out label: 16 lsr: 11.11.11.11:0
out label: imp-null lsr: 22.22.22.22:0
10.10.13.0/24
in label: 17
out label: 17 lsr: 11.11.11.11:0
out label: imp-null lsr: 22.22.22.22:0 inuse
10.11.0.0/24
out label: imp-null lsr: 22.22.22.22:0
11.0.0.0/8
in label: 18
out label: imp-null lsr: 11.11.11.11:0 inuse
out label: 18 lsr: 22.22.22.22:0
11.11.11.11/32
out label: imp-null lsr: 11.11.11.11:0
22.0.0.0/8
in label: 19
out label: 18 lsr: 11.11.11.11:0
out label: imp-null lsr: 22.22.22.22:0 inuse
22.22.22.22/32
out label: imp-null lsr: 22.22.22.22:0

---------------------------------------------------------------------------

 

P2#sh mpls interfaces
Interface IP Tunnel BGP Static Operational
Serial2/0 Yes (ldp) No No No Yes
Serial2/1 Yes (ldp) No No No Yes
P2#sh mpls ip binding
10.0.0.0/8
out label: imp-null lsr: 22.22.22.22:0
out label: imp-null lsr: 11.11.11.11:0
10.10.0.0/24
out label: imp-null lsr: 11.11.11.11:0
10.10.10.0/24
in label: 16
out label: 16 lsr: 22.22.22.22:0
out label: imp-null lsr: 11.11.11.11:0 inuse
10.10.11.0/24
in label: imp-null
out label: 17 lsr: 22.22.22.22:0
out label: imp-null lsr: 11.11.11.11:0
10.10.12.0/24
in label: 17
out label: imp-null lsr: 22.22.22.22:0 inuse
out label: 16 lsr: 11.11.11.11:0
10.10.13.0/24
in label: imp-null
out label: imp-null lsr: 22.22.22.22:0
out label: 17 lsr: 11.11.11.11:0
10.11.0.0/24
out label: imp-null lsr: 22.22.22.22:0
11.0.0.0/8
in label: 18
out label: 18 lsr: 22.22.22.22:0
out label: imp-null lsr: 11.11.11.11:0 inuse
11.11.11.11/32
out label: imp-null lsr: 11.11.11.11:0
22.0.0.0/8
in label: 19
out label: imp-null lsr: 22.22.22.22:0 inuse
out label: 18 lsr: 11.11.11.11:0
22.22.22.22/32
out label: imp-null lsr: 22.22.22.22:0

 

 

Highlighted
Participant

Re: how to advertise iBGP route to eBGP neighbor.

Hi,

First, please try to ping with source interface, otherwise, the CE router would use the closest interface (that is your 10.11.x.x) which is not known (advertised) to your backbone network.

And also, I have spotted the RIB failure in your "show ip bgp summary" output of CE routers.

Please check the reason by "sh ip bgp rib-failure".

 

I also see that your result "sh mpls ip binding" on PE1 and PE2 didn't see each other's loopback address.

 

E.g. PE1's "show mpls ip binding" not seeing 22.22.22.22

E.g. PE2's "show mpls ip binding" not seeing 11.11.11.11

 

Please check the MPLS LDP neighborship are correctly formed in your backbone. (show mpls ldp neighbor | include Peer)

Also check the loopback address of 22.22.22.22 and 11.11.11.11 are advertise through the EIGRP in your backbone. 

View solution in original post

Highlighted
Beginner

Re: how to advertise iBGP route to eBGP neighbor.

Hi,

its reachable from source interface.

As checked LDP neighbor is not formed in both iBGP neighbor. please see below command out put.

 

Please check the reason by "sh ip bgp rib-failure".: please see below output.

CE1#sh ip bgp rib-failure
Network Next Hop RIB-failure RIB-NH Matches
2.2.2.2/32 10.10.0.2 Higher admin distance n/a
CE1#ping 2.2.2.2 source loopback 1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 88/90/96 ms

 

Also check the loopback address of 22.22.22.22 and 11.11.11.11 are advertise through the EIGRP in your backbone.: yes, both are being advertise through EIGRP. 

PE1#sh ip route eigrp 111
D 22.0.0.0/8 [90/2809856] via 10.10.11.2, 00:26:48, Serial2/1
[90/2809856] via 10.10.10.2, 00:26:48, Serial2/0
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.0.0.0/8 is a summary, 00:26:49, Null0
D 10.10.12.0/24 [90/2681856] via 10.10.10.2, 00:26:48, Serial2/0
D 10.10.13.0/24 [90/2681856] via 10.10.11.2, 00:26:48, Serial2/1
11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 11.0.0.0/8 is a summary, 00:26:49, Null0

 

PE2#sh ip route eigrp 111
22.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 22.0.0.0/8 is a summary, 00:27:12, Null0
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.10.10.0/24 [90/2681856] via 10.10.12.1, 00:27:12, Serial2/1
D 10.0.0.0/8 is a summary, 00:27:12, Null0
D 10.10.11.0/24 [90/2681856] via 10.10.13.1, 00:27:12, Serial2/0
D 11.0.0.0/8 [90/2809856] via 10.10.13.1, 00:27:12, Serial2/0
[90/2809856] via 10.10.12.1, 00:27:12, Serial2/1

 

Please check the MPLS LDP neighborship are correctly formed in your backbone. (show mpls ldp neighbor | include Peer):  As checked no peer formed between both iBGP neighbor.

 

PE1#sh mpls ldp neighbor | in peer
Addresses bound to peer LDP Ident:
Addresses bound to peer LDP Ident:

 

PE2#sh mpls ldp neighbor | in peer
Addresses bound to peer LDP Ident:
Addresses bound to peer LDP Ident:

 

Please see this command output also for more clarity.

PE1#sh mpls ldp neighbor
Peer LDP Ident: 10.10.12.1:0; Local LDP Ident 11.11.11.11:0
TCP connection: 10.10.12.1.646 - 11.11.11.11.30253
State: Oper; Msgs sent/rcvd: 50/28; Downstream
Up time: 00:33:25
LDP discovery sources:
Serial2/0, Src IP addr: 10.10.10.2
Addresses bound to peer LDP Ident:
10.10.10.2 10.10.12.1
Peer LDP Ident: 10.10.13.1:0; Local LDP Ident 11.11.11.11:0
TCP connection: 10.10.13.1.646 - 11.11.11.11.16330
State: Oper; Msgs sent/rcvd: 49/28; Downstream
Up time: 00:33:24
LDP discovery sources:
Serial2/1, Src IP addr: 10.10.11.2
Addresses bound to peer LDP Ident:
10.10.13.1 10.10.11.2

PE2#sh mpls ldp neighbor
Peer LDP Ident: 10.10.13.1:0; Local LDP Ident 22.22.22.22:0
TCP connection: 10.10.13.1.646 - 22.22.22.22.12595
State: Oper; Msgs sent/rcvd: 55/30; Downstream
Up time: 00:36:49
LDP discovery sources:
Serial2/0, Src IP addr: 10.10.13.1
Addresses bound to peer LDP Ident:
10.10.13.1 10.10.11.2
Peer LDP Ident: 10.10.12.1:0; Local LDP Ident 22.22.22.22:0
TCP connection: 10.10.12.1.646 - 22.22.22.22.28512
State: Oper; Msgs sent/rcvd: 54/31; Downstream
Up time: 00:36:48
LDP discovery sources:
Serial2/1, Src IP addr: 10.10.12.1
Addresses bound to peer LDP Ident:
10.10.10.2 10.10.12.1

 

P1#sh mpls ldp neighbor
Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 10.10.12.1:0
TCP connection: 11.11.11.11.30253 - 10.10.12.1.646
State: Oper; Msgs sent/rcvd: 34/61; Downstream
Up time: 00:21:59
LDP discovery sources:
Serial2/0, Src IP addr: 10.10.10.1
Addresses bound to peer LDP Ident:
10.10.0.2 10.10.10.1 11.11.11.11 10.10.11.1
Peer LDP Ident: 22.22.22.22:0; Local LDP Ident 10.10.12.1:0
TCP connection: 22.22.22.22.28512 - 10.10.12.1.646
State: Oper; Msgs sent/rcvd: 34/61; Downstream
Up time: 00:21:59
LDP discovery sources:
Serial2/1, Src IP addr: 10.10.12.2
Addresses bound to peer LDP Ident:
10.11.0.1 10.10.13.2 22.22.22.22 10.10.12.2

 

P2#sh mpls ldp neighbor | in peer
Addresses bound to peer LDP Ident:
Addresses bound to peer LDP Ident:
P2#sh mpls ldp neighbor
Peer LDP Ident: 22.22.22.22:0; Local LDP Ident 10.10.13.1:0
TCP connection: 22.22.22.22.12595 - 10.10.13.1.646
State: Oper; Msgs sent/rcvd: 34/62; Downstream
Up time: 00:22:26
LDP discovery sources:
Serial2/0, Src IP addr: 10.10.13.2
Addresses bound to peer LDP Ident:
10.11.0.1 10.10.13.2 22.22.22.22 10.10.12.2
Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 10.10.13.1:0
TCP connection: 11.11.11.11.16330 - 10.10.13.1.646
State: Oper; Msgs sent/rcvd: 34/61; Downstream
Up time: 00:22:25
LDP discovery sources:
Serial2/1, Src IP addr: 10.10.11.1
Addresses bound to peer LDP Ident:
10.10.0.2 10.10.10.1 11.11.11.11 10.10.11.1

 

Highlighted
Participant

Re: how to advertise iBGP route to eBGP neighbor.

The LDP neighbor result look fine, and you are now able to ping 2.2.2.2 from 1.1.1.1.

So, let's focus on the below error:

CE1#sh ip bgp rib-failure
Network Next Hop RIB-failure RIB-NH Matches
2.2.2.2/32 10.10.0.2 Higher admin distance n/a

It means that your CE1 have another route (with lower AD than the eBGP's AD:20) to 2.2.2.2/32. Therefore, although your CE1 have learnt the route via BGP, but it not installing to its routing table.

I guess it likely to be a static route (AD:1) on CE1? Could you check if you already have a route to 2.2.2.2/32?

(E.g. CE1# show ip route)

Highlighted
Beginner

Re: how to advertise iBGP route to eBGP neighbor.

Dear Ngkin,

Please help me to get clear why LDP neighbor is not formed in MPLS Backbon. please refer above command output including your ask in redmark.
Highlighted
Participant

Re: how to advertise iBGP route to eBGP neighbor.

Hi,

According to your output result, the LDP neighbors are fine.

Previously from your output result of "show mpls ip binding" on PE1, I was curious that why "22.22.22.22/32" have no label assigned. But I didn't realized that your loopback interface is using /8 subnet mask, and missed the 22.0.0.0/8 entry in the output result of "show mpls ip binding".

So, in fact, your MPLS is running without anything wrong.

View solution in original post

Highlighted
Beginner

Re: how to advertise iBGP route to eBGP neighbor.

Why loopback interface is showning with /8 bit subnet even i have configure it with /24 bit subnet. is there any specific rue fir this type of election in "mpls ip binding".  please see below command output.

 

 

PE1#sh run int loo 1
Building configuration...

Current configuration : 67 bytes
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
end

 

PE1#sh mpls ip binding
10.0.0.0/8
in label: imp-null
10.10.0.0/24
in label: imp-null
10.10.10.0/24
in label: imp-null
out label: imp-null lsr: 10.10.12.1:0
out label: 16 lsr: 10.10.13.1:0
10.10.11.0/24
in label: imp-null
out label: 16 lsr: 10.10.12.1:0
out label: imp-null lsr: 10.10.13.1:0
10.10.12.0/24
in label: 16
out label: imp-null lsr: 10.10.12.1:0 inuse
out label: 18 lsr: 10.10.13.1:0
10.10.13.0/24
in label: 17
out label: 18 lsr: 10.10.12.1:0
out label: imp-null lsr: 10.10.13.1:0 inuse
11.0.0.0/8
in label: imp-null
out label: 17 lsr: 10.10.12.1:0
out label: 17 lsr: 10.10.13.1:0
11.11.11.11/32
in label: imp-null
22.0.0.0/8
in label: 18
out label: 19 lsr: 10.10.12.1:0 inuse
out label: 19 lsr: 10.10.13.1:0 inuse

--------------------------------------------------------------------

PE2#sh run int loo 1
Building configuration...

Current configuration : 67 bytes
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
end

 

 

PE2#sh mpls ip binding
10.0.0.0/8
in label: imp-null
10.10.10.0/24
in label: 16
out label: imp-null lsr: 10.10.12.1:0 inuse
out label: 16 lsr: 10.10.13.1:0
10.10.11.0/24
in label: 17
out label: 16 lsr: 10.10.12.1:0
out label: imp-null lsr: 10.10.13.1:0 inuse
10.10.12.0/24
in label: imp-null
out label: imp-null lsr: 10.10.12.1:0
out label: 18 lsr: 10.10.13.1:0
10.10.13.0/24
in label: imp-null
out label: 18 lsr: 10.10.12.1:0
out label: imp-null lsr: 10.10.13.1:0
10.11.0.0/24
in label: imp-null
11.0.0.0/8
in label: 18
out label: 17 lsr: 10.10.12.1:0 inuse
out label: 17 lsr: 10.10.13.1:0 inuse
22.0.0.0/8
in label: imp-null
out label: 19 lsr: 10.10.12.1:0
out label: 19 lsr: 10.10.13.1:0
22.22.22.22/32
in label: imp-null

Highlighted
Participant

Re: how to advertise iBGP route to eBGP neighbor.

It's because the prefix has been auto summarized by EIGRP.

router eigrp 111
network 10.10.10.0 0.0.0.255
network 10.10.11.0 0.0.0.255
network 11.11.11.11 0.0.0.0
auto-summary <-----------------

The route 11.11.11.11/32 was summarized into 11.0.0.0/8. And therefore, on PE2, you will see the EIGRP route 11.0.0.0/8 instead of 11.11.11.11/32. MPLS's IP binding are referring to the routing table, so it's also /8 instead of /32.
Highlighted
Beginner

Re: how to advertise iBGP route to eBGP neighbor.

Why we are using "allowas-in 1" whats that "1" means here

Please do not hesitate to click the STAR button if you are satisfied with my answer.
Highlighted
Participant

Re: how to advertise iBGP route to eBGP neighbor.

Hi,

Hope the below document help you to understand the meaning of "allowas-in 1".

https://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/112236-allowas-in-bgp-config-example.html