09-22-2016 02:33 PM - edited 03-05-2019 07:07 AM
A partner will bring an MPLS circuit to connect our sites. One of the requirements is to tag the packets since we will be having mixed voice and data on this MPLS circuit. They said they will enable COS on this circuit so as to prioritize voice over data in case there's congestion.
Just to make sure since I haven't done this before, this is how I will configure the switch to mark/classify the input packets:
access-list 100 permit udp any any range 16384 32767
access-list 100 permit tcp any any eq 1720
!
class-map voip
match access-group 100
!
policy-map mqc
class voip
set ip precedence 5
class class-default
set ip precedence 0
!
interface Ethernet0/0
service-policy input mqc -> will apply this to all (input) switch ports
Is there anything else I need to add? On the outbound interface connecting to the MPLS circuit, I would add something like this:
policy-map llq
class voip
priority 3000
class class-default
fair-queue
!
interface Serial1/0
bandwidth 5000
service-policy output llq
Am I doing this correctly?
Thanks for the help.
09-23-2016 07:25 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
QoS configurations vary based on platform and sometimes platform's IOS version. Since you didn't state either, cannot confirm what you're doing is physically correct.
Before implementing QoS, you should design what your QoS model is for. VoIP prioritized over data is a starting point, but prioritized how, and what about VoIP bearer vs. VoIP control traffic?
"MPLS" connections often will support QoS, but often it's something to work out with your MPLS vendor.
You can also deal with egress congestion, from your device to the MPLS cloud, sometimes without even dealing with MPLS QoS options, but the two normally are configured to work together.
09-23-2016 10:34 AM
The above is for a 3750 switch. I understand it may differ in other versions but I probably just need to understand the main principle behind it. I can make the adjustments based on my IOS version.
The MPLS provider will be AT&T by the way and here's how they want to classify CoS: http://planner.bus.att.com/tab004.pdf
09-23-2016 10:49 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide