cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
169
Views
0
Helpful
0
Replies
Highlighted
Beginner

HSRP on Nexus 9k

Hello,

I have configured Hsrp on both nexus 9k.

Nexuses are connected via VPC.

 

The Default Gateway on Servers and Pc's are the Hsrp Standby IP.

Each vlan is separated by VRF and a static route is being configured on each nexus to the FortiGate.

FortiGate is doing layer 3 inter-VLAN routing between the VRF'S.

 

I Suspect that asymmetric route is being occurred because we are facing sporadically ping loss.

 

 

 

N9K-1 configuration:

vrf context Academic
ip route 0.0.0.0/0 192.168.80.254
vrf context Back_end_Server
ip route 0.0.0.0/0 192.168.70.254
vrf context College
ip route 0.0.0.0/0 192.168.20.254
ip route 192.168.70.0/24 192.168.20.223
vrf context Cyber-lab
ip route 0.0.0.0/0 192.168.90.254
vrf context DMZ
ip route 0.0.0.0/0 192.168.30.254
vrf context MGMT
ip route 0.0.0.0/0 192.168.10.254
vrf context MGMT_USERS
ip route 0.0.0.0/0 192.168.60.254
vrf context TMG
ip route 0.0.0.0/0 192.168.50.254
vrf context dev
description backend server
ip route 0.0.0.0/0 192.168.40.254

 

interface Vlan10
description MGMT-control
no shutdown
vrf member MGMT
ip address 192.168.10.252/24
hsrp 10
preempt delay minimum 10 reload 30 sync 30
priority 150
ip 192.168.10.250

 

 

interface Vlan20
description students
no shutdown
vrf member College
ip address 192.168.20.252/21
hsrp 20
preempt delay minimum 10 reload 30 sync 30
priority 150
ip 192.168.20.250
ip dhcp relay address 192.168.20.19
ip dhcp relay address 192.168.20.20

 

 

N9K-2 configuration:

vrf context Academic
ip route 0.0.0.0/0 192.168.80.254
vrf context Back_end_Server
ip route 0.0.0.0/0 192.168.70.254
vrf context College
ip route 0.0.0.0/0 192.168.20.254
ip route 192.168.70.0/24 192.168.20.223
vrf context Cyber-lab
ip route 0.0.0.0/0 192.168.90.254
vrf context DMZ
ip route 0.0.0.0/0 192.168.30.254
vrf context MGMT
ip route 0.0.0.0/0 192.168.10.254
vrf context MGMT_USERS
ip route 0.0.0.0/0 192.168.60.254
vrf context TMG
ip route 0.0.0.0/0 192.168.50.254
vrf context dev
description backend server
ip route 0.0.0.0/0 192.168.40.254

 

interface Vlan10
description MGMT-control
no shutdown
vrf member MGMT
ip address 192.168.10.253/24
hsrp 10
preempt delay minimum 10 reload 30 sync 30
ip 192.168.10.250

 

interface Vlan20
description students
no shutdown
vrf member College
ip address 192.168.20.253/21
hsrp 20
ip 192.168.20.250
ip dhcp relay address 192.168.20.19
ip dhcp relay address 192.168.20.20

 

 

interface port-channel1
description FGT-1_port39,40
switchport mode trunk
switchport trunk allowed vlan 10,20,30,40,50,60,70,80,90-91
vpc 1

interface port-channel2
description FGT-2_port39,40
switchport mode trunk
switchport trunk allowed vlan 10,20,30,40,50,60,70,80,90-91
vpc 2

 

 

 

 

 

 

 

 

 

0 REPLIES 0