cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
540
Views
20
Helpful
11
Replies
_rucisco_
Beginner

HSRP priority not working

Dear all,

 

I have a simple configuration on PacketTracer 6.0.1 (an old version indeed) where I was playing with HSRP priorities but it does not seem to be working as expected.

 

I have 3 routers configured with IP addresses R1= 192.168.1.1, R2 = 192.168.1.2 and R3 = 192.168.1.3. The priorities are set to R1 = 110, R2 = 80 and R3 = 120. Preempting is configured in all 3 routers.

 

When starting the network I get R3 as the active router, which is what I would expect due to R3's priority but when I switch R3 off, R2 is the router to become active despite having the lower priority. 

 

I checked HSRP's message contents and surprisingly all messages (from all routers) show priority 100 even though the configuration shows the priority is properly set with command standby priority. See, for example, the configuration of R1:

 

interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0 
 duplex auto
 speed auto
 standby version 2
 standby 10 ip 192.168.1.254 
 standby priority 110
 standby preempt
!

Is this a known issue in old PT versions or is it me doing someyhing wrong.

 

---

Edit: I have tried a different configuration and priorities seem to be exchanged properly in HSRP messages. So I am really confused... I will give more details on the configuration that is not working in case someone can figure out the reason for the routers not exchanging the priorities as they should.

 

The configuration is as follows:

net.png

I have configured Fa0/0 interfaces as well as Fa0/1 interfaces of inner routers to support HSRP. First, I tried to have all interfaces in a single group, but for Fa0/0 they point to virtual IP 192.168.2.254 and Fa0/1 to 192.168.1.254. Now I have two different groups but still not working.

 

Any help is really appreaciated.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

as per the information your config to work as expected

 

You want R3 to be Active, if that Fails R1 to be Active (ratherR2) then your config should be as below (think that on switch all the interface same VLAN)

 

R3

interface FastEthernet0/0
ip address 192.168.1.3 255.255.255.0
standby version 2
standby 10 ip 192.168.1.254
standby 10 priority 120
standby 10 preempt
!

R1

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
standby version 2
standby 10 ip 192.168.1.254
standby 10 priority 110
!

R2

interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
standby version 2
standby 10 ip 192.168.1.254
standby 10 priority 80
no sh
!

 

here you see output like this :

 

R3#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 120 P Active local 192.168.1.1 192.168.1.254

 

R1#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 110 Standby 192.168.1.3 local 192.168.1.254

 

R2#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 80 Listen 192.168.1.3 192.168.1.1 192.168.1.254

 

R3 Fails

 

R1#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 110 Active local 192.168.1.2 192.168.1.254

 

R2#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 80 Standby 192.168.1.1 local 192.168.1.254

 

Since R3 interface down :

 

R3#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 120 P Init unknown unknown 192.168.1.254

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

11 REPLIES 11
Giuseppe Larosa
Hall of Fame Master

Hello @_rucisco_ ,

I would say you are facling an issue with the emulation software.

Save the project and restart the SW.

 

The key command is standby preempt that if missing does not allow an HSRP device with higher prioroty to take over the role of Active.

But I see you have it in your configuration.

 

Hope to help

Giuseppe

 

Thank you for your comment.

 

I have editted my question to add more details because I realized that on a different configuration the HSRP messages are carrying the priorities just fine.

 

Could you please check my edit? If necessary I can post the configuration of all routers.

 

Thanks!

Giuseppe Larosa
Hall of Fame Master

Hello @_rucisco_ ,

>> have configured Fa0/0 interfaces as well as Fa0/1 interfaces of inner routers to support HSRP. First, I tried to have all interfaces in a single group, but for Fa0/0 they point to virtual IP 192.168.2.254 and Fa0/1 to 192.168.1.254. Now I have two different groups but still not working.

 

Different routed L3 interfaces cannot be member of the same group and this is normal and expected. The HSRP hellos are sent to a multicast link local address 224.0.0.2 ( all routers in segment) and this cannot be routed to another subnet.

The goal of HSRP is to provide a virtual gateway emulated at L3 and L2 that is always on for the end user devices PCs in a common single IP subnet.

So HSRP, VRRP and GLBP are called FHRP First Hop Redundancy Protocol

 

Hope to help

Giuseppe

 

I am sorry but I don't understand your comment. Are you saying the problem is on the use of the same group for all interfaces (in both subnets)?

 

Now I have all Fa0/0 interfaces configured for one virtual IP address (192.168.2.254), and all Fa0/1 interfaces configured to provide another virtual IP address (192.168.1.254).

 

At first, I used for both groups the same identifier because they are in different subnets but just in case change it to use two different group identifiers: one for interfaces in 192.168.2.0/24 (Fa0/0) and another one for interfaces in 192.168.1.0/24 (Fa0/1).

 

My impression is that it should have worked in either case...

 

Thanks a lot!

as per the information your config to work as expected

 

You want R3 to be Active, if that Fails R1 to be Active (ratherR2) then your config should be as below (think that on switch all the interface same VLAN)

 

R3

interface FastEthernet0/0
ip address 192.168.1.3 255.255.255.0
standby version 2
standby 10 ip 192.168.1.254
standby 10 priority 120
standby 10 preempt
!

R1

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
standby version 2
standby 10 ip 192.168.1.254
standby 10 priority 110
!

R2

interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
standby version 2
standby 10 ip 192.168.1.254
standby 10 priority 80
no sh
!

 

here you see output like this :

 

R3#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 120 P Active local 192.168.1.1 192.168.1.254

 

R1#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 110 Standby 192.168.1.3 local 192.168.1.254

 

R2#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 80 Listen 192.168.1.3 192.168.1.1 192.168.1.254

 

R3 Fails

 

R1#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 110 Active local 192.168.1.2 192.168.1.254

 

R2#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 80 Standby 192.168.1.1 local 192.168.1.254

 

Since R3 interface down :

 

R3#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/0 10 120 P Init unknown unknown 192.168.1.254

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

Thanks!

 

Your solution is correct. The problem with my configuration was that I was lacking the group id in the commands. I was using

 

 

interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 standby version 2
 standby 10 ip 192.168.1.254
 standby priority 110
 standby preempt
!

But should be using

 

 

interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 standby version 2
 standby 10 ip 192.168.1.254
 standby 10 priority 110
 standby 10 preempt
!

To be honest I was expecting that the group id was not necessary for the priority and preempt commands since there is only one group defined for the interface...

 

So what is then the purpose for those commands without the group id?

 

Thank you all.

 

 

 

Hi

The group number is used so you can have different groups with different properties.

When configure standby without any groupnumber it is the same as configure group 1

So, for example if you have 2 routers and also 2 ip adressranges on the interface you can do it 2 ways.

router 1

interface et1

ip address 1.1.1.2/24

ip address 2.2.2.2/24 secondary

standby ip 1.1.1.1

standby ip 2.2.2.1 secondary

standby prio 110

standby preempt

 

router 2

interface et1

ip address 1.1.1.3/24

ip address 2.2.2.3/24 secondary

standby ip 1.1.1.1

standby ip 2.2.2.1 secondary

standby prio 80

standby preempt

In this scenario router 1 is active for both adress ranges

If you do it like this instead

router 1

interface et1

ip address 1.1.1.2/24

ip address 2.2.2.2/24 secondary

standby ip 1.1.1.1

standby prio 110

standby preempt

standby 10 ip 2.2.2.1 secondary

standby 10 prio 80

standby 10 preempt

router 2

interface et1

ip address 1.1.1.3/24

ip address 2.2.2.3/24 secondary

standby ip 1.1.1.1

standby prio 80

standby preempt

standby 10 2.2.2.1 secondary

standby 10 prio 110

standby 10 preempt

router 1 is now active for 1.1.1 network and router 2 is active for 2.2.2 network

 

/Mikael

Thanks for your reply.

 

I guess you mean that if no group-id is provided, the configuration is applied to the default group, which to my understanding is group 0. Am I wrong?

 

Thanks

No you are not wrong, your understanding are correct. I was little too fast when writing.

It is easy to see.

If you configure without a group you got mac-address 0000.0c07.ac00

If you configure with group 0 you also got 0000.0c07.ac00

If you configure with 1 you got 0000.0c07.ac01

If you configure with 10 you got 0000.0c07.ac0a

/Mikael 

Georg Pauwen
VIP Expert

Hello,

 

post the zipped Packet Tracer project (.pkt) file, it might as well be a version problem, I'll try and open it in the latest version (8)...

Is it possible to open PT6 in PT8? Is this a new compatibility feature? I have several times tried to open PT6 files in PT7 and was unable to do so.

 

Thanks