cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
7022
Views
0
Helpful
4
Replies
Highlighted
Beginner

HWIC-1ADSL Problems - Cisco 1841

Hi Guys,

I am a bit confused over this one, maybe one of you can help me.

I have a Cisco 1841, which I use for my home router using the WIC-1ADSL card this worked fine. My line has now been updated to a 21CN line, so I have access to a ADSL2+ connection. To access the ADSL2+ service I have been using a little Netgear, just to tie me over till the HWIC-1ADSL card arrived.

Now here is the problem:

Cisco 1841 + WIC-1ADSL - Sync fine, ATM Status up, Internet Access

Cisco 1841 + HWIC-1ADSL - Sync fine, ATM Status down/up/down etc.., No Internet Access

IOS Version: c1841-advipservicesk9-mz.151-3.T

Has anyone else come across this kind of behaviour, on a Cisco device? I have read a few threads on HWIC firmware not getting on with some IOS versions.

I was going to try running a older IOS to see if this helps or a firmware upgrade on the card.

Or is the card faulty?

Thanks

Current Running Config.

Cisco1841#show run

Building configuration...

Current configuration : 2582 bytes

!

! Last configuration change at 21:48:23 GMT Wed Jun 29 2011

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco1841

!

boot-start-marker

boot-end-marker

!

!

enable password

!

no aaa new-model

!

clock timezone GMT 0 0

clock summer-time GMT recurring last Sun Mar 1:00 last Sun Oct 2:00

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 192.168.0.1 192.168.0.10

ip dhcp excluded-address 192.168.1.254

ip dhcp excluded-address 192.168.0.254

!

ip dhcp pool Wired_Range

   import all

   network 192.168.0.0 255.255.255.0

   default-router 192.168.0.254

   dns-server 212.23.3.100 212.23.6.100

   lease 4

!

ip dhcp pool Wireless_Range

   import all

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.254

   dns-server 212.23.3.100 212.23.6.100

   lease 4

!

!

!

ip cef

ip domain name home.local

ip name-server 212.23.3.100

ip name-server 212.23.6.100

no ipv6 cef

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

!

!

interface FastEthernet0/0

description Wired Local Network

ip address 192.168.0.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface FastEthernet0/1

description Wireless Internal Network

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface Dialer0

description DSL Connection

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname username

ppp chap password 0 password

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip nat inside source list 50 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

logging esm config

access-list 50 permit 192.0.0.0 0.255.255.255

dialer-list 1 protocol ip permit

!

!

!

!

!

!

control-plane

!

!

banner motd ^C

You are attempting to connect to a managed device

If you are not an authorised user DISCONNECT IMMEDIATELY

^C

!

line con 0

logging synchronous

line aux 0

line vty 0 4

logging synchronous

login local

transport input ssh

!

scheduler allocate 20000 1000

end

Show ATM

Cisco1841#int atm0/0/0

ATM0/0/0 is down, line protocol is down

  Hardware is HWIC-DSLSAR (with Alcatel ADSL Module), address is 001f.6ca2.5d1c (bia 001f.6ca2.5d1c)

  MTU 4470 bytes, sub MTU 4470, BW 448 Kbit/sec, DLY 1140 usec,

     reliability 123/255, txload 1/255, rxload 1/255

  Encapsulation ATM, loopback not set

  Keepalive not supported

  Encapsulation(s): AAL5

  23 maximum active VCs, 256 VCs per VP, 0 current VCCs

  VC Auto Creation Disabled.

  VC idle disconnect time: 300 seconds

  Last input never, output 00:00:18, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 47

  Queueing strategy: Per VC Queueing

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     107 packets input, 7638 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     149 packets output, 5990 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

Cisco1841#show int atm0/0/0

ATM0/0/0 is up, line protocol is up

  Hardware is HWIC-DSLSAR (with Alcatel ADSL Module), address is 001f.6ca2.5d1c (bia 001f.6ca2.5d1c)

  MTU 4470 bytes, sub MTU 4470, BW 448 Kbit/sec, DLY 1140 usec,

     reliability 129/255, txload 1/255, rxload 1/255

  Encapsulation ATM, loopback not set

  Keepalive not supported

  Encapsulation(s): AAL5

  23 maximum active VCs, 256 VCs per VP, 0 current VCCs

  VC Auto Creation Disabled.

  VC idle disconnect time: 300 seconds

  Last input never, output 00:01:13, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 51

  Queueing strategy: Per VC Queueing

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     107 packets input, 7638 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     152 packets output, 6050 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out


Show DSL

Cisco1841#show int dsl int atm 0/0/0

ATM0/0/0

Alcatel 20190 chipset information

                     ATU-R (DS)                              ATU-C (US)

Modem Status:           Showtime (DMTDSL_SHOWTIME)

DSL Mode:           ITU G.992.5 (ADSL2+) Annex A

ITU STD NUM:            0x03                                         0x3

Chip Vendor ID:           'STMI'                                         'TSTC'

Chip Vendor Specific:  0x0000                               0x0510

Chip Vendor Country:   0x0F                               0xB5

Modem Vendor ID: 'CSCO'                                         'TSTC'

Modem Vendor Specific: 0x0000                               0x5100

Modem Vendor Country:  0xB5                               0xB5

Serial Number Near:    FOC13370P5KCISCO73993206

Serial Number Far:  Chip ID:            C196 (0)

DFE BOM:           DFE3.0 Annex A (1)

Capacity Used:           97%                                         34%

Noise Margin:           -2.5 dB                               23.0 dB

Output Power:           20.0 dBm                               12.0 dBm

Attenuation:           31.0 dB                               14.0 dB

FEC ES Errors:           10                                         7650

ES Errors:           11                                         12391

SES Errors:           11                                         1149

LOSES Errors:            2                                         1829866

UES Errors:            0                                         1831146

Defect Status:                     LCD       LOM          LOF  LCD         

Last Fail Code:           None

Watchdog Counter: 0x76

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction:           0x00

Interrupts:           41549 (0 spurious)

PHY Access Err:           0

Activations:           34

LED Status:           OFF

LED On Time:           0

LED Off Time:           0

Init FW:           init_AMR-4.0.015_no_bist.bin

Operation FW:           AMR-4.0.015.bin

FW Source:           embedded

FW Version:           4.0.15

                      DS Channel1            DS Channel0          US Channel1            US Channel0

Speed (kbps):                    0                  9530                   0                   448

DS User cells:                    0                     1

US User & Idle cells:                                                  0                 17256

Reed-Solomon EC:          0                   399                   0                 45634

CRC Errors:                    0                   407                   0                 62813

Header Errors:                    0                     1                   0                174882

Total BER:                      0E-0                     65535E-255

Leakage Average BER:            0E-0                     65535E-255

Not able to get Interleave delay information since the training

log collection is going on. Turn off the training log collection

or wait for few seconds till the log collection is completed.

ATU-R (DS)          ATU-C (US)

Bitswap:                 enabled                      enabled

LOM Monitoring : Disabled

DMT Bits Per Bin

Not able to collect DMT bin information since the training

log collection is going on. Turn off the training log collection

or wait for few seconds till the log collection is completed.

DSL: Training log buffer capability is not enabled


WIC-1ADSL

Cisco1841#show dsl int atm 0/0/0

ATM0/0/0

Alcatel 20150 chipset information

                ATU-R (DS)                      ATU-C (US)

Modem Status:    Showtime (DMTDSL_SHOWTIME)

DSL Mode:        ITU G.992.1 (G.DMT) Annex A

ITU STD NUM:     0x01                            0x1

Vendor ID:       '    '                          'TSTC'

Vendor Specific: 0xDBB0                          0x0510

Vendor Country:  0x04                            0xB5

Capacity Used:   99%                             56%

Noise Margin:    10.5 dB                         20.0 dB

Output Power:    20.0 dBm                        12.0 dBm

Attenuation:     30.0 dB                         16.5 dB

FEC ES Errors:    0                               0

ES Errors:        0                               0

SES Errors:       0                               0

LOSES Errors:     0                               0

UES Errors:       0                               0

Defect Status:   None                            None

Last Fail Code:  None

Watchdog Counter: 0x56

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction:     0x15

Interrupts:      1327 (0 spurious)

PHY Access Err:  0

Activations:     1

LED Status:      ON

LED On Time:     100

LED Off Time:    100

Init FW:         ASW_init_3_8_131.bin

Operation FW:    ASW_R3_8_131.bin

FW Source:       embedded

FW Version:      3.8.131

                 Interleave             Fast    Interleave              Fast

Speed (kbps):          6144                0           448                 0

DS User cells:       158587                0

US User & Idle cells:                                344951                0

Reed-Solomon EC:          0                0             0                 0

CRC Errors:               0                0             0                 0

Header Errors:            0                0             0                 0

Bit Errors:               0                0

BER Valid sec:            0                0

BER Invalid sec:          0                0

LOM Monitoring : Disabled

DMT Bits Per Bin

000: 0 0 0 0 0 0 0 2 2 3 5 7 7 7 7 7

010: 8 8 8 7 7 8 7 6 6 6 5 4 4 5 0 0

020: 0 0 0 0 0 0 8 8 8 9 9 A A A A B

030: B B B B B B B B B B B B 2 B B B

040: 0 B B A A A A A A A A A A A A A

050: A A A A A A A A A A A A A A A A

060: A A A A A A A A A A A A A 9 A A

070: 9 9 9 9 9 9 9 9 9 9 8 9 9 8 9 9

080: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8

090: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8

0A0: 8 8 8 8 8 8 8 7 8 8 8 7 8 8 7 7

0B0: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7

0C0: 7 7 7 6 7 7 6 7 7 7 7 6 6 7 6 6

0D0: 6 6 6 5 6 6 7 6 7 6 7 6 6 6 6 6

0E0: 6 6 6 6 6 6 6 6 6 6 6 6 6 6 6 5

0F0: 5 4 4 4 2 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled

Cisco1841# show dia

Cisco1841# show da

Cisco1841# show dia

Cisco1841# show atm

Cisco1841# show atm 0/0/0

                    ^

% Invalid input detected at '^' marker.

Cisco1841#show int atm 0/0/0

ATM0/0/0 is up, line protocol is up

  Hardware is DSLSAR (with Alcatel ADSL Module), address is 001f.6ca2.5d1c (bia 001f.6ca2.5d1c)

  MTU 4470 bytes, sub MTU 4470, BW 448 Kbit/sec, DLY 1140 usec,

     reliability 193/255, txload 1/255, rxload 59/255

  Encapsulation ATM, loopback not set

  Keepalive not supported

  Encapsulation(s): AAL5 AAL2

  23 maximum active VCs, 256 VCs per VP, 1 current VCCs

  VC Auto Creation Disabled.

  VC idle disconnect time: 300 seconds

  Last input never, output 00:00:01, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: Per VC Queueing

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     6021 packets input, 7387757 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     4197 packets output, 1041558 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

Cisco1841# show int dai

Cisco1841# show int dia

Cisco1841# show int dialer 0

Dialer0 is up, line protocol is up (spoofing)

  Hardware is Unknown

  Description: DSL Connection

  Internet address is 82.69.X.X/32

  MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 255/255

  Encapsulation PPP, LCP Closed, loopback not set

  Keepalive set (10 sec)

  DTR is pulsed for 1 seconds on reset

  Interface is bound to Vi2

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 00:06:44

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 7

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/0/16 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 42 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     5980 packets input, 7362934 bytes

     4192 packets output, 1024913 bytes

Bound to:

Virtual-Access2 is up, line protocol is up

  Hardware is Virtual Access interface

  MTU 1492 bytes, BW 448 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 55/255

  Encapsulation PPP, LCP Open

  Stopped: CDPCP

  Open: IPCP

  PPPoATM vaccess, cloned from Dialer0

  Vaccess status 0x44

  Bound to ATM0/0/0 VCD: 1, VPI: 0, VCI: 38, loopback not set

  Keepalive set (10 sec)

  DTR is pulsed for 5 seconds on reset

  Interface is bound to Di0 (Encapsulation PPP)

  Last input 00:00:08, output never, output hang never

  Last clearing of "show interface" counters 00:06:20

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     6024 packets input, 7364381 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     4202 packets output, 1025101 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

Cisco1841#


Everyone's tags (3)
4 REPLIES 4
Hall of Fame Master

HWIC-1ADSL Problems - Cisco 1841

You need to upgrate ADSL firmware. To download it, you will need a support contract.

Beginner

HWIC-1ADSL Problems - Cisco 1841

Sorry about the delayed reply, using the new firmware has made no difference. For reference its 4.0.18 I tested. I have swapped the HWIC card out for a normal ADSL modem which is working fine now.

Beginner

HWIC-1ADSL Problems - Cisco 1841

Well I have been facing the same problem with different version of IOS in 2811 router. So I have restored the old version of IOS then waited for the new version of IOS. cisco introduced 15.1.4M which isstable. you can upgrade to this verison.

Beginner

Re: HWIC-1ADSL Problems - Cisco 1841

I also have problem with HWIC, its just lost connection. It was workning fine but now it can not establish connection to ISP.

Here are HWIC info and router info:

router#sh dsl int ?

  ATM  ATM interface

  |    Output modifiers

 

router#sh dsl int

ATM0/0/0

Alcatel 20150 chipset information

Line not activated: displaying cached data from last activation

                ATU-R (DS)                      ATU-C (US)

Modem Status:    Showtime (DMTDSL_DO_OPEN)

DSL Mode:        ITU G.992.1 (G.DMT) Annex A

ITU STD NUM:     0x01                            0x1

Vendor ID:       '    '                          'BDCM'

Vendor Specific: 0xDBB0                          0x6193

Vendor Country:  0x04                            0xB5

Capacity Used:   83%                             94%

Noise Margin:    13.0 dB                          6.0 dB

Output Power:    20.0 dBm                        12.0 dBm

Attenuation:     19.5 dB                          9.0 dB

Defect Status:                  LCDi         None

Last Fail Code:  Handshake or init message invalid or had bad CRC

Watchdog Counter: 0x89

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction:     0x15

Interrupts:      2879 (0 spurious)

PHY Access Err:  0

Activations:     16

LED Status:      OFF

LED On Time:     100

LED Off Time:    100

Init FW:         ASW_init_3_8_131.bin

Operation FW:    ASW_R3_8_131.bin

FW Source:       embedded

FW Version:      3.8.131

                 Interleave             Fast    Interleave              Fast

Speed (kbps):          8160                0           960                 0

Cells:                    0                0           813                 0

Reed-Solomon EC:          0                0             0                 0

CRC Errors:               0                0             0                 0

Header Errors:            0                0             0                 0

Bit Errors:               0                0

BER Valid sec:            0                0

BER Invalid sec:          0                0

LOM Monitoring : Disabled

DMT Bits Per Bin

000: 0 0 0 0 0 0 0 5 8 A B B B C D D

010: D D D D D D D C C B B B B B 0 0

020: 0 0 0 0 0 0 6 7 8 8 9 9 A A A B

030: B B B B B C C C C C C C C B B C

040: B C C B C C B B C C C C C C C C

050: C C C C C C C C C C C C C C C 2

060: C C C B C C B B B B B B B B B B

070: B B B B B B B B B B B B B B B B

080: B B B B B B B B B B A A B A A B

090: A B B B A A A A A A A A A A A A

0A0: A A A A A A A A A A A A A A A A

0B0: A A A A 9 9 A 9 9 9 9 9 9 9 9 9

0C0: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9

0D0: 9 9 9 9 9 9 8 8 8 8 8 8 8 8 8 8

0E0: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8

0F0: 8 8 8 8 8 8 7 7 7 7 7 6 6 6 5 5

DSL: Training log buffer capability is not enabled

On same line other adsl router works but not HWIC.


CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards