cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
140
Views
0
Helpful
2
Replies
Highlighted
Beginner

IBGP to EBGP unable to ping

design.jpg

I'm trying to ping R4 from R1(and vice versa) but I am completely stuck and clueless what to do next. 
R2---EBGP---R4

R3---EBGP---R4

R1 and R5 is acting like a Core from a LAN network using loopback. I can ping R1 from R5 and vice versa. Can anyone help me point on what I am doing wrong, please?

And also, what's the best way to make 172.16.17.4 the primary path when going to R1/R5 from R4?

 

R1

interface Loopback0
ip address 10.7.1.1 255.255.255.0
ip ospf network point-to-point
!
interface GigabitEthernet0/0
ip address 10.255.0.52 255.255.0.0
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 10.7.5.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
ip address 10.7.6.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router ospf 1
router-id 10.7.1.1
network 10.7.1.1 0.0.0.0 area 0
network 10.7.5.1 0.0.0.0 area 0
network 10.7.6.1 0.0.0.0 area 0

 

R2

interface GigabitEthernet0/1
ip address 10.7.5.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
ip address 10.7.7.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
description Head Office R1->Service Provider
ip address 172.16.17.5 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router ospf 1
network 10.7.5.2 0.0.0.0 area 0
network 10.7.7.2 0.0.0.0 area 0
!
router bgp 65007
bgp log-neighbor-changes
network 10.7.1.0 mask 255.255.255.0
network 10.8.1.0 mask 255.255.255.0
neighbor 172.16.17.6 remote-as 4700
neighbor 172.16.17.6 route-map PRIMARYPATH in
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 172.16.17.0 255.255.255.0 Null0
!
!
route-map PRIMARYPATH permit 10
set local-preference 150

R3

interface GigabitEthernet0/2
description Head Office R2->Core
ip address 10.7.6.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/4
description Head Office R2->Service Provider
ip address 172.16.17.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router ospf 1
network 10.7.6.2 0.0.0.0 area 0
!
router bgp 65007
bgp log-neighbor-changes
network 10.7.1.0
network 10.7.1.0 mask 255.255.255.0
neighbor 172.16.17.2 remote-as 4700
neighbor 172.16.17.2 route-map SECONDARYPATH in
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 172.16.17.0 255.255.255.0 Null0
!
!
route-map SECONDARYPATH permit 10
set local-preference 125

 

R4

interface GigabitEthernet0/3
description Service Provider -> Head Office R1
ip address 172.16.17.6 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/4
description Service Provider -> Head Office R2
ip address 172.16.17.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/5
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/6
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
router bgp 4700
bgp log-neighbor-changes
network 172.16.17.0 mask 255.255.255.252
network 172.16.17.4 mask 255.255.255.252
neighbor 172.16.17.1 remote-as 65007
neighbor 172.16.17.1 default-originate
neighbor 172.16.17.5 remote-as 65007
neighbor 172.16.17.5 default-originate
!

 

R5 

interface Loopback0
ip address 10.8.1.1 255.255.255.0
ip ospf network point-to-point
!
interface GigabitEthernet0/2
ip address 10.7.7.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router ospf 1
router-id 10.8.1.1
network 10.7.7.1 0.0.0.0 area 0
network 10.8.1.1 0.0.0.0 area 0
!

 

R4 show ip bgp

Network Next Hop Metric LocPrf Weight Path
0.0.0.0 0.0.0.0 0 i
* 10.7.1.0/24 172.16.17.5 2 0 65007 i
*> 172.16.17.1 2 0 65007 i
*> 10.8.1.0/24 172.16.17.5 2 0 65007 i
*> 172.16.17.0/30 0.0.0.0 0 32768 i
*> 172.16.17.4/30 0.0.0.0 0 32768 i

R4 show ip route

10.0.0.0/24 is subnetted, 2 subnets
B 10.7.1.0 [20/2] via 172.16.17.1, 00:44:05
B 10.8.1.0 [20/2] via 172.16.17.5, 00:44:04
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.17.0/30 is directly connected, GigabitEthernet0/4
L 172.16.17.2/32 is directly connected, GigabitEthernet0/4
C 172.16.17.4/30 is directly connected, GigabitEthernet0/3
L 172.16.17.6/32 is directly connected, GigabitEthernet0/3

 

Everyone's tags (4)
2 REPLIES 2
VIP Mentor

Re: IBGP to EBGP unable to ping

You need to redistribute BGP into OSPF, otherwise R1 does not know how to get to R4...
VIP Advisor

Re: IBGP to EBGP unable to ping

Hello

1- redistribute a default into ospf from bgp/ospf rtrs based on the default your bgp rtrs are receiving from R4

 

2) create an ibgp connection between r2 -r3 this will then allow you to use the local preference you have setup 

 

3) In r4 set default weight preference to both ebgp links with a higher metric given to 172.16.17.4/30 link

 

Lasty FYI

R2-R5 10.7.7.0/30 shows it’s in area0 not area1 as your topology is showing 

 

res

paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards