cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1690
Views
190
Helpful
32
Replies

IGP Redistributed routes not redistributed into BGP

Kenneth Goh
Level 1
Level 1

KennethGoh_0-1645537349037.jpeg

R1 fa0/0 and R3 fa0/1 are OSPF neighbors
R1 fa0/1, R2 and R3 fa1/0 are EIGRP neighbors
R3 fa0/0 and R4 are iBGP neighbors
Redistribution only happens between:

  1. OSPF and EIGRP on R1
  2. EIGRP and BGP on R3
    Without redistribution between OSPF and BGP, is there a way for R4 is learn 192.168.13.0/24 routes and R1 to learn 10.1.1.0/24 routes

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.12.0/24 is directly connected, FastEthernet0/1
C 192.168.13.0/24 is directly connected, FastEthernet0/0
D 192.168.23.0/24 [90/30720] via 192.168.12.2, 00:33:41, FastEthernet0/1
D EX 192.168.34.0/24 [170/2565376] via 192.168.12.2, 00:09:54, FastEthernet0/1

 

R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

B 192.168.12.0/24 [200/30720] via 192.168.23.2, 00:23:41
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/1
B 192.168.23.0/24 [200/0] via 192.168.34.3, 00:23:46
C 192.168.34.0/24 is directly connected, FastEthernet0/0

 

Redistribution on R1

router eigrp 100
redistribute ospf 1 metric 100000 1 255 1 1500
network 192.168.12.0
no auto-summary
!
router ospf 1
log-adjacency-changes
redistribute eigrp 100 subnets

 

Redistribution on R3

router eigrp 100
redistribute bgp 64512 metric 100000 1 255 1 1500
network 192.168.23.0
no auto-summary
!
router ospf 1
log-adjacency-changes
!
router bgp 64512
no synchronization
bgp log-neighbor-changes
network 192.168.34.0
redistribute eigrp 100
neighbor 192.168.34.4 remote-as 64512
no auto-summary

32 Replies 32

....

Sorry I was out so I make fast review, 
NOW 
R3 have two 192.168.13.0 one is direct connect and other is via EIGRP redistribute to iBGP,
the BGP must be valid before R3 send iBGP to R4 BUT 192.168.13.0 is not valid "do check the show ip bgp you must see letter "r" with this subnet.
so it not valid and R4 not learn it from R3.
also please see "this remove" in red color please do this change.
lgjdflgdfll.png

How we can solve this ??
We can test this case by shut down the 192.168.13.0 interface in R3 and see if R4 get it from R3 since R3 now valid the route and can iBGP it to R4.

Before shut down the 192.168.13.0 interface on R3:

R3#sh ip bgp
BGP table version is 935, local router ID is 192.168.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*>i10.1.1.0/24 192.168.34.4 0 100 0 i
*> 192.168.12.0 192.168.23.2 30720 32768 ?
*> 192.168.23.0 0.0.0.0 0 32768 ?

 

Indeed shut down the 192.168.13.0 interface on R3, the route is learn on R4. Any solution to resolve this? 

R4#show ip route | in 192.168.13.0/24
B 192.168.13.0/24 [200/2565376] via 192.168.23.2, 00:00:39

R4#sh ip bgp | b Network
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 0.0.0.0 0 32768 i
*>i192.168.12.0 192.168.23.2 30720 100 0 ?
*>i192.168.13.0 192.168.23.2 2565376 100 0 ?
*>i192.168.23.0 192.168.34.3 0 100 0 ?

1- if you use gns3 try use different router model

2-try bgp suppress-inactive 

In the first place R3 did not show any BGP rib failure.

R3#sh ip bgp rib-failure
Network Next Hop RIB-failure RIB-NH Matches

Hello,

 

post the full running configurations if R1 and R3 again, as it is unclear what you have currently configured...

R1#sh run
Building configuration...

Current configuration : 1244 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
interface FastEthernet0/0
ip address 192.168.13.1 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
redistribute ospf 1 metric 1000 1 255 1 1500
network 192.168.12.0
no auto-summary
!
router ospf 1
log-adjacency-changes
redistribute eigrp 100 subnets

R3#sh run
Building configuration...

Current configuration : 1506 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
ip address 192.168.34.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.13.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.23.3 255.255.255.0
duplex half
!
router eigrp 100
redistribute bgp 64512 metric 100000 1 255 1 1500
network 192.168.23.0
no auto-summary
!
router ospf 1
log-adjacency-changes
!
router bgp 64512
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
redistribute eigrp 100
neighbor 192.168.34.4 remote-as 64512
neighbor 192.168.34.4 next-hop-self
no auto-summary

Hello,

 

make the changes/additions marked in bold:

 

R1#sh run
Building configuration...

Current configuration : 1244 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
interface FastEthernet0/0
ip address 192.168.13.1 255.255.255.0
--> no ip ospf network point-to-point
--> no ip ospf 1 area 0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
--> no redistribute ospf 1 metric 1000 1 255 1 1500
--> default-metric 1000 33 255 1 1500
network 192.168.12.0
--> redistribute ospf 1
no auto-summary
!
router ospf 1
log-adjacency-changes
--> network 192.168.13.0 0.0.0.255 area 0
redistribute eigrp 100 subnets


R3#sh run
Building configuration...

Current configuration : 1506 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
ip address 192.168.34.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.13.3 255.255.255.0
--> no ip ospf network point-to-point
--> no ip ospf 1 area 0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.23.3 255.255.255.0
--> duplex full
!
router eigrp 100
redistribute bgp 64512 metric 100000 1 255 1 1500
network 192.168.23.0
no auto-summary
!
router ospf 1
log-adjacency-changes
--> network 192.168.13.0 0.0.0.255 area 0
!
router bgp 64512
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
redistribute eigrp 100
neighbor 192.168.34.4 remote-as 64512
--> no neighbor 192.168.34.4 next-hop-self
no auto-summary

This not real, so there is some bug.

No rib in bgp, the definition of rib is that path is best select but not install in routing table becuase there best ad in table "in your case it direct connect".

Now we can do more check by clear bgp and see if show ip bgp give for this route "r".

I change a model to CSR1000v router. Same show ip bgp result shown below after applying bgp suppress-inactive.

R3#show run | sec router bgp
router bgp 64512
bgp log-neighbor-changes
bgp redistribute-internal
redistribute eigrp 100
neighbor 192.168.34.4 remote-as 64512
neighbor 192.168.34.4 next-hop-self

 

R3#show ip bgp | b Network
Network Next Hop Metric LocPrf Weight Path
r>i 10.1.1.0/24 192.168.34.4 0 100 0 i
*> 192.168.12.0 192.168.23.2 28416 32768 ?
*> 192.168.23.0 0.0.0.0 0 32768 ?

 

R3#show ip bgp rib-failure
Network Next Hop RIB-failure RIB-NH Matches
10.1.1.0/24 192.168.34.4 Higher admin distance n/a

 

R4#sh ip bgp | b Network
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 0.0.0.0 0 32768 i
*>i192.168.12.0 192.168.34.3 28416 100 0 ?
*>i192.168.23.0 192.168.34.3 0 100 0 ?

One of them

Either change model or bgp suppress .

You change the model check the r4 without add bgp suppress 

 

Can i see show ip bgp and show ip route after change model 

just I need full config for router and show of 
show ip bgp R3
show ip route R3
show ip bgp R4

Still showing the same result. Currently R3 & R4 are CSR1000v routers. bgp suppress-inactive is only applied on R3.

3#show ip bgp | b Network
Network Next Hop Metric LocPrf Weight Path
r>i 10.1.1.0/24 192.168.34.4 0 100 0 i
*> 192.168.12.0 192.168.23.2 28416 32768 ?
*> 192.168.23.0 0.0.0.0 0 32768 ?
R3#show ip route | b Gateway
Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets
B 10.1.1.0 [200/0] via 192.168.34.4, 00:00:04
D 192.168.12.0/24 [90/28416] via 192.168.23.2, 00:21:55, GigabitEthernet2
192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.13.0/24 is directly connected, GigabitEthernet1
L 192.168.13.3/32 is directly connected, GigabitEthernet1
192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.23.0/24 is directly connected, GigabitEthernet2
L 192.168.23.3/32 is directly connected, GigabitEthernet2
192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.34.0/24 is directly connected, GigabitEthernet3
L 192.168.34.3/32 is directly connected, GigabitEthernet3

 

R4#sh ip bgp | b Network
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 0.0.0.0 0 32768 i
*>i 192.168.12.0 192.168.34.3 28416 100 0 ?
*>i 192.168.23.0 192.168.34.3 0 100 0 ?

 

R3#show run
hostname R3
!
interface GigabitEthernet1
ip address 192.168.13.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet2
ip address 192.168.23.3 255.255.255.0
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet3
ip address 192.168.34.3 255.255.255.0
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet4
no ip address
shutdown
negotiation auto
no mop enabled
no mop sysid
!
!
router eigrp 100
network 192.168.23.0
redistribute bgp 64512 metric 1000 1 255 1 1500
!
router ospf 1
!
router bgp 64512
bgp log-neighbor-changes
bgp redistribute-internal
bgp suppress-inactive
redistribute eigrp 100
neighbor 192.168.34.4 remote-as 64512
neighbor 192.168.34.4 next-hop-self

 

R4#show run
hostname R4

interface GigabitEthernet1
ip address 192.168.34.4 255.255.255.0
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet2
ip address 10.1.1.4 255.255.255.0
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet3
no ip address
shutdown
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet4
no ip address
shutdown
negotiation auto
no mop enabled
no mop sysid
!
router bgp 64512
bgp log-neighbor-changes
network 10.1.1.0 mask 255.255.255.0
neighbor 192.168.34.3 remote-as 64512

 

can I see in R3 
show ip eigrp topology ?

R3#show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.34.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 192.168.23.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet2
P 192.168.12.0/24, 1 successors, FD is 28416
via 192.168.23.2 (28416/28160), GigabitEthernet2
P 192.168.13.0/24, 0 successors, FD is Infinity
via 192.168.23.2 (2563072/2562816), GigabitEthernet2
P 10.1.1.0/24, 1 successors, FD is 2560256
via Redistributed (2560256/0)

Review Cisco Networking products for a $25 gift card