cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
928
Views
5
Helpful
3
Replies
iccuCisco
Beginner

Inconsistent Address & Mask P2P T1

I have a P2P T1 between locations, each router have two ethernet interfaces, one interface is configured for communitcations between locations for our phone system.  What I am trying to achive here is to use the second interface on each router for data traffic.  I have for the phones interface configured with IP's 10.x.x.x with static routes set which works without issue, now when I configure the second interface with IP's 172.x.x.x and attempt to create a static route from one side to the other i receive the following error "inconsistent address & mask" I have even attempted to change the subnet mask to another value without success.

1 ACCEPTED SOLUTION

Accepted Solutions
Peter Paluch
Hall of Fame Cisco Employee

Stephen,

This looks like a typo in your ip route command. What exact network address and netmask are you using?

Best regards,

Peter

View solution in original post

3 REPLIES 3
Peter Paluch
Hall of Fame Cisco Employee

Stephen,

This looks like a typo in your ip route command. What exact network address and netmask are you using?

Best regards,

Peter

View solution in original post

Peter you were right there was a typo, i was trying to route from IP to IP and used the subnet 255.255.255.0 instead of 255.255.255.255 this was the issue, my mistake was I wanted to create a static route from network to network and thus would use 255.255.255.0. 

Thank you,

Stephen

Richard Burts
Hall of Fame Guru

Stephen

There is not enough information here to allow us to determine what is the problem. Posting the specific static route would be a good start.

From the symptom my first guess would be that your route has a host specific address with a mask for a subnet. But without seeing the route specifics it is only a guess.

HTH

Rick

Sent from Cisco Technical Support iPad App

HTH

Rick