cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1324
Views
5
Helpful
7
Replies

Iner vlan

Shivu b
Beginner
Beginner

Hello All,

 

I have two L3 interface vlans, Vlan 20 - Wired user and Vlan 30 on L3 same switch. SVI created on Router.

On Router interface Gi 0/1 - Wired subnet configured and wireless subnet address configured on sub interface Gi 0/1.30

 

when wired user transfer file to wireless user or vice versa, traffic pass via physical interface of Router.

but this would consume traffic on WAN, even traffic is locally and but crossing L3 boundary

to prevent traffic should we remove sub interface of wireless user subnet and advt network under Eigrp ?

 

and is there any difference in advt dynamic Route on Router and having sub interface ? ex: Is it reduce switch process , Memory, fast convergence

7 Replies 7

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

what device model and what is version of code running.

 

yes if the SVI interface Located in router, traffic travese all the way to Gateway and move to other L3 network.(unlike L2 connect each other in same domain)

 

this is normal, if this impacting performance of your Internet Router, you need go higher model to support the traffic, or offload the config to Lan level on other device ?

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

paul driver
VIP Expert VIP Expert
VIP Expert

Hello
If the switch is L3 capable, you could let the switch perform the intervlan routing and not the router.

Have additional SVI on the switch for the router interconnection or even just a routed port with a default route towards this router or a dynamic routing protocol for any egress traffic, Howerver all this does depend on the resources of the hardware you have running and the amount of traffic etc...


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello Paul,

 

Thanks for your reply,

 

I do create SVI on switch iteself, but if these vlans to be accessible across global our sites then should be advt under dynamic Routing protocol or set it under sub interface of Router either.

 

Hello


@Shivu b wrote:

I do create SVI on switch iteself, but if these vlans to be accessible across global our sites then should be advt under dynamic Routing protocol or set it under sub interface of Router either.

 


When you say accessible across global sites do you mean these vlans are extended across sites (L2 mpls vpn)?.

 

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello Paul,

 

Vlan's are not extended, these IP's should be accessible across all sites. between Router we use static Routes and we use dynamic Routing protocol for Router management vlan only and not user vlan,

example below,

IP Routing enabled on L3 switch.

ex: int vlan 20

IP address 192.168.20.5 255.255.255.0

no shut

 

int vlan 30

IP address 172.21.30.5 255.255.255.0

no shut

ip route 0.0.0.0 0.0.0.0 192.168.20.1

 

interface GigabitEthernet0/1
description  customer LAN
ip address 192.168.20.1 255.255.255.0

 

interface GigabitEthernet0/1.30

desc vlan 30
encapsulation dot1Q 30
ip address 172.21.30.1 255.255.255.0

 

20.1 is default gateway on systems, if vlan 30 user transfer files too vlan 20 or vice versa, Bandwidth consuming on ciricuit, to avoid

should i keep gateway IP as vlan IP on systems? or should i remove sub interface and build dynamic Routing on Router?

Hello
I would suggest keep it on the switch that way inter-vlan traffic shouldnt go via the rtr but the switch, the only time it will touch the rtr is when your users from either vlan need to exit the LAN.

However to do that you need to change the ip address on your rtrs lan facing interface:

Options

1) Change the rtrs ip address from 192.168.20.1 to 192.168.20.X
2) Change the rtrs ip address to a new address subnet created from a new SVI vlan on the switch and assign the switch/router interconnect to this new vlan
3) Create a routed port on the switch a new address subnet for the rtrs lan facing interface assign the switch/router interconnect to this new subnet <--- most applicable
4) Change the vlan 20 users default gateway to that of switch SVI vlan 20

Example:
Switch
int x/x
description Link to rtr
no switchport
ip address 172.16.1.2 255.255.255.252
no shut

int vlan 20
IP address 192.168.20.1 255.255.255.0

no ip route 0.0.0.0 0.0.0.0 192.168.20.1
ip route 0.0.0.0 0.0.0.0 172.16.1.1

router
description Link to switch
ip address 172.16.1.1 255.255.255.252
no shut

ip route 172.21.30.0 255.255.255.0 172.16.1.2
ip route 192.168.20.0 255.255.255.0 172.16.1.2

Lastly advertise these statics via your dyanmic routing


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello Paul,

 

Thank you for detail explanation.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: