cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1342
Views
5
Helpful
17
Replies
Beginner

Interface down/down issue.

Hi everyone.

I'm having some problems with an interface of my cisco router, actually, with any interface.

I have 2 internet connections in the place where the router is, one with DHCP and the other with static public IP address. When I connect the router to the public IP, te interface goes Status down, protocol down, when I connect it to the DHCP connection everything it's up, the interface works and my router goes to internet, not even the led indicator it's on with the public IP connection.

When I connect my computer to the port of the public IP, it has Internet access and everything works correctly, the problem is only when it is connected to the router, everything goes down as if it were a physical problem or something like that, but as I mentioned, DHCP works with the same patch cord.

 

Thanks for reading!

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor

Re: Interface down/down issue.

When you connected to laptop what speed you see on the laptop.

 

Suggest to default the interface and connect and see that the interface come up, once that is success you can configure switch post.

 

Do you have any config other side ? rukush side how the port configured ?

 

 

BB
*** Rate All Helpful Responses ***
17 REPLIES 17
VIP Advisor

Re: Interface down/down issue.

Hello


@tresdeasada wrote:

Hi everyone.

When I connect the router to the public IP, te interface goes Status down, protocol down, when I connect it to the DHCP connection everything it's up, the interface works and my router goes to internet, not even the led indicator it's on with the public IP connection.

When I connect my computer to the port of the public IP, it has Internet access and everything works correctly,!


 

Do you have the router interface hard coded ( speed/duplex)
What is the device your connecting the router to - you may require a cross-over cable?



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Interface down/down issue.

Both interfaces are hard coded and both interfaces goes to the same Rukus Switch.

I was thinking the same thing about the cable, only I do not have one on hand, maybe I should try with that.

Hall of Fame Master

Re: Interface down/down issue.

Can you post the configuration of both interfaces? Also please post the output of show interface for the two interfaces.

 

HTH

 

Rick

Beginner

Re: Interface down/down issue.

G0/2 is the interface connected to Public IP

G0/0 is the interface connected to DHCP

 

GigabitEthernet0/2 is down, line protocol is down
Hardware is CN Gigabit Ethernet, address is 1c6a.7a17.5662 (bia 1c6a.7a17.5662)
Internet address is 45.235.173.164/27
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto Duplex, Auto Speed, media type is RJ45
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 02:07:07, output 02:07:15, output hang never
Last clearing of "show interface" counters 00:01:59
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 

interface GigabitEthernet0/2
ip address 45.235.173.164 255.255.255.224
ip flow monitor FNFnbarMON input
ip flow monitor FNFnbarMON output
ip virtual-reassembly in
duplex auto
speed auto

 

GigabitEthernet0/0 is up, line protocol is up
Hardware is CN Gigabit Ethernet, address is 1c6a.7a17.5660 (bia 1c6a.7a17.5660)
Internet address is 10.213.100.61/23
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1Gbps, media type is RJ45
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 194
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1702000 bits/sec, 171 packets/sec
5 minute output rate 80000 bits/sec, 92 packets/sec
14688361 packets input, 4287394085 bytes, 0 no buffer
Received 300477 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
3737 input errors, 0 CRC, 0 frame, 3737 overrun, 0 ignored
0 watchdog, 14440 multicast, 0 pause input
8688838 packets output, 1528552179 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
14440 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
13 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 

interface GigabitEthernet0/0
ip address dhcp
ip flow monitor FNFnbarMON input
ip flow monitor FNFnbarMON output
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto

VIP Advisor

Re: Interface down/down issue.

What is the results if you connect to GigabitEthernet0/2 to laptop back to back is the port come up.

 

In this case what is the ISP side end device ? 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Interface down/down issue.

If I connect mi laptop to G0/2, the interface goes up, G0/2 works, it goes down only when I connect it to the Public IP port. That port goes to a Ruckus switch.

VIP Advisor

Re: Interface down/down issue.

what happends when you connect latop configured with static IP and connect to ISP Ruckus switch and is that working ?

 

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Interface down/down issue.

That's correct, it works, when I configured the Public IP on my laptop and connect to Ruckus switch I have internet.

The problem is when I connect that precisely port (The IP public port) to my cisco router. So, the port to Ruckus works, mi cisco interface works, the problem happens when I connect them. Cisco Int <--> Ruckus

VIP Advisor

Re: Interface down/down issue.

When you connected to laptop what speed you see on the laptop.

 

Suggest to default the interface and connect and see that the interface come up, once that is success you can configure switch post.

 

Do you have any config other side ? rukush side how the port configured ?

 

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Interface down/down issue.


I checked the speed on my laptop, 100Mbps, I was configuring in speed auto and at 1Gbps the router interface. It was just a matter of putting the interface with the speed that marked my lapton and the interface went up.

 

I did not check the ruckus parameters because I do not have access to them, it is part of the network of the building where my office is located and my task was to configure an internal router with output to that Ruckus switch.

Thank you very much for the help!

Highlighted
Enthusiast

Re: Interface down/down issue.

There's a disparity between your comment that the interfaces are hard-coded and the configuration you posted.

 

From Gi0/0 - Hard-Coded

GigabitEthernet0/0 is up, line protocol is up
Hardware is CN Gigabit Ethernet, address is 1c6a.7a17.5660 (bia 1c6a.7a17.5660)
Internet address is 10.213.100.61/23
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1Gbps, media type is RJ45

 

 

From Gi0/2 - Auto

GigabitEthernet0/2 is down, line protocol is down
Hardware is CN Gigabit Ethernet, address is 1c6a.7a17.5662 (bia 1c6a.7a17.5662)
Internet address is 45.235.173.164/27
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto Duplex, Auto Speed, media type is RJ45

 

Beginner

Re: Interface down/down issue.

It's hard coded now, it still does not work.

 

GigabitEthernet0/2 is down, line protocol is down
Hardware is CN Gigabit Ethernet, address is 1c6a.7a17.5662 (bia 1c6a.7a17.5662)
Internet address is 45.235.173.164/27
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1Gbps, media type is RJ45

 

Thanks for the reply!

Enthusiast

Re: Interface down/down issue.

OK. Is the Ruckus Side also hard-coded?

Could you post the following from the router:

 

1. sh ip int brief

2. sh run int gi0/0 and 0/2

3. From Ruckus switch, show running interface of the ports connected to the Cisco router.

 

For now, I assume the same cable type are used for both interfaces.

 

Thanks

Beginner

Re: Interface down/down issue.

It was a speed issue.

I did not check the ruckus parameters because I do not have access to them, it is part of the network of the building where my office is located and my task was to configure an internal router with output to that Ruckus switch.

 

GigabitEthernet0/2 is up, line protocol is up
Hardware is CN Gigabit Ethernet, address is 1c6a.7a17.5662 (bia 1c6a.7a17.5662)
Internet address is 45.235.173.164/27
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not set
Full Duplex, 100Mbps, media type is RJ45

 

THANKS FOR THE HELP!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards