cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2011
Views
0
Helpful
10
Replies

ip default-network is not working

Hi All,

Routes with * i.e. Default route is stil not appearing. I think there is a config mistake...but could not find where

router eigrp 100

network 1.0.0.0

network 10.1.0.0 0.0.255.255

network 172.16.0.0

network 192.168.12.0

network 192.168.13.0

no auto-summary

!

ip http server

!

ip route 1.0.0.0 255.0.0.0 1.1.1.0        ----->ip default-network 1.1.1.0

ip route 1.1.1.0 255.255.255.0 Null0

output::

C    192.168.12.0/24 is directly connected, Serial1/0

     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

S       1.1.1.0/24 is directly connected, Null0

S       1.0.0.0/8 [1/0] via 1.1.1.0

C    192.168.13.0/24 is directly connected, Serial1/1

D    192.168.24.0/24 [90/2172416] via 192.168.12.2, 00:25:44, Serial1/0

     172.16.0.0/24 is subnetted, 3 subnets

C       172.16.9.0 is directly connected, Loopback9

C       172.16.10.0 is directly connected, Loopback10

C       172.16.11.0 is directly connected, Loopback11

     10.0.0.0/24 is subnetted, 8 subnets

C       10.1.8.0 is directly connected, Loopback8

C       10.1.3.0 is directly connected, Loopback3

C       10.1.2.0 is directly connected, Loopback2

C       10.1.1.0 is directly connected, Loopback1

C       10.1.7.0 is directly connected, Loopback7

C       10.1.6.0 is directly connected, Loopback6

C       10.1.5.0 is directly connected, Loopback5

C       10.1.4.0 is directly connected, Loopback4

D    192.168.34.0/24 [90/2681856] via 192.168.13.2, 00:25:45, Serial1/1

D    192.168.0.0/24 [90/2297856] via 192.168.12.2, 00:25:45, Serial1/0

Any reason why its not cadidate default route.

Any assistance will be appreciated.

Cheers!

Ravi

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Master

Re: ip default-network is not working

Ravi

Assuming that your config has this command to specify the default network "ip default-network 1.1.1.0" then the biggest problem is that you have violated one of the basic requirements of default network. The default network should be a classful network (class A or B or C) and not a subnet that is known somewhere is the network. But you have given a subnet value.

I believe that there is also an issue in the way that EIGRP processes your intended default network. The purpose of having a default network/gateway of last resort is to advertise to other EIGRP neighbors that they should forward to you their traffic for unknown destinations because you can forward it. But your router learns the route as a discard route to null 0.

There are better ways to get EIGRP to advertise a default route. You could use the EIGRP summary address command on interfaces to have EIGRP advertise a default route out those interfaces. Or you could configure a static default route and redistribute the static into EIGRP.

HTH

Rick

View solution in original post

10 REPLIES 10
Hall of Fame Master

Re: ip default-network is not working

Already replied in another thread, please avoid opening duplicates.

Re: ip default-network is not working

Hi Paolo,

Please provide me the thread URL. This is not a duplicate thread.

I am working on this issue and its really taking its toll. Your assistance will be highly appreciated.

Chrees!

Ravi

Rising star

Re: ip default-network is not working

I think he is referring to the following:  (search results from the support community)

https://supportforums.cisco.com/search.jspa?peopleEnabled=true&userID=&containerType=&container=&q=ip+default-network

Hall of Fame Master

Re: ip default-network is not working

Ravi

Assuming that your config has this command to specify the default network "ip default-network 1.1.1.0" then the biggest problem is that you have violated one of the basic requirements of default network. The default network should be a classful network (class A or B or C) and not a subnet that is known somewhere is the network. But you have given a subnet value.

I believe that there is also an issue in the way that EIGRP processes your intended default network. The purpose of having a default network/gateway of last resort is to advertise to other EIGRP neighbors that they should forward to you their traffic for unknown destinations because you can forward it. But your router learns the route as a discard route to null 0.

There are better ways to get EIGRP to advertise a default route. You could use the EIGRP summary address command on interfaces to have EIGRP advertise a default route out those interfaces. Or you could configure a static default route and redistribute the static into EIGRP.

HTH

Rick

View solution in original post

Re: ip default-network is not working

Hi Rick,

It worked. But does that mean ip default-network command does not do compress it to the default classful network. Any apprent reason why it is not changing to classful subnet automatically.  or is it behavior of the default-network command.

Cheers!

Ravi

Hall of Fame Master

Re: ip default-network is not working

Ravi

I do not completely understand your message. When you say that it worked - what was it that worked? Did you use the default network command with a classful network address, did you use the summary address command, did you redistribute a static default network?

The default network was never intended to compress a subnet address to a classful network address. The default network command has always expected that the parameter configured would be the classful network address and not a subnet.

HTH

Rick

Re: ip default-network is not working

i used classful network address.

ip default-network 1.0.0.0

It caused the static route to be candidate default.

Yes that helped. I appreciate your assistance.

Cheers!

Ravi

Beginner

Re: ip default-network is not working

ip default-network is classful

use ip default-network 1.0.0.0 instead of

ip default-network 1.1.1.0

Highlighted
Cisco Employee

Re: ip default-network is not working

and do we need these statements

ip route 1.0.0.0 255.0.0.0 1.1.1.0

ip route 1.1.1.0 255.255.255.0 Null0

I assume all we need to have is a route to minor network of 1.0.0.0(1.1.1.0) in our case which has been obtained by EIGRP.

So I dont think we need the above statements

Please correct me if I  am wrong.

R.S.Karthic

Cisco Employee

Re: ip default-network is not working

I think this automatically populates while configuring your defaut-network command.

RSK

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards