cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
529
Views
0
Helpful
6
Replies
SZ1111
Beginner

IR829 AP access

Hi,

I'm having issues connecting to integrated AP in my IR829 router.

If I configure IP address on wlan-ap0 interface I can connect to the internal AP.

interface wlan-ap0
 ip address 1.1.1.1 255.255.255.255
end
IR800#service-module wlan-ap 0 session          
Trying 1.1.1.1, 2004 ... Open
Connecting to AP console, enter Ctrl-^ followed by x, 
then "disconnect" to return to router prompt

If I want to share IP address with my vlan interface I cannot connect to the AP.

Vlan99                     1.1.1.1         YES manual up                    up      
wlan-ap0                   1.1.1.1         YES TFTP   up                    up
interface wlan-ap0
 ip unnumbered Vlan99
end
IR800#service-module wlan-ap 0 session 
Trying 1.1.1.1, 2004 ... 
% Connections to that host not permitted from this terminal

I have upgraded router and AP to the latest availaible version.

Service Module is Cisco wlan-ap0
Service Module supports session via TTY line 4
Service Module is in Steady state
Service Module reset on error is disabled
Service Module heartbeat-reset is enabled
Getting status from the Service Module, please wait..
  Image path       = flash:/ap1g3-k9w7-mx.153-3.JK4/ap1g3-k9w7-mx.153-3.JK4
  System uptime    = 0 days, 0 hours, 8 minutes, 2 seconds
IR800#show version  
Cisco IOS Software, ir800 Software (ir800-UNIVERSALK9-M), Version 15.9(3)M3, RELEASE SOFTWARE (fc1)
line con 0
 stopbits 1
line 1 2
 stopbits 1
line 3
 script dialer lte
 no exec
 transport preferred none
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 4
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
 no exec
 transport preferred none
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 1/3 1/6
 transport preferred none
 transport output none
 stopbits 1
line vty 0 4
 login
 transport input none

We already have installed 25 routers with standardised configuration and we would like to keep it also on new routers.

The only difference between routers where I can connect on IP UNNUMBERED wlan-ap0 interface and the new ones is the IOS software.

 

"OLD" routers -> Version 15.7(3)M4b

"NEW" routers -> Version 15.9(3)M3

 

Thank you in advance

 

6 REPLIES 6
Georg Pauwen
VIP Expert

Hello,

 

it could be that your TCP session is hung. Issue the command:

 

show tcp brief

 

This will probably show you something like this:

 

TCB Local Address Foreign Address (state)
6353F5E8 192.168.1.1.1720 1.1.1.1.12871 SYNRCVD

 

Clear all tcb numbers listed, like this:

 

clear tcp tcb 6353F5E8

Sorry but there are no sessions established. I dont understand why is it working if I configure IP address on WLAN-AP 0, but it's not working if it shares IP (ip unnumbred).... it practicly should be the same.

 

 

I mean I can configure IP address on wlan-ap0 interface and this will solve the issues. But it's a kind of annoyance because we want to have standardized solution on all routers.

Hello,

 

odd indeed. I would delete Vlan 99 altogether, and then recreate it. I assume Vlan 99 is just for the unnumbered, and has no other functionality ? What if you use Vlan 1 instead ?

VLAN 99 is used also for the lan side (GW for the clients).

I have tested all things imagined, change vlans, delete, vlan interfaces, different IP and so on.

I tried again vlan 1 as you suggested, and the symptoms are the same. Cannot connect to AP.

 

I forgot to mention, I received yesterday 4 IR829 routers, and all have the same software and all 4 have the same issues.

So "bug" is not happening just on one specific device.

 

Currently I dont see any other way than to put static IP on the wlan-ap0 interface.

I will still use vlan 99, and some random or (1.1.1.1 255.255.255.255) IP on wlan-ap0 interface.

Hello,

 

definitely sounds like a bug (a yet undocumented one).