cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
619
Views
0
Helpful
7
Replies
Highlighted
Cisco Employee

IS-IS (CLNS) not working over GRE tunnel in IOS-XR

We are having trouble setting up an IS-IS adjacency across a GRE tunnel, whose endpoints are a couple of IOS-XRv devices.

 

The GRE tunnel is going across an MPLS cloud.

The tunnel endpoints are reachable. Actually, OSPF is working fine across the GRE tunnel.

 

Here´s the extract of the configs and I´m ataching the full configs.

 

XR1
router isis 1
is-type level-2-only
net 49.0000.0000.0011.00
address-family ipv4 unicast
metric-style wide
interface Loopback1
passive
address-family ipv4 unicast
int tunnel-ip 1113
point-to-point
address-family ipv4 unicast
int tunnel-ip 1114
point-to-point
address-family ipv4 unicast

 

XR3

router isis 1
is-type level-2-only
net 49.0000.0000.0013.00
address-family ipv4 unicast
metric-style wide
interface Loopback1
passive
address-family ipv4 unicast
int tunnel-ip 1213
point-to-point
address-family ipv4 unicast
int tunnel-ip 1113
point-to-point
address-family ipv4 unicast

 

Thank you in advance.

 

Alfonso

 

7 REPLIES 7
Highlighted

It is related to clns mtu. 

try to set lsp-mtu under router isis process configuration.

Highlighted

I agree with Evgeniy, it's likely an MTU issue. (I haven't done an IS-IS on a GRE tunnel on a XR, but I have on IOS platforms. Those generally need the MTU configured on the interface.)
Highlighted

Hi Evgeniy, thanks for the quick reply.

I just tried setting MTU to 1400 and then to 1300, but no luck. Still no adjacency.

 

RP/0/0/CPU0:XR1#sh isis neighbors
Thu Feb 28 09:43:00.003 UTC

IS-IS 1 neighbors:
System Id Interface SNPA State Holdtime Type IETF-NSF

 

Everything else looks fine, right?

 

The GRE tunnel is reachable even with an mtu of 1450 without fragmentation:

 

RP/0/0/CPU0:XR1#ping 192.168.113.13 size 1450 df-bit
Thu Feb 28 09:35:24.595 UTC
Type escape sequence to abort.
Sending 5, 1450-byte ICMP Echos to 192.168.113.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/29 ms

 

Here's the current config of one side (replicated on the other side):

 

router isis 1
is-type level-2-only
net 49.0000.0000.0011.00
log adjacency changes
lsp-mtu 1300
address-family ipv4 unicast
metric-style wide
mpls ldp auto-config
!
interface Loopback1
passive
address-family ipv4 unicast
!
interface tunnel-ip1113
point-to-point
address-family ipv4 unicast

interface tunnel-ip1114
point-to-point
address-family ipv4 unicast

Thank you.

 

Alfonso

Highlighted

Hi Alfonso,

 

I have this working perfectly well with XRv 6.1.3. You might want to run some debugs to see what is going on.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Highlighted

Well, I'm doing this with XRv 6.1.2. 

Is your IS-IS adjacency going over a GRE tunnel as well?

If so, could you please share your full config?

 

"debug isis adjacencies" is not showing anything:

 

RP/0/0/CPU0:XR1#show debug
Sat Mar 2 17:40:47.982 UTC

#### debug flags set from tty 'vty0' ####
clns events flag is ON with value 0
isis adjacencies flag is ON with value 'unfiltered'

 

Is that an indication of something?

 

Regards.

 

Alfonso

Highlighted

Apparently it's not MTU related.

Any more ideas?

Anyone?

Highlighted
VIP Mentor

Hello,

 

on a side note, when I configure the router, the system displays the message below and adjusts the MTU automatically.

 

Can you post the output of:

 

show isis interface tunnel-ip1113

 

from both sides ?

 

RP/0/0/CPU0:XR2#RP/0/0/CPU0:Mar 15 11:42:04.101 : isis[1010]: %ROUTING-ISIS-4-SNPTOOBIG : L2 SNP size 1492 too big for interface tunnel-ip1113 MTU 1476, trimmed to interface MTU